Question about Power Acoustik MOFO-15 Car Subwoofer

1 Answer

My 15 was working fine and then it just stoped working. When I go over bumps it will kick on and then off. What can cause this problem?

Posted by on

  • Ronautotech May 11, 2010

    What type of terminals does the sub have?

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

    Mentor:

    An expert who has written 3 tips or uploaded 2 video tips.

  • Expert
  • 155 Answers

Sound like you have a lose wire some wear. slammin with a 15 you gotta check all your screws every now and then LOL

Posted on May 06, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

When stoping i here a bumping noise


have your front-end checked, could be bad strut, shock-absorber, worn bushing @ control-arm, not good, unsafe, this could cause that bumping noise you hear, seek repair ASAP. avoid pot holes ! good luck

Feb 15, 2013 | 1999 Chevrolet Venture

1 Answer

Lights, windscreen whipers and inside car fan has stoped working all at the same time!


all of these devices have fuse in your kick panel (box beside gas pedal). most probably, the main wire connector in the kick panel became loose thats why all the devices failed at the same time

Jan 31, 2013 | Cars & Trucks

1 Answer

Vauxhall astra wont start


This make of car is not sold here inthe USA so we have no tech info on it. Sorry

May 27, 2012 | Vauxhall Astra Cars & Trucks

1 Answer

I have just bought my first Dt125r 2002 model. I can not kick start it and when I bump start it, it goes but no power and then cuts out after 10-15 secs


Usually this is caused by the air/fuel mixture not being optimal. Try adjusting the carburetor.

Please see the following link for an example.

http://www.youtube.com/watch?v=aUNU0G-Ofj4

If that does not work, check the spark plugs, they may be fouled.

Hope this helps!

Sep 06, 2011 | 2002 Yamaha DT 125 R

1 Answer

Odometer stopped working but the speedometer is working


I have just done some work on my ford escourt 75D
van the speedo was working perfectly fine & now its stoped working what could I have done to stop it working.

Baz

Jun 17, 2010 | 1991 Plymouth Sundance

1 Answer

04 suzuki rmz 250


Put in a new spark plug and check plug wire connections and ECM ground connections.

You probably have weak spark and when bump started the plug sparks strong enough to run the engine.

A weak battey can also cause this. Your ECM needs a minimum of 9V to work. (the ECM gives spark and timing) When kicking over, there is not enough volts to spark. When bumping over the alternator provides the extra volts to start the bike.

Hope this helps!
Rob

Sep 22, 2009 | Motorcycles

1 Answer

Going over bumps or bump roads, stearing shakes,pulls, at any speed fine after 15 min park


Please have a check at your steering rack and your shocks.

But I have a strong belief it could be your steering rack.

Rate this

Apr 15, 2009 | Toyota Tacoma Cars & Trucks

1 Answer

Is it my battery?


well this is what you should try ,,jump the car get it running
then when its warmed up take the positive lead of the battery
if the car stops the alternator is gone (thats what charges the battery) if the car runs its fine

and if u have put another new battery in it and the alternator is fine look for any broken wires earths or positives that could be making it drain so quick
and make sure your battery levels are full
hope this helps

Jul 02, 2008 | 2001 Mercury Cougar

Not finding what you are looking for?
Power Acoustik MOFO-15 Car Subwoofer Logo

Related Topics:

60 people viewed this question

Ask a Question

Usually answered in minutes!

Top Power Acoustik Car Audio & Video Experts

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

yadayada
yadayada

Level 3 Expert

75743 Answers

Jose Velazquez
Jose Velazquez

Level 2 Expert

227 Answers

Are you a Power Acoustik Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...