Question about KitchenAid KSB560 5 Speed Blender

2 Answers

Hello, My Kitchen Aid Blender KSB560MCO was working fine, but now if I push any of the operating buttons, the lights flash and the motor won't turn. I've tried unplugging it overnight, but it still won't work

Posted by on

  • 2 more comments 
  • ceclarke1 May 02, 2010

    Good Morning,



    The blades are turning fine manually - it's more that the motor isn't turning on.

  • ceclarke1 May 02, 2010

    The Blender has power, I was using it quite a bit last night, and the lights started to blink. Now it won't work, but the blades move manually if I spin them.

  • ceclarke1 May 02, 2010

    The blades turn smoothly when the blender is unplugged. When I plug it in and try pushing an operating button - all of the lights flash.

  • ceclarke1 May 02, 2010

    Thanks, I'll see what I can do.

×

2 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 2,007 Answers

See if you can get it to turn by hand. Unplug it first, and try to turn the gear that the blade goes on. It could be gummed up with something.

Posted on May 02, 2010

  • Dar
    Dar May 02, 2010

    Well, obviously you have power if the lights are coming on. I suspect the switches are wet, or dirty. Probably the best thing to do is take it apart and clean it the best you can. If it's fairly new, take it back to where you got it and have it replaced or repaired under warranty.

  • Dar
    Dar May 02, 2010

    Something is probably burnt out . A capacator, or a fuse if it has one internal, or a wire, or the motor itself. We aren't going to fix it with a keyboard. You have to take it apart.

×

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 674 Answers

Unplug the blender and try turning the blades by hand to see if the motor is lock up. If it is you're looking at a new blender.

Posted on May 02, 2010

  • Brian Niten May 02, 2010

    Does it have any burnt smell. It is possible the motor burned out.

×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Problem with soup mate,all lights flashing but nothing happening


If this is a Kitchen Aid blender with the flashing lights then you will need to remove the motor base cover and check the motor for a circuit. If it is open circuit then either replace the motor or locate the thermal fuse (under some white tape and aluminium clip on one of the field windings) and either replace or bypass fuse if it is open circuit.

May 19, 2014 | KitchenAid Kitchen Aid Kitchenaid 5-speed...

1 Answer

Why the lights on my kitchen aid baking not coming on


Check for loose connections from mains cable to PCB and from PCB to motor. Check motor for circuit continuity, it may need a new motor, it is rarely the PCB.

Jul 26, 2013 | KitchenAid Kitchen Aid Kitchenaid 5-speed...

1 Answer

Two buttons are stuck in on my kitchen aid blender.


I have been searching for an answer to this same problem. My chop and mix buttons were stuck and I was getting no power or blinking lights. After finding no help on-line, I decided to take it apart and fix myself. It was easy and it worked!
1. Take the bottom of the mixer off by removing the rubber foot pads and remove the exposed 4 screws.
2. Remove the 3 sets of wires that are attached to the inside panel with clips. Very easy to remove, just squeeze at the base of the clips and pull up.
3. Remove the 2 screws holding that panel in place and gently lift off.
4. Remove the panel found under the top panel by also removing 2 screws. When you flip this panel over you will see what operates the switches.
In my blender the black plastic nubs that push against the buttons that were stuck and got twisted off kilter so they were not resetting properly. I just put a small screwdriver in there to try and straighten them as much as possible. All of these steps will be obvious as you disassemble the blender.
5. Push on the back of the buttons that were stuck to get them unstuck before reassembling everything back together.
I was surprised how easy a fix this was and how obvious what the problem was when I opened the blender up. No soldering or fancy tools needed, just 5-10 minutes and a phillips head screwdriver!
Good luck!

May 21, 2013 | KitchenAid KSB560 5 Speed Blender

1 Answer

How do you replace a bad circuit in Kitchenaid blender KSB50B4


It is more likely the motor is faulty than the circuit board. Test the motor with a meter.

Aug 12, 2012 | KitchenAid Kitchen Aid Kitchenaid 5-speed...

1 Answer

When I turn my blender on, it runs for only a few seconds, then stops and all the lights on the panel flash on and off.


More often than not it will need the motor to be replaced, only Kitchen Aid parts will do, motors are usually unique to brands and models. Sometimes it can be the control/button panel but normally the motor.

Mar 21, 2011 | KitchenAid Kitchen Aid Kitchenaid 5-speed...

1 Answer

Ksb 560 mco 5 speed blender lights flicker a as soon as switched


My Blender Model number KSB560MCO does not run. When try to blend all of red lights come one and they blink and move around. Any suggestions what could be wrong? Appreciate any help.
Thanks

Jul 30, 2010 | KitchenAid Kitchen Aid Kitchenaid 5-speed...

1 Answer

KitchenAid Blender KSB5WH3 flashing lights how to get to the fuse


i found broken solder connections on triac on circuit board. it's the part with the cooling fingers that surround it. pencil soldered the cracked connections; now works fine.

Jun 19, 2009 | KitchenAid Kitchen Aid Kitchenaid 5-speed...

1 Answer

Kitchenaid Blender Classic


Same thing happened to me. Opened it up and along the red wire to the motor is a bass fuse. Went to the hardware store and then I replaced it. Works fine.

Apr 12, 2009 | KitchenAid Kitchen Aid Kitchenaid 5-speed...

1 Answer

Kitchen Aid blender


to see if its the Triac or just the off button perform this: connect the blender,while pressing the off button press the on button; if the blender stays on and you dont hear the relay function (Light ticky sound) maybe the off button get a broken solder point. But if the relay is functioning and there is no way to change the speed the problen is the TRIAC. This is a small piece on PCB with a heat sink

Aug 30, 2008 | KitchenAid KSB3 Classic Work Top Blender

Not finding what you are looking for?
KitchenAid KSB560 5 Speed Blender Logo

Related Topics:

197 people viewed this question

Ask a Question

Usually answered in minutes!

Top KitchenAid Blenders Experts

Appliance engineer

Level 2 Expert

87 Answers

eyecam

Level 2 Expert

87 Answers

Cindy Wells

Level 3 Expert

5100 Answers

Are you a KitchenAid Blender Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...