Question about Pool & Spa

1 Answer

My Emerald Spa Cygnus 5000 displays the FLO error consistantly. For about a week I could mess with the filter or turn the power off then on and it would start up again only to go out a few ours later. Now it does not work at all. Any ideas on what could be wrong?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 19,396 Answers

Hi.

FLO error means that there is a problem with the pressure switch(if pump is
on but no water pressure detected).

Please follow the troubleshooting below.

  • Ensure that there is enough water for the SPA to operate.
  • Check if the pump is working.
  • If pump is not working, a tech can test the pump reading volts and energizing the pump.
  • If the pump is working, check if there is anything (eg.blockage) preventing water circulation in pipes.Eventually remove the blockage.
  • If there is no blockage, check the pressure switch, and ensure that the cable is properly connected to the pressure switch.
  • Lower Set Point at 60°F and turn the pump off, then jump the two pressure switch terminals (this must be done by a technician).
  • If by jumping the pressure switch you get no error, then replace the pressure switch.
  • If the error persists, replace the SPA pack.

Regards.

Posted on May 02, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
New users get 2 Free calls (no credit card required) and instant help on almost anything you can think of (from cars to computers, appliances, handyman, and even pets).
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Lo flo pool power rp23


Clean your filter,...
... just a slight sensing of "Lower" water flow, may trigger the sensor to read not enough water flow. Also check your impeller, your skimmer baskets & the hair and lint pot basket at the pump.
If all those are confirmed as clean & clear - then you may have a faulty flow sensor.

Apr 24, 2014 | Pool & Spa

1 Answer

Circulation pump is running but FLO is displayed on panel and heat light goes out.


FLO is displayed because something has caused a reduction in water pressure through the heater. The spa control will turn the heater off when FLO is displayed to prevent a burn out.
I suggest checking the filter cartridge, the suction fittings & any valve which could be partially closed & restricting flow.
Try run the spa with out the filter cartridge if this clears the error then it is the cartridge.
If none of these work it is possible the your flow switch and/or pump is beginning to fail.
Good luck!

Mar 24, 2013 | RTO Sundance Heater Element Harness Black...

1 Answer

The FLO is lit up on my Pro-form restoration 5.1. how do i fix it?


The error code FLO indicates that there is NOT enough water flow through the system to operate the spa and make the heater turn on.
Check your spa filter by removing it. If the heat indicator comes on then you can be assured your filter is too dirty.
If the heat indicator light does NOT come on after removing the filter then you need to check the PRESSURE SWITCH by by-passing the switch and see if the heat indicator light comes on. If it comes on after jumping the two wires together that go to the pressure switch then you know you have a bad pressure switch.
Also, check the gate valves on either side of the pump to make sure they are completely up and you have good water flow.


Rod
US Parts Center
888-521-6183

Feb 06, 2013 | Pool & Spa

1 Answer

Aqua Flo Flo Master won't start on low speed


Water flow error on hot tub means low water flow. This is not enough water flow to turn the system on.
Some motors do have a start capacitor on them. you can certainly check that or take it to your local motor repair shop and they can check that for you.

Rod
US Parts Center

Jan 13, 2013 | Aqua Flo Aquaflo Flo - Master Xp2 2 Speed...

1 Answer

My spa hums for a few seconds then kicks off. No flow. lights and control display are working.


Is the shut off occuring @ the GFI? & is there an error code displayed on your topside?

If the breaker is kicking off, the best way to troubleshoot is to disconnect all components, (pumps, heater, circ, etc.) & then plug one in & turn the breaker on. repeat the process until you locate which component is tripping the breaker.. then you know whats causing the trouble

Feb 24, 2011 | Aqua Flo Aquaflo Flo Master Xp2 Spa Pump...

2 Answers

Qca Spa pumps and blower will not come on, water down to 35º f


Ken,

You need to contact a hot tub technician/engineer as you clearly have issues.

'ICE' means that the water temperature is too low and therefore the pumps will be turned on to prevent freezing within the plumbing. Depending upon the spec and settings, the heater maybe disabled during 'ICE' condition.

'ECON' is Economy Mode. If you have a mode button, keep pressing it until you see 'Stan' on the display. This will put the system back into the standard mode.

'FLO' means that there's insufficient flow of water through the heater, or non at all. 1) Check the water level - top up if low. 2) Ensure that all jets are open and flow water - if they don't you may have a pump issue. 3) Remove the filter(s) and see whether or not this clears the fault, if so clean or replace the filters.

'COOL' is displaying because the set temperature is much higher than the current water temperature.


As I mentioned at the start, you really should get someone to take a look at your hot tub. You may have a few issues that need resolving.

Regards,
Ian.
http://hottub.synthasite.com

Feb 07, 2010 | Qca Spas Majestic Series Aruba Xl Hot Tub

1 Answer

I have an appolo spa explorer model...bought it


you must have a small pump call laing if you do, air picket inside the plumbing try to turn both pump on high and wait few minutes if doesn fix try to loose the nut just a little bit with the breakers off and let the air go out. try one more time. if doesn work turn on high both pump and touch if they are working then a impeller may be broken inside one of them try to turn each one separate to find wich one as t he broken impeller.

Oct 29, 2009 | Aqua Flo Aquaflo Flo Master Xp2 Spa Pump...

1 Answer

Flo 6 showing on display panel?


DO YOU HAVE ALL THE WIRES CONNECTED? IF YES POWER MODULE MUST BE REPLACE

Jun 28, 2009 | Jandy Lite2 Lj175n 175,000 Btu Natural...

Not finding what you are looking for?
Pool & Spa Logo

Related Topics:

680 people viewed this question

Ask a Question

Usually answered in minutes!

Top Pool & Spa Experts

Jay Finke
Jay Finke

Level 3 Expert

1343 Answers

Bill Jordan

Level 2 Expert

372 Answers

David Spradling
David Spradling

Level 3 Expert

5743 Answers

Are you a Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...