Question about Audio Players & Recorders

1 Answer

I have a Technics SU-G91 amp when I turn it on the over load light lights up and I cannot get any sound from the main speakers

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Brigadier General:

    An expert that has over 10,000 points.

  • Master
  • 8,546 Answers

Disconnect the speakers and see how that works out. It's trying to tell you it senses overcurrent or a short on the output.

Posted on May 02, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Technics SU-G91... clipped out @ high volume. Disassembled, sleaned and applied new grease to heat sinks. Amp worked great for a while, clipped out and now occasionally will not light up the front dis


First off, why do you drive the amp into clipping? It's not good for amp, nor your Klipsch. We won't even mention the terrible load that Klipsch in parallel presents to your amplifier, nor the distortion. I would suggest to you, that the amp goes into thermal overload. Trying turning it down by 20-30db, and see if it stays on-line. It can be fixed, if turning it down doesn't help, it can be repaired, but not inexpensively.

Nov 27, 2014 | Technics Audio Players & Recorders

1 Answer

How do I hook up a stereo reciver to the technics su-g91


I assume you want to use the SU-G91 as a power amplifier to drive your speakers. If your receiver has connections for inserting an equalizer (may be labeled pre-amp output and power amp input), remove the jumpers between the pre-amp and the power amp, then run cables from the pre-amp to the SU-G91 inputs. You can have an equalizer between the receiver and the integrated amplifier.
If this is not available, use the recording output (for a tape recorder on older receivers). Note that the volume control on the receiver will be bypassed with this connection.

Sep 23, 2012 | Audio Players & Recorders

1 Answer

Hi I just got a Technics SU V2 amp and can't get sound from the speakers. What size speakers would suit this amp? What is the correct method to connect the speaker leads to the back of this amp,...


Being a 500W amplifier, you need to connect speakers with 300W each. The correct method to connect speakers is red terminal of speaker should be connected to red terminal of amplifier & black to black. The left side to left side speaker & right to right speaker. There may be main & remote terminals. Main speakers are the speakers at local place of the amplifier & remote for remotely placed speakers. I do have Technics SU-V85A which is somewhat similar. Enjoy! A nice piece to listen.

Oct 22, 2011 | Technics SUV500 2-Channel Amplifier

1 Answer

I have a technics su-g91 integrated amp. everything is disconected from it and the yellow over load light is on. What do I do?


hi...i have a electric guitar and i was wondering if i can conect it in my technics su-g91amp?

Nov 24, 2010 | Audio Players & Recorders

3 Answers

Technics SU-G91 OVERLOAD PROBLEM


THe amp has detected a problem and shutdown to prevent further damage. This unit has 2 amp pacs inside and one or both have failed. If you can solder, you can fix this yourself. The main amp pac is an SVI3206 and can be purchased online for about $60.

Keep me posted.
Dan

Oct 17, 2008 | Audio Players & Recorders

2 Answers

Su-g91


Have you checked the fuse in the unit?

Aug 31, 2008 | Technics SA-AX540 Receiver

2 Answers

Technics SU-G91 Left channel bad


Did you ever find the solution to the left channel issue? I have the same problem with mine.

Dec 02, 2007 | Technics SA-AX540 Receiver

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

163 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

102366 Answers

 Grubhead
Grubhead

Level 3 Expert

5020 Answers

The Knight
The Knight

Level 3 Expert

73698 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...