Question about Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum

1 Answer

I have a Kenmore upright progrssive intell clean. For some reason it isn't sucking when I use it to vacuum. When I use attachments they work fine, but when I plug the hose back in after using the attachments and turn it back on it makes a weird noise and I can feel air blowing out of the back. Can you help me resolve this problem?

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 957 Answers

You have the answer and just don't know it. You are there so keep looking. Somewhere between where the suction hose connects with the lower hose and the power-head. There is a blockage, you may need to turn the unit upside down and look there or try using a wire with a hook on one end, to extract the blockage. but something is blocking the tube from letting air and debris from traveling up the tube.

Posted on May 01, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The bottom of the vacum isn't sucking


My dyson animal seems to have a blockage in the base it makes I sucking noise then pops the sucks ion threw the wand is fine

Oct 22, 2012 | Dyson DC28 Animal Bagless Upright Vacuum

1 Answer

Manual for Kenmore Progressive Direct Drive Upright Vacuum


can some one show via picture of the location where the micro switch is where the hose attaches to the progrssive direct drive vacuum cleaner to get the start brushes rolling again,

Sep 28, 2010 | Kenmore 31913 Progressive Direct Drive...

2 Answers

My upright kenmore progressive vacuum will not suction up when using the sweeper. It will suction things when I use one of the tools. I have put in a new bag and have tried to see if anything is blocking...


I believe on the front top part of the vacuum is a cover. you need to take it off. behind it you will find at least two filters. You will need to replace the hepa filter and the other one should be like a thin black sponge, you can just wash that one.
If its not that then there are two clips on either side of the base of the vacuum. Pull those clips outwards, then lift the top off, you will see the tube that the hose attaches to. Pull the hose off and check for debris in there.
I hope that works for you.

good luck

Aug 07, 2009 | Vacuums

1 Answer

Vacuum doesn't vaccum!


Sounds like there is a clog near where the hose conects to the lower brush part.. Try to look up in there.. Under the brush there should be an opening that goes into the hose.. There might be a clog there..

Jul 08, 2009 | Bissell Upright Vacuum - The Pet Hair...

2 Answers

Loud whistling noise from back of vacuum


On the back side of most kenmore vacuums, there is an air relief diaphragm that, when the motor is sucking but there is no air flow, will pop, causing the sound you heard. check your hose for blockage, check your bag and or filter for blockage,even your attachments/wands can become lodged with debris. Often, after a few, the motor will get hot and the machine will shut down. This is a thermostat on the motor that protects it from overheating. I am quite sure that this will solve your kenmore woes, fine choice in vacuum, kenmore, tried and true. hope to have helped! Have a super, and hopefully sucking(ha ha) Sunday

Jan 03, 2009 | Kenmore 34720 Upright Vacuum

1 Answer

Vaccum has no suction


Here is what we did to fix the problem of our vacuum having no suction.
We unscrewed the three screws on the back and took the hose off of the vacuum.  Then we took the hose outside and put the water hose through the vacuum hose and turned on the water.  After about 30 second the water pushed through a dust bunny the size of a fist and a marker.  Basically, the vacuum did not have suction because the hose was clogged with dust, etc.  After reassembling the vacuum, it worked just fine.  

May 11, 2008 | Kenmore 34923 / 34925 Progressive Bagged...

2 Answers

Won't suck, just blows


it has a blockage - you will have to find it - probably in hose leading away from roller

Mar 18, 2007 | Kenmore 32734 Upright Vacuum

Not finding what you are looking for?
Kenmore 31913 Progressive Direct Drive Bagged Upright Vacuum Logo

685 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18394 Answers

kakima

Level 3 Expert

102366 Answers

yadayada
yadayada

Level 3 Expert

76109 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...