Question about Hoover SteamVac Carpet/Upholstery Deep Cleaner Vacuum

1 Answer

How do i insert the hose to the tank , so that i can use the upolstery conector.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 294 Answers

This model shown is a 5900 series. I will base my answer from this. First remove the lower tank cover, and then remove the front panel duct in front of the lower tank. Insert the hose end that looks like a triangleinto the slot where the froint panel was.re-install the lid on the tank. Tilt handle upright and you are ready to use the hose

Posted on May 02, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do you change from tool attachments to floor?


On the front of the recovery tank is a slide-out piece. lift up and out (or down-depending on your model). On the end of the hose is a piece the same size and shape as the one on the tank. Slide it down in the slot in the recovery tank. You'll see a little push door labeled
"upholstery and floor attachment". Push down on the top of the door to open it. Then take the hose attached to the piece inserted in the recovery tank and push it into the upholstery and floor access door.

May 15, 2012 | Hoover F5866-900 SteamVac Deluxe Wet/Dry...

1 Answer

On a filter queen 360 vaccum the electrical connection from the hose to the wand was loose and over time the electrical arcing burned up the female conector piece. Is there any way I can replace this...


I am having the same problem On a filter queen 360 vaccum the electrical connection from the hose to the wand was loose and over time the electrical arcing burned up the female conector piece. This sounds to me like a manufacturing problem. The arcing is a fire hazard. Why aren't these problems being fixed for free. When will the recall come out?

Feb 22, 2011 | Filter Queen Vacuums

1 Answer

A friend of mine has a bissell pro heat 2x, which wont vacuum back the water from the carpet on the main floor setting, the hose will spray and vaccuum back. how would i resolve this? if it is a matter of...


First check the motor duct gasket. The motor duct gasket is visible once the tank is removed. It is located underneath the handle on the top of the base of the machine. It has a black rubber coating around it. If there is no suction there please let us know. If your machine does have suction at the duct, continue to check the following:


- Ensure the Ready Tools Dial is set to the appropriate setting (Floor Cleaning or Hose Attachments).
- Remove the tank from the machine and ensure the tank lid is attached properly. The front window must first hook onto the lip of the bottom of the tank and then drape over the tank. Latch the bottom tank to the top tank lid. THIS LID CANNOT BE ATTACHED PROPERLY IF THE TANK IS NOT REMOVED FROM THE MACHINE.
- Make sure the Water Tank is not full on the outside of the bladder. If it is, empty the tank.
- Ensure the hose is firmly attached to the back of the machine. If not, re-insert as necessary by twisting into place.
- The machine must be in an upright, locked position and set to the Hose Attachment setting. If the handle is slightly tilted back while using, it will create a small gap at the suction inlet (where handle meets gasket, above the Bottom Tank) which will cause little or no suction.
- Check the red Tank Lint Screen for debris. If the Lint Screen is dirty, the unit will have poor suction. Clean the Lint Screen if necessary.
- If the float flap door in the tank lid is activating prematurely when you turn the machine on, this flap door should be replaced. This tank may need to be emptied.
- Check the Tank Lid and Tank for damage.

Nov 16, 2010 | Vacuums

1 Answer

I have the hoover steam vac f5906900 and im just trying to use the detachment. I plugged in the water part but i cant get any suction. the water is spraying out that is all....help my dog **** on my bed...


Hi, The attachment hose also has to be plugged into the dirty water recovery tank. The other end of the hose which has the square plug, must go in the spot on the recovery tank where the water comes up from the floor. To do this, Remove the lid of the recovery tank, slide out the little rectangle (usually same color as the recovery tank) which is located just above the clear water channel from the floor there, and insert the square piece for the attachment hose. It should only fit in one way. Replace the lid to the tank and you should be ready to attack the ****. Good luck. Mark

Nov 10, 2010 | Hoover F5906-900 Upright Steam Vacuum

1 Answer

Little Green pro heat is leaking from bottom with very little suction. I just purchased it.


Try the following suggestions for the leaking issue:

- Check to see if the black or white "duck bill" gasket is misassembled or missing from the collection tank; ensure the gasket will open where the flat flaps meet and then reinstall it. The duck bill should be inserted into the curved side of the collection tank.
- Check to see if the solution tank/cap insert is leaking.
Note: When the solution tank is filled and turned right side up, the straw on the insert may fill with water/solution causing the tank to leak for a couple of seconds. This leaking should subside after the straw empties out.
- Check for proper placement of the o-ring on the cap insert. The o-ring should be between the bottle and the insert piece (part with the "straw").
Try the following for the suction issue.
- Remove the Collection tank and locate the circular motor duct on the base of the machine. Turn the machine on and feel for suction at this location. If you feel suction proceed as follows:
- Remove the gasket from the bottom of the Collection Tank. Ensure that this gasket is open (not sealed shut) at the top of the gasket where the flaps meet. If the end is not open, simply squeeze the end to open it. The “duck bill” shaped portion of this gasket should align with the rounded side of the Collection Tank.
- Check to make sure there are no cracks in the flexible vacuum hose or in the tool you are using.
- Make sure the collection tank latch is locked down securely.
- Check for suction at the end of the hose with the attachment off by suctioning water out of the sink or a cup. If there is low/poor suction, check the hose for clogs by raising the hose handle above the unit to allow the water to go into the collection tank.
The issues may be related as you can see some of the suggestions are similar.

Aug 04, 2010 | Bissell 1425 Little Green ProHeat Handheld...

1 Answer

Hoover 5906-900 how do I attach the hose


hi. Take the recovery tank out of the cleaner, take off the top. There is a plastic block inserted in the fron of the tank, it slides up, pull it up and out. Take your hose end, the hose end block slides in there in its place.. then you replace your lid, be sure to rollit from the front to the back, feel the "click", reinstall your tank. Now insert the small hose into the receptacle that opens with a hinged flap. I hope this helps to fix ya (haha). Let me know if it does, because your good feedback helps me get good ratings! Thanks! Rene(The Vacuum Doctor) Here is a manual if you need it.
http://www.hoover.com/pdfs/manuals/F5906900.pdf

Nov 07, 2009 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

No suction from upholstery attachment


http://www.hoover.com/pdfs/manuals/F5914900.pdf

Problem: Low suction
Problem: Clean solution won’t
dispense
Problem: Brushes/brush indicator
won’t rotate during floor cleaning
Possible cause
Possible solution
• Not firmly plugged in
• Plug unit in firmly
• No voltage In wall plug
• Check fuse or breaker
• Blown fuse/tripped breaker
• Replace fuse/reset breaker
Possible cause
Possible solution
• Recovery tank full/automatic
shut off engaged
• Remove and empty recovery tank
• Blockage In tool on end of hose
• Remove tool and clear blockage
• Recovery tank lid not on
correctly
• Make sure lid is on securely
• Recovery tank front panel not
replaced after stair or upholstery
cleaning
• Replace recovery tank front panel
(page 14)

Before using tool
It may be necessary to remove air from
the system (“prime the pump”) so the
clean solution will flow to the tool. Follow
these steps:
1. Attach tool to hose and turn the carpet
cleaner ON.
2. Put the tool on a hard surface or
against your hand to block off the suction.
3. Wait a few seconds (can take up to
15 seconds). Then squeeze the trigger
and begin cleaning.

GOODLUCK!!!!

Jun 17, 2009 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

How do i attach the upolstery attachment?


Go to www.Hoover.com Click on carpet cleaners. Click on steam vac all terrain. Click on Learn more. Click on Download Instruction manual in pdf. It explains all. The hose is attached on the front of the recovery tank. under the hoover symbol.

Jan 30, 2009 | Hoover SteamVac F5914-900 SpinScrub...

1 Answer

Hi it sucks at the hose but not through the intake


There is a duct(#11) that has to be inserted in place of the hose duct, in front of the tank. It won't **** from the bottom without it. If you did put it back in, then the foam filter(if yours has one) is up to high on the bottom of the tank, should be a 1/4 in. gap from the top to the top of the filter.


52514fb.jpg

Mar 10, 2008 | Hoover F5515 Hot Spot Upright Vacuum

1 Answer

Upholstry attachement


The hose end should have a duct on it that you insert in front of the dirty water tank. It must be down all of the way so it will seal. This is where your suction starts from. Acouple of other reasons could be the dirty water tank lid is not locked down all of the way around, the back end isn't locked. If there is a foam filter on the bottom of the dirty water lid, there mustbe a gap between the top and the filter.

Mar 07, 2008 | Hoover F5832-910 SteamVac Supreme Vacuum

Not finding what you are looking for?
Hoover SteamVac Carpet/Upholstery Deep Cleaner Vacuum Logo

Related Topics:

201 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18402 Answers

Gerry Harvey
Gerry Harvey

Level 3 Expert

1466 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...