Question about Ovens

Open Question

Jenn Air JGW8130 single gas oven - wall unit

Everything works perfect... except for the Bake mode. Sometimes it starts heating immediately, sometimes it takes up to an hour. Lately, it just stays at the 100 degree starting point and never starts heating. The sounds and display indicate it wants to work. It acknowledges that I've chosen Bake, it just won't heat. Broil and Clean modes work fine. Clock and digital displays are fine.

Thoughts?

Posted by on

6 Suggested Answers

the dr
  • 447 Answers

SOURCE: Jenn-Air w156 Single Wall Oven Problem

Most likely its the EOC (electronic oven control), it needs to be replaced. If you self cleaned the oven a lot the very high heat generated fatigues computers in modern ovens.

Posted on Sep 28, 2007

Amigaman
  • 248 Answers

SOURCE: bake burner

It is almost always a weak bake igniter. These age and will no longer pull enough current through them to allow gas valve to open. If bake igniter comes on and doesn't light, replace it.

Posted on Nov 18, 2007

  • 1314 Answers

SOURCE: jenn-air expressions 27" convection wall oven model wm27460 won't heat

reset your breaker reprogram the clock try again what happend last time it was working self clean broiling etc

Posted on Dec 29, 2007

SOURCE: Jenn Air w30400b with F2 code

Since the elements are working fine, the thermostat seems to
be in question or, the contacts and connections to the thermostat
are loose etc. This seems to be a controller / temperature thermister problem and since it is intermittent, it might just be
bad contacts in that area of the circuits. see this description below.

INGLIS Royal 100 STOVE F1 F2 F3 ERRORS
Mode lUP 48500 ( thats eye you, not ONE U )

I got the dreaded F3 error on the Display Panel,
every time I pressed BAKE or BROIL, BUT, I could
hear the three relays click in, and then kick out in
sequence, just before the F3 appeared.

I called Westinghouse ( that services INGLIS ) and
was told that F3 " means unpug for 1/2 hour and then
press CLEAR 5 Seconds to reset ". Which is nonsense.

All functions on the clock and timer work fine, and the
three relays were working, so its not a computer problem.
I called service REPAIR companies who said it was the
THERMOSTAT, and replace it - $147.99 ... The Glass tube
of the display is $200 with no circuit board, the relay board
is $300 and the computer/display is $400.

I did tests on the thermostat, first heating it with a propane
lighter, and it raised from 475 Ohms at room temperature,
to 600 ohms, so I knew it was functioning.

Then, I plugged in a variable resistor where the thermostat
plugs in. I went from Zero Ohms resistance to 5000 Ohms in
200 Ohms steps.

Zero Ohms ( equal to burnt out or unplugged) gives you
an immediate F1, which you cannot clear.
From 100 Ohms to 400 Ohms, you get Error F2, which
means thermostat too low.
From 400 Ohms to 665 Ohms there is no error.
At 665 Ohms, the BAKE will beep twice, stating that you
are setting the temperature at or lower than the actual temperature
of the oven ( you cant set the oven at 200, for example, if it is
already at 450 Degrees )
Using this 2 Beep code, I raised and lowered the resistance
and made a graph of the reading on the display versus the
OHMS that the thermostat would send to the controller:
665 Ohms = 170 Degrees Farenheit, which is the
lowest reading in the BAKE MODE.
800 Ohms = 240 Degrees
1100 Ohms = 380 Degrees
1400 Ohms = 500 Degrees, which iis the maximum that
the unit showed in the BAKE MODE.
1430 Ohms to 2750 Ohms, there was no reading, an NO ERRORS.
ABOVE 2750 OHMS, the F1 ERROR appeared again, meaning
thermostat out of range.

Note that the computer module supplies 5 volts DC to the thermostat,
to see the changes in current with changing resistance.
You can easily check the thermostat to see if it is OK, with an
Ohmeter across the thermostat, which should read about 475 Ohms
at room temperature. If it reads Zero, it is burnt out. If it reads
over 2750, it is defective. Check to see if the thermistor in the
tube is SHORTED to the steel outter case as well, as this should be
infinite ohms ( no contact )- if it reads ZERO it is shorted to case.

I found that on the Internet, there are hundreds of people looking for
the F3 code for the ROYAL 100 ( model number IUP 48500 )
and a general search shows that for 400 " other" models of all kinds,
F3 = REPLACE THERMOSTAT ! Not on this model, and all typical searches
for technical support or diagrams or troubleshooting did not even list
the Royal 100 AT ALL, as if it never existed.

I then did tests on the relay board, and replaced the capacitors, a few diodes,
some resistors that were a bit out of value, and two transistors that were
a bit out of value. There was no change in F3.

I cleaned the contacts on the three relays using a typical board fingernail
file that ladies use for their finger nails ( I keep a supply for cleaning
relay contacts, since there is sandpaper on both sides, and they are
tiny enough to fit between most contacts ). THEN, I realized that the BROIL
contacts were bouncing apart - they were too far apart, and not closing
properly, so I bent the stationary contact a bit closer, and plugged in the
stove = NO ERRORS..

I analysed the circuit, and after turning on the 3 relays ( NOTE, when you
turn on BAKE, as in a regular oven, THE BROIL ELEMENT goes on at first
to quickly help the BAKE element get the oven up to temperature )
there is a feedback circuit that feeds 250 Volts back into the 5 Volt computer
chip ( ! ! ! ) It uses two 22 Meg Ohm resistors in series for a total of 44 Million
Ohms, which shows about 46 volts accross the resistors. Since the gas
tube display uses 30 volts to light up, the 46 volts is within the computer
board's ability to lower it enough to feed into the computer. There are transisors
on the back of the control board and Zener diodes etc. to " compare " the
voltage, where 46 volts in = 250, and Zero volts, means that the element
is burnt out, the element fuse in the fuse panel is burnt out, or, the relay
contacts are dirty. The relays are absolutely standard 24 volt relays,
with a plasic cover that snaps off if you pull and wiggle it. You will see
the round silver contact pads are blackened and probaly pitted.
Sand these flat until silver/brass shiny, and test to make certain that
when you press the metal lever that the magnetic coil pulls DOWN,
that the contacts touch! If they do not touch tight, bend the
stationary contact in a tiny bit and test again.

You can first check the fuses - there are two 120 volt fuses in the
fuse panel that give you 250. Then, you can unplug the stove,
and use an OHM meter to see if the element is burnt. The two types
of elements I checked were 3000 Watt at 18.7 Ohms, and 2500 Watt,
at 48 Ohms. If the elements are burnt out, you will get ZERO ohms.
If the element is burnt internally through the insulation in the tube,
and shorting to ground, between the ends and the steel back of the
stove ( ground) you will get a reading of X amount of ohms ( which
normally should be ZERO ) If the element is burnt or shorted to
ground, replace.

The F3 error is a really dumb mechanical errror of whether the 250 volts
is on the elements. It does not involve the computer or the thermostat,
or the relay " electronics" at all - it is just simply 3 contacts that supply
250 Volts, and whether or not the contacts work, the elements work,
or the fuses work. This the same 250 Volts that is on an ordinary
dial stove, and the dumbest part of the whole unit.

When I called service, they said they would order the $147.95 temperature
thermostat, and " see if this fixes the problem", if not they would start
replacing the modules - $300 and $400, plus labour, plus tax etc., and
since the problem was on the module, this would cost $147.95 + $300,
plus $75.00 for the first 15 minutes, and $15 for each additional 15 minutes,
for a total of about $466 dollars ( CDN ) which is about $460 dollars US.

A package of 25 fingernail files is $1.00 at the dollar store. That is all that
it cost to fix the problem. You need a square ( Robertson ) head screwdriver
to remove the 7 screws on the back panel, and then you wiggle the
covers off the relays, and clean them. It takes 10 minutes.

good luck ! Damned the manufacturers for not putting this information
in the user manual.

Robin Graves, January 2008, kidbots.com

Posted on Feb 01, 2008

aborcass
  • 2651 Answers

SOURCE: GE Profile -Installed wall oven - won't heat

brand new??? under a year old??? if so you have a warr call for service, but it sounds like an ignitor isssue, brand new , perhapsgot damaged in shipping 1-800-ge-cares

Posted on Mar 30, 2008

  • 1 Answer

SOURCE: Oven will not heat up on bake broil or convection cook.

I justn encountered the same problem (Model KERS507Y). Haven't checked yet...but am suspecting the Thermal fuse. Have you solved the problem?

Posted on Apr 09, 2009

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Samsung oven error codes


you need the service rep or repairman

Jan 12, 2012 | Ovens

1 Answer

GE Wall Oven - No heat (broil or bake)


On appliances like this only the heating elements use 220 volts. things like the clock, fan, etc use 110 volts. That is why some things work and other do not. Start at the breaker, sometimes a double pole breaker will have 1 side tripped, but will look perfectly fine. switch the breaker all the way to off then re-set. If nothing changes follow the power to the appliance remove the panel and look for some fuses, check to see if any are blown. Also sometimes the microwave will have a separate power source even though its built in to the same appliance. So that's not always a good symptom to follow.

Nov 10, 2007 | Ovens

1 Answer

My oven is ten yrs old lately when i push bake then start the timer starts counting backwards and the pilot light comes on but the oven does not get hot. sometimes i can slam the door and it will start...


Sounds to me like your oven is a gas oven that uses silicone carbide ignition. When that ignitor gets aged it gets weak and will not open the safety valve. How it works video:

When you bang on the oven the bimetal will open on a weak ignitor. If yours is dim orange that is another sign of a weak ignitor.

Jun 29, 2011 | Whirlpool Ovens

1 Answer

WE ran the cleaning sycle on our oven and cleaned it well. It now won't heat ut on broil or bake. Everything seems to be working, but the heating elements won't heat. Any suggestions?


Hi,
Cycling the power off and then on again will sometimes reset it...often you will have to call the customer service number to get the steps to take to unlock that...

Also check out this tip...

http://www.fixya.com/support/r3969401-self_cleaning_oven_problem

heatman101

Apr 26, 2010 | Ovens

1 Answer

FGF374 - Broiler and Bake does not stay on


The flame sensor has to prove the flame to stay lit. When it fails, the valve closes.

Jul 23, 2009 | Frigidaire 30" Self-Cleaning Freestanding...

1 Answer

Oven will not heat


Sounds to me like your bottome element is burned out.  I would replace this, or at least take it out and bring it to an appliance store to have it tested.

Mar 04, 2009 | Jenn-Air 27 in. Electric Single Wall Oven...

1 Answer

GE JTP70 convection oven - defaults to self-cleaning mode


I believe your control board is going bad. This isn't that expensive. However, get one from a GE parts store. They tend to be better priced.

Jan 29, 2009 | GE JTP70 Electric Single Oven

1 Answer

Won't heat up


You have two ignitors one for bake and one for broil your bake is not working

Nov 09, 2008 | Maytag CWG3100A Gas Single Oven

1 Answer

My Dacor wont heat, broil or convection after self cleaning. No heat but everything else works The bake, broil, and convection elements on my Dacor CPS130 electric wall oven will not heat.  The oven has...


like another person stated-from the front behind the door, take off the 6 screws and the cover by the latch. there is an "oven hi temp limit switch" It is crome with 2 heavy black wires connected to it. On the back side of this is a small red button which will reset the limit switch. I had the same issue (everything worked except the any of the heating elements) and quickly resolved.

Jan 07, 2008 | Ovens

Not finding what you are looking for?
Ovens Logo

Related Topics:

221 people viewed this question

Ask a Question

Usually answered in minutes!

Top Ovens Experts

William Miller
William Miller

Level 3 Expert

8820 Answers

Dan Webster
Dan Webster

Level 3 Expert

8147 Answers

Mike Cairns
Mike Cairns

Level 3 Expert

3053 Answers

Are you an Oven Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...