Question about Volfenhag 1600 WATT CHROME AMP AMPLIFIER 2 CHANNEL Car Audio Amplifier

1 Answer

Protect mode hello i sort of need help about my volfenhag zx-7100 amplifier i had it playing in my truck one day and all of a sudden the music started to get a static like sound and all of a sudden the amplifier went into protect mode(red light) on the amplifier

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 52 Answers

Protection circuit.
Checek the wiring of the amp and speakers, don' forget to look for shorts at the speakers. Make sure no wires are touching each other

Posted on Sep 02, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Need help setting amp right


volfenhag's are cheap. you get what you pay for. that is the german equiv. to pyramid or kraco.

Jul 10, 2010 | Volfenhag ZX-5007 Car Audio Amplifier

1 Answer

How to switch protection off (red LED to blue)


The protection light is on indicating a short or over- voltage problem. If you disconnect the speaker leads and the light goes off or green then the problem is a shorted speaker or wiring problem. If the light stays red the problem is inside the amp and it will need service and parts.

May 03, 2010 | Volfenhag ZX-5007 Car Audio Amplifier

1 Answer

Protection mode keeps coming on


That probably means that it's getting a surge of power. Do you have a fuse from your battery wire to your amp? Check also your ground wire. You may need to upgrade your ground wire.

Mar 03, 2010 | Volfenhag ZX-8400 Car Audio Amplifier

1 Answer

I have a volfenhag zx-8400 and it just geos into protection mode


The most likely problem would be a blown fuse. I would replace all of the fuses.

Oct 04, 2009 | Volfenhag ZX-8400 Car Audio Amplifier

1 Answer

How to install a zx-hypercap in to my car


Hello youngbossrio,

Like other car audio capacitors, the Volfenhag zx-hypercap has two terminals, a positive and a negative. The negative terminal is connected to the metallic frame of the vehicle (ground). The positive terminal is connected "in-line" with the amp 12V positive terminal.

The capacitor should be as close as possible to the amp. Within a couple of feet is acceptable.

The capacitor needs to be "charged" before connecting it directly to 12V positive. This is done with a 1000 ohm resistor and a voltmeter. The exact value of the resistor is not critical but it should be in the 500-1000 ohm range. Use at least a 1 watt resistor (your capacitor may have come with a resistor for charging).

Hope this helps.

Aug 26, 2009 | Volfenhag ZX-8300 Car Audio Amplifier

1 Answer

Need help please...


If you unplugged the fuses, the amp won't come on at all. I'd say its a blown transistor, you can test this by opening up the amp and using a multimeter to check resistance on the transistors.

Aug 03, 2009 | Volfenhag ZX-8400 Car Audio Amplifier

1 Answer

Volfenhag ZX-7160 Car Audio Amplifier owners manual to adjust the frequency also wiring diagram diamartn64@gmail.com


its very easy to hook it up. your best bet is to join www.carstereo and ask your question there.but it is easy to set and hook up amp if you really need help email me

Mar 03, 2009 | Volfenhag ZX-7160 Car Audio Amplifier

1 Answer

Protection light


It's likely that there are shorted output transistors in at least one channel. If you want to repair it yourself, you'd have to determine which transistors are defective and replace them. The following page will help guide you through the basic troubleshooting.

Basic Amplifier Repair Primer


Jun 10, 2008 | Volfenhag ZX-8300 Car Audio Amplifier

1 Answer

I can only get one speaker to work


Is ur unit brand new? if thats brand new ofcourse 90 percent OK. You identify first the rear and front speakers (left & right). Beware to short circuit the unit. short circuit may cause damage ur power out..Set up first the speakers before you conect the power supply..hope i help you even a little...thanks..

Mar 16, 2008 | Volfenhag ZX-7170 Car Audio Amplifier

Not finding what you are looking for?
Volfenhag 1600 WATT CHROME AMP AMPLIFIER 2 CHANNEL Car Audio Amplifier Logo

Related Topics:

142 people viewed this question

Ask a Question

Usually answered in minutes!

Top Volfenhag Car Audio & Video Experts

Robert Rankin

Level 2 Expert

356 Answers

hoyzee1

Level 2 Expert

150 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17130 Answers

Are you a Volfenhag Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...