Question about Bissell 37604 Lift-Off Pet Bagless Upright / Canister Vacuum CleanerVacuum

1 Answer

Power head turns on and works the power that turns vacum on not

The motor for suction does nothing. I took foam filter out and cleaned it but do not know how to do anthing with button that says something about cleaning filter

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Sergeant:

    An expert that hasĀ over 500 points.

    Champion:

    An expert who has answered 200 questions.

  • Bissell Expert
  • 357 Answers

If the suction motor doesn't come on but the brush motor does, you have a bad vac motor. If neither motor runs, it's probably a cord problem. Most parts for these are not available anymore.

Posted on May 01, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Filter queen vacuum head has no power


More information needed. When you turn on the vacuum do you hear the motor running? Is the problem that there is no suction at the head? Is there suction at the canister when the hose is removed? I would first check to make sure that there is no obstruction in the hose. Have you checked the filters to see if they are clean?

Sep 11, 2014 | Filter Queen Majestic Canister Vacuum

1 Answer

I have power and air suction, but the beater will not turn and the belt is fine.


Check that you are getting power to the brush roll motor. Many Rainbows have a reset button on the power head.

Jan 31, 2014 | Rainbow Vacuums

1 Answer

Uv200 very weak suction


is there a blockage in the inlet pipe ???

Jul 12, 2012 | Black & Decker UV200 Wet/Dry Vacuum

1 Answer

No suction in dyson vacum


have you tried cleaning that round foam thing? if that is cleaned and air dried it usually will work after that.

Jan 06, 2012 | Vacuums

1 Answer

I have a Kenmore Elegance Vacuum with Dirt Sensor, Model # 116.30750400C, Serial number M41901532. When vacuuming the carpet the power head will work for 3-6 mins then automatically shut off, power is...


It is an electrical problem in the handle, if you can or know somebody that has any fix it ability it can be fixed in about ten minutes. Oh, and Sears SUCKS!!

Oct 17, 2010 | Kenmore 34612 Bagged Upright Vacuum

1 Answer

My hose no longer works no suction buth the vacuume still works how do i fix I checked the hose checked the filters nothing works to get my hose so it has suction.


Check the following after unplugging the power cord from the outlet.
- Check for suction at the back of the unit, after removing the hose where it attaches to the back of the vacuum. If there is NO suction, the machine will need to be taken to a local Service Center for inspection.
If there IS suction at the back of the machine with the hose removed, please check the following:
Unplug the unit from the outlet.
- Check the Pre and Post-Motor filters for debris. Dirty filters can restrict airflow. The pre-motor foam filter is square and located in a pull out tray underneath the dirt cup. The foam filter may be hand washed in cold water with mild detergent. Reinstall the filter when it is completely dry. The post-motor HEPA Media filter is rectangular and located on the side of the machine. Note: The white HEPA Media Post-Motor Filter is not washable.
- Ensure the dirt cup is empty.
- Check the upper tank for build up or clogs.
- Twist the inner cyclone to the left and pull down
- Wipe the inside of the upper tank and separator plate with a
damp cloth moistened with water or mild cleaning detergent.
- Once the inner cyclone is dry, lock back into the machine by
pushing up and turning to the right.
- Put the dirt cup back in
- Check for good suction at the end of the upholstery hose. If there is good suction, make sure the hose is firmly connected to the lower hose on the back of the vacuum. If there is no suction at the end of the hose, check the hose for splits, cracks or clogs.
- Make sure the brush is rotating. If it is not, remove the access plate and examine the brush, and belt for damage. The access panel can be removed by lifting the 4 tabs located at the bottom of your machine. Lift tab 1 then 2-4 tabs to remove the access panel.

CLEARING CLOGS
- Detach the upper hose from the machine. Insert a broomstick into the hose to push any obstruction through to the opposite end.
- Remove the screw from the left side of the lower hose on the back of the unit, and straighten this section of hose by pulling it down or lay the unit out flat, and roll the unit on its side with the lower house towards the top side. Look through the hose for any obstructions. Push a broom stick through the lower hose to unclog.

Aug 12, 2010 | Bissell Upright Vacuum - The Pet Hair...

1 Answer

Dyson DC07 Vacume cleaner trips on thermal after 10 min motor not excesive hot resets after 15 min has been doing this for the last 3 mths. Could it be faulty thermal or motor overheat how can I check...


first, check both filters on that unit. the premotor filter on the side, and the hepa filter underneath the canister. if those filters are clean move through the suction channel and look for a clog or obstruction. also make sure the canister is clean. I have never seen the thermal go bad on those machines (not saying it cant happen though). it sounds like the filters are dirty or you have a clog. its also a good idea to change the pre motor filter if its older than a yr. the foam is fine but the white material behind the foam gets clogged frequently. let me know if you have any other questions and if this doesnt fix the problem.

Jan 06, 2010 | Dyson DC07 All Floors Bagless Upright...

1 Answer

The suction motor is not working, just the power head


Please be more detailed? What brand? one or two motors?
If power is working with no suction. could be a clog or bad filter if -
and if it is a bagless unit - there is usually more than one filter - if filter is clogged you will use alot of suction!
9 times out of 10 it is usually a filter or clogged.

Nov 04, 2009 | Vacuums

2 Answers

It has lost most of its suction power...what to do?


clean all the filters if this doesn't help then check for blockages at head, hose and entrance to collection chamber

May 30, 2009 | Vacuums

2 Answers

Loss of suction bissell vacume


that is normal for the vacume to shut off if the motor overheats you must keep teh dirt cup clean and empty and all the filters clean, when you empty the dirt cup if you have a lot of pet hair take the hose off and make sure that it is clean as well, and do not try to pick up any of those cleaning wipes that will stop it up real quick

Sep 29, 2008 | Bissell Lift-Off(R) Revolution(R) Turbo...

Not finding what you are looking for?
Bissell 37604 Lift-Off Pet Bagless Upright / Canister Vacuum CleanerVacuum Logo

Related Topics:

94 people viewed this question

Ask a Question

Usually answered in minutes!

Top Bissell Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18391 Answers

Brad Brown

Level 3 Expert

15557 Answers

Jim Thurston

Level 3 Expert

670 Answers

Are you a Bissell Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...