Question about Vacuums

1 Answer

Vacuum smell I have a new bagless Hoover Empower Widepath. When I start to vacuum, after only about 2 minutes, it starts to smell really bad, like rubber I would say. Is it band slipping, and how do I check that out to make sure??

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers

Your belt is slipping, it is probably stretched and slips trying to drive the brush roll. Take the bottom plate off, check the brush also, make sure the ends turn freely. The belt runs from the brush roll to the motor shaft. If you can't get to the motor shaft, then you will have to remove the top cover.

Posted on Mar 25, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My hoover empower vacuum wont turn on


Buy a Dyson I love mine! Sorry for being smart.

Jun 06, 2012 | Hoover U5262-900 / U5260-900 / U5266-900 /...

1 Answer

My hoover empower widepath sucked in coin how can I get it out?


Shake it (not so easy) and if you cannot get it to fall out, you have to open up the unit for extraction.

Mar 29, 2011 | Hoover Vacuums

1 Answer

My vacuum doesn't seem to be picking up debris


That means that you need to replace the belt. Here is the belt you need and the manual:

Hoover EmPower Belt and Manual

Jan 08, 2010 | Hoover U5262-900 / U5260-900 / U5266-900 /...

1 Answer

My Hoover bagless vacuum starts to smell like something's burning


What does it smell like? If it smells like burnt anything-it could be that the fan is broken and lodged in the motor. You can see if the fan is good just by looking into it.

Mar 13, 2009 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

Hoover Empower Widepath Vacuum Doesn't ****


This model requires the lower end of the hose to be installed into the base unit to pick up the dirt. If it is properly installed, I would check the belt and also look for a blockage. The normal life span of a belt is about 9-12 months. your belt # 40201190 2 pk

Mar 11, 2009 | Hoover U5172900 Fold Away Widepath Bagless...

1 Answer

Hoover Empower Widepath, brush won't spin.


The belt needs to be changed, it's probably spinning in place which is causing the smell (burnt rubber).

Dec 04, 2008 | Sandia Plastics Super Hipster Power Hepa...

1 Answer

Cleaning my bagless vacuum


Hi Anne,
It does not say to get the filter wet but;;;;;;;;;;;;;;;;; I have had mine for 2 years. When I do a thourgh cleaning of the filter. I actually fill the inside of the filter up with water then hose the outside and let air dry. Another great thing to do is always have 2 filters. Let the one dry out and pop in a new one.

Good luck...
I have only had 2 filters.. and they clean out great with water..

Deb

Nov 17, 2008 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

Hoover empower


Don't ignore your instincts. If you think it smells like a scorching belt, you're probably right. Check that the pulley the belt is meant to spin is free to turn. If it isn't, find out why and then sort that out. A.

Feb 24, 2007 | Hoover U5262-900 / U5260-900 / U5266-900 /...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

187 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18298 Answers

Roger Potts

Level 3 Expert

694 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...