Question about Jl Audio 500/1 Car Audio Amplifier

1 Answer

I have a jl 500/1 pops fuses some times could it be im pulling too much power from the battery because i dont have a cap or extra battery im running at 2ohm with a 15 inch kicker l5

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 93 Answers

Seems like the KICKER is pulling to much power try to knock it back up to 4ohm and see what happens. If its fine that way then you might need a bigger amp.

Posted on Apr 30, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a jx jl 500/l, amp will not power down unless underhood fuse is removed


check your fuse on the battery and check the fuse on the amp or it might b loose connection of power line and the remote wire(the blue wire

Aug 27, 2013 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

So my jl 500/1 v2 has power and no audio... i get 3 ohm when i use the voltmeter on the amp the sub but no voltage? is this a fuse problem or am i an *** who has no idea how to troubleshoot


Okay lets go step by step. First check and sure you have battery voltage and twelve volt turn on on the remote term. of your amp. Be sure u have a ground also. Next take your speaker leads disconnect them and pop them with a battery, and make sure it pops. I(f that all passes you need to make sure your amp is getting an input signal because you could have a bad rca cable.

Aug 20, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

JL Amp isn't powering subs and speakers


just go through ur connections man one by one ull find the prob soon.....check teminals on battery...power line to amp ....all fuses within prob area and obviously make sure u have a good ground.....really impotant.....ground is the most neglected thing people do from my experience bein a audio tech oh and if that isnt it check ur subs....stick a 9v batt on the back pos n neg of each sub n c if they pop in r out this will determine if ur subz r blown

May 14, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

JL Amp isn't powering subs and speakers


silly as it sounds, you may want to check your EQ settings on your headunit. Things like sub volume, SLA, loudness and balance. When they replaced your battery, those old settings were lost.

Mar 26, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

Im running a jl 500/1 and a 300/4 with a 2 gauge power wire quiet a few people have told me i dont need to use my capacitor . does anyone have any advice on power caps ? ive heard they dont work an they do...


a cap is always a good idea. it helps with power requirements that is needed from amplifiers when it is needed. The higher the rating the better holding of power. They work best right by the amplifiers.

Sep 26, 2009 | Car Audio & Video

2 Answers

JL 500/1 loses power after 15 seconds


I would check either the remote wire or the ground. Better yet check both

Apr 02, 2009 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

My amps keep turning off


that is possible,but you might need to run an another battery so they can get the suffenent power and you will need a bigger alternater

Mar 08, 2009 | Alpine MRV-1507 Car Audio Amplifier

2 Answers

Jl 1000/1 popping fuse


well you need to check to see if nt no shottage with the amp and also check if the fuse is not to low amp 20,,,, 25 if not put the amp in a separet 12 volt battery

Dec 10, 2008 | Jl Audio 1000/1 Car Audio Amplifier

3 Answers

2 12w6v2's with a 1000/1


I dont know how you blew both subs with a 1000/1. the subs have an rms of about 400w. according to jl,the sweet spot for them is about 500-600watts. are you sure that you had the jumpers wired correctly and the amp at 2ohms?

Jun 11, 2008 | Jl Audio 1000/1 Car Audio Amplifier

1 Answer

Blowing fuses


You will need to have the amp bench tested at full load to see if there is a pending problem. It will need to see with speaker loading resistors, how much current the amp is drawing and at different frequencies. if the amp checks out with the proper current, at the rated output, have the speaker checked out. Good Luck

Jun 15, 2007 | Jl Audio 500/1 Car Audio Amplifier

Not finding what you are looking for?
Jl Audio 500/1 Car Audio Amplifier Logo

Related Topics:

130 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jl Audio Car Audio & Video Experts

Mark Skinner

Level 2 Expert

77 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Are you a Jl Audio Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...