Question about Technics Audio Players & Recorders

2 Answers

My technics su-g86 has no sound but has power?hjow can i get sound to work?

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

It's simple I had the same problem , all u need is terminal compound. Here is what u do , open ur receiver inside u see huge heatsink and RSN3305 AUDIO MODULES H are on the heatsink rite , so u do this umscrew them off the heatsink and rest of stuff that is connecter to the heatshink , then when everything unscrewed from heatsink , then u umscrew heatsink its self from the unit , pull the heatsink out and put terminal compoud on it put nice amount and make is nice and smooth its urfinger do that in spot the audio modules were located , then u look and the back of the audio modules and apply terminal compound to the back of them also and also smooth it out with ur finger , make sure its all covered up and smoothly , make sure u didn't leave not even a tiny peace not covered , and after that put it all toghwter , the reason it happens after many years of use the compound that was put there by technics at factory probobly dried out by now and audio modules starting to overheat due to lack of compoud comecctiong to the heatsinck , after that process it will work as new , till terminal compound dries up ... It's simple fix and it will work just as it did out of the store

Posted on May 12, 2012

  • romd May 12, 2012

    I do all kinds of electronis and computer equipment anything consoles , pcs, laptops , stereos , dvds all bikes electronics , so if any problems u guys have I'm sure I can help

×

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 4,234 Answers

This amp uses a large IC for the final amp stage (RSN3305). This is the likely part that is defective. It is possible that the voltage regulator circuit is defective as well. Without taking measurements inside the unit, I can not state for sure. The part costs approx $75.

Let me know if you need more info.

Dan

Posted on Apr 29, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Su-2760 will not work. gets a flash of power, turn off


Sounds like the safety circuit is tripping cutting off the power. Most probable cause a short circuit on the main power amp board, causing an overload.

Apr 01, 2014 | Technics Audio Players & Recorders

1 Answer

Technics SU-G75 has no sound


Hello
when the resistors are burned,means that the transistors are damaged, or the power module is damaged.
and in your case its the power module.
Hope this helps.


23392686-biweyzzz1swyjlxgbbebmoak-5-2.jpg

Feb 07, 2014 | Technics SU-G75 Amplifier

1 Answer

Technics Amplifier SU-V4


The clicking sound will be a relay for the protection circuit. That could be faulty, but first check out the main devices on the main amp section. Those attached to the big heat sink. If you see a single IC amp that could well be faulty.

Oct 04, 2013 | Audio Players & Recorders

1 Answer

Hi my technics su-x120 inputs not working!


get audio cord or use yellow red white in for audio sound

Dec 05, 2009 | Audio Players & Recorders

2 Answers

My technics amplifier su-g86 started by clicking off and leaving no sound. Now it turns on, but has no sound. The speakers are hooked up and everything else is fine. It just clicks off periodically and...


Most of the time this problem is caused by bad solder joints.
All the units I have repaired all that was needed was to reflow the solder joints.
The most common place is the leads of the hybrid IC.
Usually there are very very fine cracks which can barely be seen with a good magnifying glass.
I usually go ahead and resolder most of the solder joints related to the output section.
Basically the mechanical stress of the heating and cooling causes this as well as the manufacturer trying to use as little solder as possible.

Hope this helps,
Richard

Aug 29, 2008 | Technics Audio Players & Recorders

2 Answers

Technics SU-G91 Left channel bad


Did you ever find the solution to the left channel issue? I have the same problem with mine.

Dec 02, 2007 | Technics SA-AX540 Receiver

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

500 people viewed this question

Ask a Question

Usually answered in minutes!

Top Technics Audio Players & Recorders Experts

 Grubhead
Grubhead

Level 3 Expert

5011 Answers

T-Comtech Repairs
T-Comtech Repairs

Level 2 Expert

417 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

6694 Answers

Are you a Technics Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...