Question about Jl Audio HD750/1 Car Amp

1 Answer

No audio on my jl audio hd750/1 plus flahing red/green led

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 93 Answers

Thats a sign of bad inputs.

Posted on Apr 27, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why my jl audio 1400d amplifier stays in protective mode?


Check for a speaker wire that come come of , Or a loose grond wire on the amp or where ever you have the ground wire connected two,

Oct 31, 2012 | Jl Audio Car Audio & Video

1 Answer

I have a JL total mobile audio T500.1 mono amp and it was playing then all the sudden it stopped and the power light which is usually green is now red and stays red and no sound comes from the subs any...


This happens when the amp goes into protection mode. 90% of the time, it means there is a short or has another issue inside the unit and has to be fixed or replaced. Hope this helps and good luck!

Jul 09, 2010 | Jl Audio Car Audio & Video

1 Answer

I have a jl 500/1 . The distribution block is lit showing 12v plus. no green power light on the amp? I disconnected pwr and ground and reconnected. the green light came on for 10 seconds and shut off. all...


The amplifier will not power on unless/until it recieves the turn-on signal from the head unit.

It seems the issue is with the head unit in this case.

Check the fuses and verify constant and switched power with a multimeter.

Once the Head unit powers on - the amplifier should also.

Thanks for using FixYa - a 4 THUMBS rating is appreciated for answering your FREE question.

Jun 18, 2010 | Jl Audio 500/1 Car Audio Amplifier

1 Answer

I hookd my jl 500/1 up i like it louddd but the bass goes in and out??? can you help .


is there a green light? does it go red? the unit could be auto-protecting from your speakers, are they old speakers?

Feb 07, 2010 | Jl Audio 500/1 Car Audio Amplifier

2 Answers

Green light blinks slowly on my JL Audio 300/4 amp


Check your fuse at the battery. While AGU glass fuses "look" good, when you read the voltage AFTER the fuse, you can only be getting 5 volts or so. I can't tell you how many times I have seen this.

Larry T
Winona Lake, IN
http://www.cybersoundsaudio.com/cybersounds/vehiclepics.html

Jan 27, 2009 | Jl Audio 300/4 Car Audio Amplifier

1 Answer

I HAVE A JL AUDIO MONOBLOCK AMP 250


It indicating that the power output is too loud and possibility of speakers may get damaged if played at this volume for long periods. When the loudest sound is played the led light mightshow its loosing its brightness and dims in time with the sound level.......................sodeep

Jan 17, 2009 | Jl Audio 500/1 Car Audio Amplifier

3 Answers

JL Audio 12W7


no repair kits available will work on any spl sub. JL will fix the sub for about 410$ plus shipping or i can sell you a new sub with warranty (JL factory direct replacement) for about $ 475 shipped

Jun 04, 2008 | Jl Audio 12W7 Car Subwoofer

1 Answer

Jl audio E6450 cutting out


hi, have you figured out whats wrong with ur amp ...i have the same amp ....and as soon as i finished the connections ...and connect the remote on wire,,, the amp goes on ...making a ticking sound with the green light blinking and the red light staying solid on ...whats the problem please help ....how can i fix this ......my amp is a jl e6450 ....im using a panasonic cd player with a built in amp ....and thats the cd player im trying to connect to the jl amp ...please HELP

Nov 01, 2007 | Jl Audio E6450 Car Audio Amplifier

Not finding what you are looking for?
Jl Audio HD750/1 Car Amp Logo

Related Topics:

239 people viewed this question

Ask a Question

Usually answered in minutes!

Top Jl Audio Car Audio & Video Experts

Mark Skinner

Level 2 Expert

77 Answers

Tygh Duval
Tygh Duval

Level 2 Expert

300 Answers

hoyzee1

Level 2 Expert

150 Answers

Are you a Jl Audio Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...