Question about Balboa Instruments Duplex Digital Panel 2 Pump

1 Answer

Hello I have a one year old Balboa 500z running a single pump. It worked great until I turned off the breaker to the spa when I drained and cleaned it. After re-filling it; I turned the breaker back on. It went through its normal Pr mode and I turned on the jets to get the air out. It now will shut off completely on its own. I must shut off the breaker for awhile to get it to turn on again but that doesn't always work either. It will click in the control box every time when I flip the breaker on but doesn't always turn on. I'm thinking maybe a bad breaker and not getting the required amps? Thanks

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Guru:

    An expert who has written 7 tips or uploaded 3 video tips

  • Expert
  • 351 Answers

If you suspect a bad breaker, that is an easy troubleshooting idea. In some cases you can swap the wire to a different breaker, of the same value, in the panel. This temporary swap would tell you if the fault is in the breaker or the circuit. If you do not have another breaker of the same value , then you would have to buy one for this self check.
The next step would be to check the wiring from the breaker to the device. Disconnect the device and try to reset the breaker. This will tell you if the fault is in the feed wires or the device or in the device itself.


Please Vote !!

Posted on May 15, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Spa has a Balboa 500z Top side and control panel. It was running at 104 degrees and then one day it just shut down. The Circ pump won't start up at all and when I first turn on the power, I hear the...


Turn breaker power off. Verify now power to unit with volt meter. Most systems have in line over temp over current to protect circuit board and motor. Also the water level switch must be made to complete interlock condition. Check the heater coil for continuityas it may have opened. Check heater for continuity to each coil set. There is an interlock that is for diagnostics on start up that will prevent unit from starting. Look for any melted wires or components too. Always know and verify breaker settings. Verify your meter with known voltage reading first. Be safe my friend.

Jun 04, 2017 | Balboa Instruments Pool & Spa

1 Answer

Low flow message on balboa 500z system


The low flow message on any Balboa means that you are having an issue with the flow of water through your heating unit. This can be caused by a few things.

  • Low water levels
  • Dirty filters
  • Something is impeding your water flow
Top up your water level and make sure it is where it needs to be, clean your filters or replace them, and check that nothing is impeding your water flow at the skimmer or water intakes.

Here is a link to water flow issues.
F2 Error Code Trouble Shooting

Dec 24, 2013 | Intex 2500 Gal Easy Set Swimming Pool...

1 Answer

Balboa VL700S control panel jets 1 not working


Your problem is going to be in the circuit board in the spa control box under the skirt.
You have a bad relay.
Rod
US Parts Center

Jun 25, 2013 | Pool & Spa

1 Answer

Spa heateer run by Balboa 500Z control box. Standard mode will not shut off. Lowering temp to 88 still gets temp up to104.what is problem?


Sounds like the temp probe is not working or is disconnected. Temp going high, motor running means that it is calling for more heat which brings both the heater and the pump on until after set temp is reached. Once reached, heater will turn off and a few seconds later the pump will shut down.

Check connections for the temp probe. If connected make sure probe is where it should be. If it is, might try to replace it before considering the control board.

Aug 25, 2012 | Garden

1 Answer

I have just refilled by hot tub with a balboa 500z pump. After refilling it the pump is working fine but the jets are not. The dr light has come up. Please can someone help me bleed the pump to get it...


Priming can be done many different ways depending on thetubs design. Some tub manufactures provide bleed valves located on the plumbingjust beyond the pump and heater unions. Some pumps have a bleed valve locatedon the pump. If there are no bleed valves then you will have to release theunion nuts to allow the air to escape.
You can find answers to common spa or bath problems online at http://www.balboadirect.com/support.aspx
Hope that helps.

Jun 12, 2011 | Balboa Instruments Duplex Digital Panel 2...

1 Answer

My Balboa 500Z-Series Hot tub has been working fine for 6 months. Then today, without warning the lights started flashing and I could not turn them off from the light button. Additionally a code...


Hello!
I have a question about my Balboy 500Z. When the water is heated the motor pump is still running that means the pump runs all the time without interrupt even the water has it's temperature. Now my question: is it possible to turn of the pump? thank you for your quick answer! Greetings Beat from Switzerland

Jan 02, 2011 | Balboa Instruments Duplex Digital Panel 2...

3 Answers

Balboa vs500/501/502 gs500/501/502 I just refilled spa yesterday and now I'm getting error codes HL and dr both indicate low flow issues, The water level was re-filled to where it's always been. Any help...


A lot of times you can get an air lock as the spa fills. All you need to do to fix this is open the drain valve for a few seconds till it runs just water and no air. Or start the pump wile the drain is open. This should fix your problem. Good luck.

Sep 04, 2010 | Balboa Instruments Duplex Digital Panel 2...

1 Answer

I have the Balboa 500Z pump heater kit. Its hooked direct to a mighty iron ( 120v) recirclulating pump. Ever since it was new, I keep getting lack of water vflow errors ( dr, then dy ) I have plenty of...


I have a 6 month old Balboa 500Z. I have noticed that the filter system tis running all the time 24/7. I have reset the filter cycle to run for 2 hours { F2 }. It still is running all the time. It dose not seem to make a difference what I set the cycle for it just keeps running

Dec 06, 2009 | Balboa Instruments Duplex Digital Panel 2...

1 Answer

I have a catalina spa with BALBOA CONTROL PANEL


Where are you from?

If you live in the UK give me a call/email as I have worked on lots of Catalina Spas over the years.
http://hottub.synthasite.com

Regards,
Ian.

Jun 07, 2009 | Balboa Instruments Duplex Digital Panel 2...

Not finding what you are looking for?
Balboa Instruments Duplex Digital Panel 2 Pump Logo

524 people viewed this question

Ask a Question

Usually answered in minutes!

Top Balboa Instruments Garden Experts

Ian Kime
Ian Kime

Level 2 Expert

77 Answers

Paul Stonecypher
Paul Stonecypher

Level 1 Expert

28 Answers

Mister Danger

Level 3 Expert

5631 Answers

Are you a Balboa Instruments Garden Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...