Question about Sony Cyber-Shot DSC-T1 Digital Camera

8 Answers

For use with compatible battery only????

Everything was working fine until I charged the battery a few days ago and now it gives me the message 'for use with compatible battery only' when I turn on the camera? the battery is the original one that came with the camera??? any help would be appreciated...thanks

Posted by on

  • 7 more comments 
  • Disdainful Jun 14, 2008

    Same thing going on with me. I haven't noticed anything that helps except that it seems to work better when the battery's not at full charge.

  • Anonymous Jun 28, 2008

    Exact same issue...brand new camera. Bought a second battery when I bought the camera and I get message with both. I called Sony and they want me to send it to them to get repaired. Not happy at all with Sony or this camera.

  • Anonymous Jul 01, 2008

    the same problem. message appears every time the camera is turned on... has been going on for a week now

  • zash Aug 13, 2008

    Well the only solution that worked for my camera was to buy a new battery...now all has been fine...I have a feeling that it was the charger that screwed up the original battery. I had lost ithe charger and bought a knockoff from ebay for $10, it worked fine for the first few times then my son put in the battery backwards and the rest is history....

  • gemgoddess Oct 10, 2008

    F***ing frustrating!! My battery was FINE until I charged it. :(

  • Anonymous Oct 17, 2008

    ME TOO! bought it from a random cheap site on ebay.. put it in backwards..ugh

  • shuffleover Feb 03, 2009

    Me too. (DSC T77)
    I bought an Energizer battery ($60 instead of the Sony $100),
    charged it - worked fine for about 30 sec. then, "For use with compatible battery only" - I could take one picture though before it shut down.
    I think Sony has put some special characteristic into their brand of battery and programmed the camera only to work with batteries that have this "special" (read: proprietary booby-trap) characteristic. 
    - Any ideas (other than sending the camera back) ?

  • Anonymous Apr 01, 2009

    Same problem with my camera. I will never buy a sony again!!!!

  • juliepd76 May 18, 2009

    My battery is the original one...I used it successfully in the morning, charged it, took it to a party and for the exact same message: "For use with compatible battery only."



    I love my camera and want this problem solved!

×

8 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 2 Answers

Press the power button + the shutter button + the zoom button,
All once for 5 seconds !!
And your camera will work normally

Posted on Aug 14, 2013

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Same thing happened to me! Stupid new charger!

Posted on Jul 01, 2011

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I got the same problem, i went to sony service care and they told me that you have to change the battery be cause it has been damaged.
and the problem still hanged and no one know the reason, but 70% it happened cause of the charger ... don't ever plug your battery in the charger too much time. my cam is DSC-W35 ... for me .. no sony any more :(

Posted on Nov 16, 2009

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I've heard of this issue with more than one Sony (seems like there was a post in the forum not long ago with the same issue...). If you've bought a new battery, the problem would appear to be in the camera's power controller. With that in mind, I'm afraid you'll have to decide if the cost of repair is worth it, rather than simply putting the money toward a new camera.
Farid

Posted on Aug 12, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Discharge battery by pressing aluminum foil on battery contacts, ( 10 seconds) then recharge battery but not fully? Lets keep helping each other!

Posted on Feb 06, 2014

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

This issue is bugging me badly.. I turn on the camera and it says that ****.. I've changed charger and battery; but it didn't work out. So here is my solution for you.. NO MORE SONY CAMERAS' :(.. Cuz its ****........

Posted on May 28, 2012

Same problem for me also. i am VERY mad. however they came out with a new version of the battery i use so THAT may work but idk

Posted on Jul 13, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Same problem for me.... not sure how to fix it. tried taking it out, recharging it, but nothing has worked...

Posted on Jul 01, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

How do I fix starting problem in Megane 2004 1.6 16v


Sounds as though there is a charging problem with the car. It starts when battery fully charged but when the charge is low it fails to start. I would get a mechanic to connect his meter to the battery and see if it is charging as it should. It is also possible that something is draining the battery when not in use. Check interior lights are going out when parked up, nothing is plugged into cigarette lighter outlets attached to sat nav etc., things like that.

Jul 14, 2015 | 2004 Renault Megane 1.6

1 Answer

My iphone 3gs will not charge or conect to itunes


REplace your data cable.If not working that also.... check you port of iphone.And try different USB port.
Thanks.

Feb 18, 2013 | Apple iPhone 3G

2 Answers

Tips to troubleshoot battery (seeking) Receiving "Battery not charging" message from computer.


Take it to Auto Zone or O`riellys and they will test it for you at no charge.They can check your charging and starting system also.Hope this helps.Good luck.

Nov 13, 2011 | 2003 Chevrolet Silverado 1500

1 Answer

The truck stalled a few days ago. It was jumped and ran fine. Yesterday it stalls again, but won't the battery won't hold a charge. It was towed to the shop and they said everything tested fine once they...


sound like might have a prooblem with the charging system. if the altenator is not charging the battery while driving then when the battery voltage gets too low (prob around 10volts) then the computers will shut down, then when jump started it gets some power back, and when the battery is charged will all work fine for a while.
does your model have the voltage gauge in the dash? should be over 12 volts when engine running, 14volts is a good charge rate. and should stay up above 12 all the time, with lights on air condon etc...
and altenators can be funny, work sometimes, and not atother times,

Mar 24, 2011 | 2002 Mitsubishi Montero Sport

3 Answers

Sony erricson w705, wont charge the battery, it comes up with a message saying it cant charge the battery please put a sony erricson battery in, but it is a sony erricson battery and when the battery was...


my phone is the same model and did this but when i charged it, after about an hour it would come up with 'charging error stop ' and when i unplugged it, it hadn't even charged at all. and then the other day it just wouldnt charge, i plugged it in, it said it was charging but it wasnt. in the end, it worked by keeping the phone switched off and charging it while i was turned off. so try that, if not then i really dont know sorry

Oct 08, 2009 | Sony Ericsson Walkman W705 Cell Phone

1 Answer

Battery Not Identified.


hello

I suggest you a few steps to solve your problem.
  • remove the charger and press the power button till all residue power is radiated.
  • then connect the charger and charge the battery fully and try booting the system.
  • if this don't work check the output of your charger and see if it is working fine.
  • if it is working fine then remove the battery and connect the charger and try starting the system.
  • if it works then there are two things possible.
  1. battery gone.
  2. IC responsible for charging is gone.
i hope you can figure out the problem through this.

Thank you

Aug 07, 2009 | Dell Inspiron 1525 Laptop

1 Answer

Charging system


it could still be the alternator it may have warn brushes or bad reg

Mar 17, 2009 | 2008 Ford Fusion

3 Answers

Canon Ixus 75 not charging


The camera was working fine 5 days ago. Yesterday when I tried to switch it on, I assumed that the battery was flat so I charged it but when fully charged the camera still won't switch on. i Please help!

Mar 24, 2008 | Canon PowerShot SD750 / IXUS 75 Digital...

Not finding what you are looking for?
Sony Cyber-Shot DSC-T1 Digital Camera Logo

Related Topics:

4,630 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Cameras Experts

kakima

Level 3 Expert

102366 Answers

james laughton
james laughton

Level 3 Expert

1841 Answers

John Peabody
John Peabody

Level 1 Expert

14 Answers

Are you a Sony Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...