Question about MA Audio HK401SX Car Audio Amplifier

1 Answer

Amp is in protect mode

Dont know whats wrong with it

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Novelist:

    An expert who has written 50 answers of more than 400 characters.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 68 Answers

If you have'nt fixed your amp by now I thought I'd tell ya a couple of things why it's going into protect. The basics. Blown subs, bad power suply or mosfets, and blown output transistors/mosfets. Still need help let me know. I repair amps for a living and i'm the cheapest you'll find and honest. I also give the longest warranty. I'm tired of other people rippin people off on repairs. Let me know.

Posted on Sep 19, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My amp was working good and i didnt use like for two months and know it doesnt work the green light turns on but the red light too of over current and i cant hear nothing i dont know what is it..


if it turns red its a protection light you most likely got the ohms wired wrong on the speakers and the amp is going into protect mode so you dont fry it or the subs

Mar 04, 2011 | Sony XM-2150GSX Car Audio Amplifier

1 Answer

My amp will go into protection mode when i turn my truck on, it flashes green and beats once,then turnd protection mode on... whats wrong with it??


im not sure what is wrong but i do know if you keep it hooked to subs it will fry them because that happened to my friends jackhammer amp and 2 12" mtx jackhammers

Mar 10, 2010 | Fusion FEW12PK Car Subwoofer

1 Answer

Jbl am in protect mode


if it goes in protect mode means ur amp is turn up to high or it is over heating so it protectn it from fryn ur amp try to adjust it down

Jul 12, 2009 | JBL BP1200.1 Car Audio Amplifier

1 Answer

Power light turns from green to red protect mode and then there is no sound coming from my speakers


there are 2 reasons for it to be going into protect mode 1 is heat 2 is the load on it. if it is going into protect mode soon after it starts there is a problem with the speaker. if it is after it has been on for a while it is that the amp itself is overheating. hope this answers your question

Apr 27, 2009 | SPL Audio Phantom DK2-1000 Car Amp

1 Answer

My amp


My amp stays in protect mode i don't know whats wrong Any suggestions

Apr 05, 2009 | Legacy Audio American Legacy II LA1990 Car...

2 Answers

Rockfordfosgate P6002 amp protect light goes on


are u sure u have them running at the right ohms, for not only the subs but the amp too...if you go lower than your amp is rated you can fry stuff...via protect mode......hopefully this helps

Mar 17, 2009 | Rockford Fosgate p-450.4 Car Audio...

1 Answer

Audiobahn a8000t problem


If the protect LED is lit, the amp probably has shortedoutput transistors. To eliminate other possible causes, read throughthe following page:

Amp in Protect Mode - Troubleshooting

Let me know if you have any other questions.

Nov 23, 2008 | AudioBahn A8000T Car Audio Amplifier

1 Answer

Kenwood kac-7202


Nope it's not a high-to-low level converter problem, it's most likely a problem with one of two things. 1) either you've blown the output stage in the amplifier, or 2) you've hooked up your subs wrong and your amp is seeing to low of an impedance. The amp is supposed to be 1ohm stable, but we had the same problem. When the indicator light goes red it means that the amp has gone into protection mode, now you have to figure out why. If something in the amp goes bad or just disconnects from the board it will cause power protection mode. If you fry something on the board because you are running the amp to hard or at the wrong impedance it will go into thermal protection mode, however there's no simple way to figure out which has happened.

Have you tried hooking up some different subs to see if the problem remains? try this. If the problem no longer happens then you know it's your subs, if it does still happen then you'll know it's an internal problem.

Years ago I had a Kenwood KAC-821; long story short, I melted the main power wire right off of the board, everytime I turned the system up the amp would shut down.

Take you amp to an authorized dealer and have them bench test it for you.

Let me know what you find out.

Jul 14, 2008 | Kenwood KAC-7202 Car Audio Amplifier

2 Answers

Crunch GP 3000 D Pro


It's very likely that the output transistors have failed in the amp. They will need to be replaced.

Jun 14, 2008 | Crunch Drive V-600 Car Audio Amplifier

Not finding what you are looking for?
MA Audio HK401SX Car Audio Amplifier Logo

Related Topics:

111 people viewed this question

Ask a Question

Usually answered in minutes!

Top MA Audio Car Audio & Video Experts

Robert Rankin

Level 2 Expert

338 Answers

Ronald Prier

Level 2 Expert

71 Answers

The Knight
The Knight

Level 3 Expert

73619 Answers

Are you a MA Audio Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...