Question about Kodak EasyShare Z760 Digital Camera

5 Answers

Docking station the red light on the docking station keeps blinking

Posted by on

  • 7 more comments 
  • Anonymous Apr 20, 2008

    Mine does too. What does this mean?

  • RojoC May 12, 2008

    I ahve hte same problem it is really irritating and I am having difficulty charging the battery.

  • ComputerNut May 13, 2008

    Having the same problem. When the camera is first put on the
    docking station it will charge for about 10 seconds then go to flashing red. Tried
    to clean the battery terminals and reseat the battery. Didn't work. I accidentally
    dropped it from about a foot onto padded carpet. Put it on the docking station
    and it stayed in charging mode. Next day the same problem. Same drop and it
    works. Assuming it may be a battery seating problem. Don’t recommend the
    solution that worked for me.

  • haasahhh May 23, 2008

    I just experienced this problem for the first time today, too. I got this camera in December of 2005. I haven't had any problems until now...maybe time for a new battery??

  • Anonymous Jun 10, 2008

    Yes , same poblem

  • Anonymous Jul 20, 2008

    me too

  • Becca Rouse Aug 03, 2008

    This happens to me too. I also have banged it around and then got it to work, although that drives my husband crazy when I do it. I don't want to start buying batteries and cables if it's not going to fix the problem. But I can't figure out what's causing it since most of the time it works! Right now it has been doing it for the last two day sno matter what I try. Ugh!

  • rpgrml Sep 02, 2008

    I got mine Dec 2005 too! I never had a problem until now. It is blinking red but I can still transfer my pictures to the computer. Is there another way to charge the battery?

  • Anonymous Oct 08, 2008

    When I put the Kodak Z760 on the dock station the lights go green. Then in about 10 seconds the lights flash red, why?

×

5 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 3 Answers

I had the same problem. I did need to take the clear plastic insert off but then I had to put a rubber band around the dock and camera (more on the left of the camera and dock) to hold it evenly on there since the camera was leaning on the right and wasn't charging for me. Now it charges as soon as I put it on there with the rubber band with no blinking red light anymore! Hope this helps!

Posted on Jul 31, 2010

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 2 Answers

Check the plastic insert that fits onto the top of the docking station. Take it all the way off, and then carefully reseat it onto the station. Make sure this plastic insert is fully seated onto the docking station. If it's loose at all, you are likely to have the red-blinking light which indicates the camera is not charging properly.  Replace the cameras (gently, but firmly) onto the docking station, and check back in a couple of minutes to make sure the red light has not come back.

Posted on Oct 27, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Try using some electronic cleaner on the connections. I had the same problem and it took care of it DO NOT USE WD40 as it is an oil based solvent. Only use electronic cleaner. You can get it at most department stores. An auto parts store is an excellent place to find it also. My belief is that like any electrical connection they become corroded over time and make a poor connection. By cleaning the connections you re-establish a good solid connection between the camera and docking station.

Posted on Jan 16, 2011

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I am having the same problem. I don't think it is a XP-SP3 problem, I haven't installed it yet. I checked my connections and they seemed fine. I did notice that my camera was not seated firmly to the docking station, so I removed it then placed on the station again and held it firmly in place. When I removed my hand I noticed that the camera unseated itself slightly and the red light was blinking again. I also noticed that the cord holding the lens cap seemed to be interfering with the camera being seated, so I moved that around too. So far, so good, the camera is charging!

Posted on Sep 05, 2008

Same here - is it an XP-SP3 thing?

I think the PC is disconnecting the USB from the computer and then it doesnt't charge. But that doesn't make sense since the dock is powered.

Posted on Jul 20, 2008

2 Suggested Answers

shockwave727
  • 262 Answers

SOURCE: camera wont charge

Hi, if you are using the KLIC-5000 battery try to clean the metal contacts on the battery. Try also to remove the battery of your camera dock your camera on the docking station then turn on the camera, if the camera will not turn on it means the charging mechanism of the dock is defective. Now if the camera turns on it means the battery is defective that is why you can charged it.

Posted on Feb 11, 2010

Bubbabear64
  • 2794 Answers

SOURCE: Charging Camera

I would test the docking station first. Do you have a way of charging the camera without using the docking station?

Thought I'd ask because some can and some can't.

Posted on Jun 21, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why wont my HP photosmart R967 turn on battery is new and docking station is fine but it will turn on if connected to docking station


It is likely the battery is not making contact properly or is not getting fully charged.
Check the instructions on battery connection on page 9 and confirm the lights are blinking correctly to show battery is charging.
http://h10032.www1.hp.com/ctg/Manual/c00717663.pdf

Aug 03, 2014 | HP Photosmart R967 10MP Digital Camera,...

4 Answers

My kodak eastyshare z760 flashes red when on the battery charger but yet, the battery never shows fully charged.


I had the same problem. I needed to take the clear plastic insert off but then I had to put a rubber band around the dock and camera (more on the left of the camera and dock) to hold it evenly on there since the camera was leaning on the right and wasn't charging for me. Now it charges as soon as I put it on there with the rubber band with no blinking red light anymore! Hope this helps!

Jun 10, 2010 | Kodak EasyShare Z760 Digital Camera

1 Answer

Camera wont charge


Hi, if you are using the KLIC-5000 battery try to clean the metal contacts on the battery. Try also to remove the battery of your camera dock your camera on the docking station then turn on the camera, if the camera will not turn on it means the charging mechanism of the dock is defective. Now if the camera turns on it means the battery is defective that is why you can charged it.

Feb 11, 2010 | Kodak EasyShare Z760 Digital Camera

1 Answer

Docking station charges two of the three bars to green and then afterwards goes into blinking red bars and the third green bar never gets charged.


went to best buy and bought a new battery charger. i don't know what's wrong with the docking station but at least i'm back in business insofar as being able to continue using the camera.

Sep 20, 2009 | Kodak EasyShare Z760 Digital Camera

3 Answers

Red flashing light on battery indicator on the loading dock.


My Z760 does the same thing. When that happens I run the battery completely down by taking pictures until it shuts down. Then when I put it on the dock it charges properly. Don't leave your camera on the dock all the time and don't try to always keep the battery fully charged--instead it will develop memory and think it needs to be fully charged to run and will give you a low battery signal earlier than it should. Wait until you actually get a low battery signal before charging and it should help, but mine will still give me the red light sometimes. Then I run the battery out like I said before. I hope this information helps. :-)

Mar 14, 2009 | Kodak EasyShare Z760 Digital Camera

2 Answers

Camera won't charge


Hi!

It's a problem with the battery. It already reached it's life cycle. I had the same problem with my 15 month old casio camera a year ago - flashing red light on docking station. I even tried borrowing a docking station/charger to see if something else is wrong with it.

The only solution for this is to have the battery replace.

I hope that helps.

Good luck and have a nice day!

Nov 26, 2008 | Casio EXILIM Card EX-S770 Digital Camera

6 Answers

Charging...Red Light


This happened to me. The cause was the battery did not fit into the case, This led to poor connection of the battery. After I fixed the loose battery , it worked perfectly till today.

Oct 05, 2008 | Kodak EasyShare Z760 Digital Camera

1 Answer

Charging Camera


I would test the docking station first. Do you have a way of charging the camera without using the docking station?

Thought I'd ask because some can and some can't.

Jun 21, 2008 | Casio Exilim Card EX-S600 Digital Camera

2 Answers

Charging battery


BAD BATTERY. if it is less than one year old they will replace the battery for you. Contact tech support and give them your contact information. They will require you send in your battery and give you the address to send it to. Then they may be able to send you a replacement free of charge.

Feb 10, 2007 | Casio Exilim Card EX-S600 Digital Camera

Not finding what you are looking for?
Kodak EasyShare Z760 Digital Camera Logo

669 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kodak Digital Cameras Experts

kakima

Level 3 Expert

96417 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

Tony

Level 3 Expert

2598 Answers

Are you a Kodak Digital Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...