Question about Fender Hot Rod Deluxe Guitar Combo Amplifier

2 Answers

Fix Reverb unit on Fender Hot-Rod Deluxe Amp

My fender Hot-Rod Deluxe amp fell out of the back of a moving car... long story... Luckily the only thing that doesn't work is the reverb. Does anyone know how i should go about fixing the Reverb unit on this amp?
I figure it might be as simple as unscrewing the unit at the bottom and checking to see if anything looks loose, or has become detached. Other suggestions or links to repair tips would be great.

Posted by on

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 57 Answers

Could have broken a spring in the reverb tank, or a wire connecting it to the amp, or the reverb driver tube, or a few other things, but those are the most likely in this situation. Thats what I'd check first. Give it a little slap and if it vibrates like normal, your spring is probably ok, you can still open it up and double check though. Check your wires. Then pull your reverb driver tube and replace it. If that doesn't work, it is probably in the circuit somewhere, and you should not work on your amp unless you know what you are doing. They store large amounts of electicity in the caps and they can kill you.

Posted on Apr 24, 2010

  • Len Jeffrey Dec 07, 2014

    I must add one more thing to this person's advice. With the amplifer off or on standby, pull the phono plug out of the 'output' socket of the reverb pan and [sfter removing the phono plug from the input socket] insert it into the input socket. Turn the amp back on. Bang the reverb pan. It should have less of an output level but there should still be a sound proving that the input coil or transducer is OK.

×

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that got 5 achievements.

    Governor:

    An expert whose answer got voted for 20 times.

    Hot-Shot:

    An expert who has answered 20 questions.

  • Expert
  • 122 Answers

Try to remove the reverb springs tank unit.check the springs if loose or broken change the unit.if ok measure the resistance of two coils in the input and output rca female connectors.then check the male connectors and the cables in the two sides at the tank and the amplifier end.be carefull do not open the chassis or try anything inside the amp.high dc voltage and high capacity capacitors can seriously shock you even with mains disconnected!

Posted on Jun 13, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Crate three button foot swich how do you connect it to the amp


The Fender Hot Rod Deluxe shows a 2-button footswitch as standard but I'm confused. This link shows it as connected to the amp via a mono cable ... FENDER Hot Rod Deluxe DeVille Footswitch which is impossible using two switches. Normally it's a stereo (tip, ring, sleeve) with tip to sleeve being one connection, and ring to sleeve the other. Good luck with this one.

Apr 22, 2014 | Fender Hot Rod Deluxe Guitar Combo...

1 Answer

Hey! I have a 1975 Silverface Super Reverb. recently, the reverb has stopped working, but I can still hear the coils vibrating if I give the amp a shake, so I'm assuming some connection is bad. If I...


The unit is screwed down. There are two screws one at each end. Look hard you will find them. Most of the time there is a small transducer (coli of wire) the small wires are usualy broke.

May 24, 2017 | Fender Hot Rod Deluxe Guitar Combo...

1 Answer

Sometimes the reverb works, then next day it dont.i have a 1999fender hot rod deluxe


Fender Amplifiers are notorious for their reliability issues.However, I'm sure that amp will sound sweet once you get everything working again!

The problem is likely your "tank". The tank contains the springs which create reverb as the guitar's signal is sent through them. A broken spring could be causing your problem.

Luckily, any of the larger music stores should have them avalible.

Good Luck!

-Sheeves

Mar 02, 2011 | Fender Hot Rod Deluxe Guitar Combo...

2 Answers

My reverb on my Fender deluxe Hot rod amp has stopped working. What is wrong?


Your reverb spring is most likely broken. If it has electronic reverb, then the chip has gone out. For both of these problems, a qualified amplifier technician will have to look at it and replace the parts.


Hope that helps!

Feb 13, 2011 | Fender Hot Rod Deluxe Guitar Combo...

2 Answers

My Fender Hot Rod Deville reverb is not working. What should I look for in trying to fix this problem


There are two coils in the reverb unit which use delicate wires which can break off - these can easily be checked, as follows:-

i) Remove one cable plug from the reverb unit & substitute an uncapped phono plug to the socket.Then check that there is electrical resistance across the plug terminals.

ii) Reconnect original phono plug & do same test as i) to the other socket.

iii) If either is open-circuited, then look for a break in the lead-out wires from the corresponding coil inside the reverb unit.
This break may be repaired (contact me for details) or buy a new reverb unit!

iv) If there is electrical resistance at both sockets of reverb unit, then clean both original phono plugs & try the system again.

Sep 15, 2010 | Fender Hot Rod Deluxe Guitar Combo...

1 Answer

How do i connect the boss gt 10 to a fender blues deluxe amp and bypass the amps preamp


You can plug the output of the gt10 into the "power amp in" jack of the Fender. This bypasses the preamps in the Fender but uses a buffer amps in the Fender to drive the power amp. Please note that the reverb is STILL in the circuit when you do this. You can turn the reverb to zero if you wish to disable it.

Jun 09, 2010 | Fender Hot Rod Deluxe Guitar Combo...

2 Answers

Amp is little used and now the reverb is not working. It is never moved from the room where I play.


There are only TWO op-amps and the tank involved with the reverb. Both of those are in one IC chip labeled "U2". It is a TL072.

Pin 1 of that chip is the output to the tank and pin 7 is the inout of the reverb control pot that then goes into the power amp.

They resistively mix the delayed reverb signal with the straight signal at the input of the power amp.

I assume you have turned up the reverb control which is just a volume control for the signal going through the tank.

There are so few parts involved with this that a failure is really rare.

May 13, 2010 | Fender Hot Rod Deluxe Guitar Combo...

1 Answer

I have a brand new fender deluxe combo amp is the preamp in and out usable for an effects loop


Yes you could do that. The preamp output is just a BUFFERED output of the signal sent to the power amp. And the power amp input jack is BUFFERED before driving the power amp. These impedances are neither high or low being in the 1K to 3K ohm range.

The jacks for BOTH are mono jacks so noise pickup is possible if long cables are used. The external effects unit should be well grounded and operate off the same receptacle as your Fender for system safety. Use SHORT audio cables to minimize noise.

ALL the signal will pass through the effects unit when used this way... HOWEVER the internal reverb will still be in this path. You can kill this by turning the reverb control to zero on the Fender.

May 13, 2010 | Fender Hot Rod Deluxe Guitar Combo...

1 Answer

Hot Rod Deville, reverb squeal...


Here is an article that might help:http://www.guitarplayer.com/article/reverb-troubleshooting/jun-09/97165 Here is the schematic:http://www.fender.com/support/amp_schematics/pdfs/Hot_Rod_DeVille_Schematic.pdf Check to see if someone hasn't reversed the input and output cables at the reverb tank. Then troubleshoot the reverb section .

Aug 28, 2009 | Fender Hot Rod Deluxe Guitar Combo...

2 Answers

I have a Fender Hot Rod Deluxe. It has very few


First try turning the volume control down before turning switch to operate.

IF this seems to fix it, IF the unit has a tank reverb, the vibration of the reverb springs MAY be causing the problem. The solution then is to reduce the volume before applying power WHICH is a good idea anyway... from an electrical engineer.

Jul 24, 2009 | Fender Hot Rod Deluxe Guitar Combo...

Not finding what you are looking for?
Fender Hot Rod Deluxe Guitar Combo Amplifier  Logo

Related Topics:

2,479 people viewed this question

Ask a Question

Usually answered in minutes!

Top Fender Music Experts

dave nyman

Level 1 Expert

17 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

287 Answers

Are you a Fender Music Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...