Question about Fender Hot Rod Deluxe Guitar Combo Amplifier

1 Answer

I have Fender Hot Rod Deluxe and Blues Deluxe amps.After the amps are in use for 20-30 minutes, volume just flat out fades to almost nothing. I have had it checked out and technician could not reproduce the problem, however, he said it was a known issue with these amps. Tubes are OK. What gives?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Fender Master
  • 5,603 Answers

I want you to do a test. while using the amp plug a pair of headphones into the preamp out... note you will only hear stuff on one side if they are stereo phones and the sound may be fairly weak... while the unit is operating correctely then unplug phones and use it. When it fades out plug in phones compare the level when it was OK... If the preamp output fades lower as well, then we know problem is in the preamp section...

We can do a lot of troubleshooting without opening the amp.

I see nothing in the scheamtics that should be an issue causing this...

Since it didn't fail for the tech, think "what was different?". Are you connecting something else? Foot pedal? Temperature? :Loudness of playing?

Now what else is in common to these two units... AHA! The guitar...

If your guitar has a battery in it, the 20 to 30 minutes fading would correspond to a battery failing and then recovering after you unplug the guitar for a while.

Posted on Apr 24, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hot Rod Deluxe


Most likely clipping. This happens when the source DBs are too high for the amp....feeding in too hot.

Jul 17, 2014 | Fender Hot Rod Deluxe Guitar Combo...

1 Answer

Crate three button foot swich how do you connect it to the amp


The Fender Hot Rod Deluxe shows a 2-button footswitch as standard but I'm confused. This link shows it as connected to the amp via a mono cable ... FENDER Hot Rod Deluxe DeVille Footswitch which is impossible using two switches. Normally it's a stereo (tip, ring, sleeve) with tip to sleeve being one connection, and ring to sleeve the other. Good luck with this one.

Apr 22, 2014 | Fender Hot Rod Deluxe Guitar Combo...

1 Answer

Certain notes have a buzzy break up sound through the amp


If not a valve issue check by preamp valve substitution 12AX7A's.Check solder joints +/- 16v circuits and send/return and input jacks.

Dec 11, 2013 | Fender Hot Rod Deluxe Guitar Combo...

2 Answers

My Fender Hot Rod deluxe makes a popping noise when switching back to the clean channel.


This is because your clean channel only runs through the pre-amp section, requiring an increased volume level to match that of the volume of the drive section which is overdriven by the pre-amp circuit. my suggestion is to use lower volume level on the clean channel of the amp. To get any volume boost you may need to match the two channels you could use a signal/volume booster or overdrive pedal between your guitar and amp input, switching it off and back on when you switch back and forth between channels.

Jul 15, 2012 | Fender Hot Rod Deluxe Guitar Combo...

1 Answer

My fender hot rod deluxe is distorting in clean channel when I push the volume past 2


Realize that the number on the volume control is only relative... it means nothing regarding what the amp can produce. With a high level output guitar you can easily drive the amp into distortion at very low volume control level settings... what counts is the actual output sound volume and specifically the voltage output going to the speaker. Once the amp reaches saturation, any further input just pushes it into distortion or "flat topping".
An oscilloscope on the output will quickly show when amp starts to flat top.

Jan 17, 2011 | Fender Hot Rod Deluxe Guitar Combo...

1 Answer

How do i connect the boss gt 10 to a fender blues deluxe amp and bypass the amps preamp


You can plug the output of the gt10 into the "power amp in" jack of the Fender. This bypasses the preamps in the Fender but uses a buffer amps in the Fender to drive the power amp. Please note that the reverb is STILL in the circuit when you do this. You can turn the reverb to zero if you wish to disable it.

Jun 09, 2010 | Fender Hot Rod Deluxe Guitar Combo...

3 Answers

Fender hot rod deluxe tube rattle.


Fender hot rod´s have an common problem on the plate resistors of the preamp and phase inverter tubes.

Check if the 100K and 82K resistors on the tube socket board are not brown. Those resistors usually need to be changed to bigger ones 1/2W.

this guy made a good document about this fix:

http://home.comcast.net/~fredholz/Justin-Holton/Fixing%20Loud%20and%20Intermittent%20Crackle%20or%20Static.pdf

Apr 01, 2010 | Fender Hot Rod Deluxe Guitar Combo...

1 Answer

My Fender Blues Deville 212 has a very "ratty" tone on clean...


i am guessing on what the problem is , the post is very vague. i am guessing a channel switching issue. you need to check the "sugar cube" looking power resistors solder welds. they are probably cracked and arent making good contact. if you tap on the amp it will cut in and out, its probably these two resistors. they are usually 470ohm 5 watt cement resistors. what happens is they get real hot, and as they cool down they crack the little solder welds. i usually replace them with new and keep them floating up over the pcb to help them stay cool and off of the board to prevent further solder weld cracking, stock they are real close to the board. then put a little silicon under the resistor to hold it in place and to keep it still on the board. i just fixed a blues deluxe with this issue. while you are in there, cut out the resistor sitting right behind the reverb pot, this will make the reverb awesome. also solder the mid pot center leg to the mid pot leg that comes off of the bass pot leg to get better midrange control. very easy mods. check the master volume pot, is it a B100K? pull it and put an A250k in its place for better volume control. bias pots , etc. check my website yostamplifier.com.

Mar 05, 2010 | Fender Hot Rod Deluxe Guitar Combo...

1 Answer

Fender Hot Rod Deluxe. Turns on, sounds very good for a little while between 2 to 10 minutes. Then the volume fades out. I replaced the power tubes and still does the same thing! PLEASE HELP!


More than likely a bad solder joint. Where is the next question. How confident are you with voltage measurments? The rails in tube amps are high and can kill you so if you are not inclined to do so please don't. The reason I suspect a solder joint is that it is a failure over time, cold solder joints expand and contract with heat. When they heat up they break connection. Not saying 100% that is your problem but it is very likley.

Dec 13, 2009 | Fender Hot Rod Deluxe Guitar Combo...

Not finding what you are looking for?
Fender Hot Rod Deluxe Guitar Combo Amplifier  Logo

414 people viewed this question

Ask a Question

Usually answered in minutes!

Top Fender Music Experts

dave nyman

Level 1 Expert

17 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

287 Answers

Are you a Fender Music Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...