Question about Onkyo TX-DS575 Receiver

5 Answers

Onkyo receiver audio problem

I have an Onkyo TX-DS575X AV receiver. The unit powers up fine, but I can no longer get any audio to the speakers. Speakers are fine, it seems the unit has some type of ouput issues. Any suggestions? Is it worth taking to get serviced?

Posted by on

  • 12 more comments 
  • Frank B Mar 29, 2008

    Same problem - display works so it is getting power but cannot get any sound. Took the cover off and lightly tapped on circuit boards and wires to see if there is something loose but could not find anything.

  • mainstayinc Apr 02, 2008

    Same problem - not getting any sound out of speakers. Everything else seems to be working fine. I purchased my DS575 online new. Worked great for two or three years. No sound ever since. I have not taken any steps to try and resolve the issue other than checking the settings on the receiver.

  • sadhelp Apr 16, 2008

    Same problem. Bought it new worked fine then stopped working after about 4 yrs. Would not buy another onkyo product. Have pushed every button on the unit.

  • Anonymous May 06, 2008

    Same problem, for a while I could leave the unit on for a little while then switch it back and forth from V1 to V2 and get sound back but now its not working at all.

  • NetStalker Jun 29, 2008

    Yep, same problem here, woke up one morning and everything looks fine, just no sound coming from speakers. Im afraid this may be the last for my Onkyo.... :(

  • Anonymous Jul 07, 2008

    Have the same problem here.

  • Anonymous Jul 08, 2008

    no sound

  • Digs01 Aug 01, 2008

    I have experienced the same issues for years. Had it fixed once and that lasted less than a year. VERY FRUSTRATING!

  • Liberalguy Nov 26, 2008

    Wow, same problem here!  I have the ts605, worked fine for a year.  Sound suddenly started going out in July.  Usually turning it off then back on, and it would work again.  But then the sound went out more frequently until it stopped working at all at the end of August.  Like others describe, the unit display works, and video continues to go through it just fine to tv, but just no AUDIO from ANY source, no matter what types of connection.


    Called Onkyo, under arranty, and I spent $120 shipping it to Onkyo's service center in Denver.  After 8 weeks, they sent it back saying they "could not duplicate failure."  Got it back plugged it in, and it worked for 3 weeks, then same thing, no audio.


    Last night, I swapped out the only cheap speaker cable I use (the center speaker), re-checked all connections, and plugged it in.  Worked for 25 minutes, then audio went out :(



  • Anonymous Dec 28, 2008

    My problem is that I the only way I can get any sound is if I have the volume turned to max, even then, I only get some sound. In addition, it seems like I only get sound out of the left speaker. Nowhere else.

  • Anonymous Dec 30, 2008

    I had a similar problem, whereupon the surround sound would stop working, or would work erratically. Solutions #2 and #4 worked like an Irish charm. Thanks for your help!

  • eebut Feb 14, 2009

    Have had a ds575 5.1 for a long time. Just recently no audio but pushing buttons seems to eventualy start the audio. Cycleing thru dsp options with dsp button seems to work the best. Am curious if any others have gone the circuit board route suggested in a couple of responses and what kind of luck they had.

  • grizAdams Mar 22, 2009

    I had the same issue, solution 3 fixed my problem. Great suggestion.

  • Anonymous Mar 29, 2014

    Unit does not Power on TX-SR508

×

5 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 2 Answers

Called Onkyo and here is the solution they gave me.

1. Turn on unit.

2. Press and hold VIDEO 1 button.

3. While pressing VIDEO 1 button, press Speaker A.

4. You should see "CLEAR" on the display for a second and the unit will go on stand-by mode.

5. Turn on the unit again and check if sound is back.

Hope this helps.

Posted on Jul 07, 2008

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

I have Found two problem which cause NO AUDIO 27-07-08
jaiki39@yahoo.com

  1. 1.Failed connection between top &bottom of circuit board NCDG-6575 (Dolby --DTS) processing board.
Near & under IC Q710

2.Failed componet IC Q710 part # LC372100PT
IF you disconnet CKT board NCDG-6575
you will get audio on speaker B left & right CH only

SOLUTION have CKT board NCDG-6575 Repaired or REPLACED

Posted on Jul 28, 2008

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

With many thanks to Jaiki I found that unseating and reconncting ckt board NCDG-6575 did the trick.

The ckt board is the smaller board right behind the front display. There is a white ribbon cable on the top of the board that you can simply pull out. Leave the rest of the connectors attached.

Posted on Dec 29, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Jaiki., unseating the ribbon connector to PCB, NCDG-6575 seems to have enabled the dolby sound! I'am still suspicious that maybe leaving the cover open for 5-10 minutes may also have had an affect on the circuit (IC chip you mentioned) . Although the enclosure where the receiver sits is reasonably vented, perhaps heat is the interrmittant factor. I'll watch that carefully and look at better cooling or replacement of the chipif that's it. Thanks again for your insite and to the great web site... brd

Posted on Dec 26, 2009

  • WFairburn Oct 04, 2010

    This worked for me, was out of comnission for 3-4 years!

×

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Hold Video 1 and Speaker A until CLEAR displays and shuts down the receiver to standby mode. Turn on using the remote and use the remote to choose modes, etc. Obviously a temporary fix but it works!

Posted on Nov 29, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My onkyo tx-ds575x lost power in a storm and now I get no audio from it. The sony bravia tv has sound but the onkyo won't send it to the speakers.


Hi,
Please reset Onkyo receiver that will solve noisy sound problem, to reset the receiver, press and hold Video-1 button on unit and press Speaker-A button. Display will show *Clear* that means receiver has been restore on default settings, turn it On and check sound.
Hope this will help.
Thanks.

Apr 06, 2011 | Onkyo Audio Players & Recorders

1 Answer

Hook cable box to this receiver


I have similar situation with my TXDS 565 and could not video out of my unit after hooking up the cables properly in and out of the unit for all auxilary modules... I assume that you have tried to place your vid IN from the cable box to your units vid IN and run a vid OUT cable or S cable to your TV. If this doesn't work for you as it did not for me, then you must run your cable direct to the TV vid IN and run your audio out from the TV audio Out back to your reciever as audio IN in the Video I or II ports on the reciever unit. This will give you audio control through the rec. unit.

I suspect that my is damaged and will not function properly; yours may be too,

My unit is about 10 years old and repair is too expensive so I will run it this way until something else fails and I will replace it... probably not Onkyo.,'

Let me know if I clearify any of this.


Jan 02, 2009 | Onkyo TX-DS575 Receiver

3 Answers

Onkyo TX-DS575X, remote intermittend malfunction


You have to raplace IR sensor PIC-26043TE2 or similar and should help.

Oct 08, 2008 | Onkyo TX-DS575 Receiver

1 Answer

ONKYO TX-DS575X - Speaker B not working


You may have blown one of the speakers. Put a different set on them to test this theory.

Dec 16, 2007 | Onkyo TX-DS575 Receiver

Not finding what you are looking for?
Onkyo TX-DS575 Receiver Logo

5,428 people viewed this question

Ask a Question

Usually answered in minutes!

Top Onkyo Audio Players & Recorders Experts

Dennis McCollum

Level 2 Expert

137 Answers

 Grubhead
Grubhead

Level 3 Expert

4751 Answers

The Knight
The Knight

Level 3 Expert

71635 Answers

Are you an Onkyo Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...