Question about Legacy - American II: 2 Channel 2000W American II Series LA-1990 Car Audio Amplifier

1 Answer

Problem with legacy amp

I got a new 2000w legacy amp, it worked for a little while but now i cant get any sound out of it. ive checked my speakers for ground problems and checked amp power and ground, nothing wrong with any of that. ??? can anyone help?

Posted by on

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Sergeant:

    An expert that has over 500 points.

  • Expert
  • 290 Answers

I would check the RCA preamp wires connecting the stereo to the amp. If these are loose or broken, it could cause you to lose your sound.

Does the amp show signs of life, such as clicking on, an LED turns on, or anything like that?

Has anything else changed between the time it worked and didn't work?

Posted on Mar 20, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Speakers "pop" on and off but no sound while its on. i turn everything on and i hear it, then nothing, and hear it when i shut it off. the amp was working fine and one time i got in the truck and they...


you could have a shorted speaker I would disconnect all speakers and test them 1 at a time to see if you can get the amp to make some sound before I did anything.

Aug 07, 2013 | Power Acoustik Car Audio & Video

1 Answer

I need to know the size of external fuses for a american legacy amp 2000 watt 2 channel 1990


25 to 30 amp fuses will work great, anything lower could possibly blow a fuse when a good bass note hits even if there is nothing wrong with the amp. Hope this helps.

Jul 09, 2010 | Legacy - American II: 2 Channel 2000W...

1 Answer

How does my bass boost remote for amplifier work


there is a slot in the amp for the one end of it it looks like a phone jack plug it in but the bass boost is asking your amp to create more power then it can so be careful with it

Apr 01, 2010 | Legacy - American II: 2 Channel 2000W...

1 Answer

My alpine pdx 1.1000 amp cuts out, the sub cuts off and the amp goes in safe mode but it does it before it even gets loud, the sub is a 2000W rms sub, why dos the amp go in to safe mode, i cant turn the...


Power is rated at 1000x1 @ 4ohm.
How many voice-coils does your speaker have? If more then one, are the coils wired in series or parallel? How many ohms are the coils? If you actuate the cone with your hand, do you hear any "scraping" sounds?
Assuming everything above is within range and or tests good, the amplifier more then likely has at least one failed output transistor. a DMM would be needed to check for shorts.

Jun 24, 2009 | Alpine PDX-1.1000 1000W x 1 Car Amplifier...

1 Answer

ICBM-DIGITAL MONO-Channel 2000W AMPLIFIER speaker much


Look into competition lines of different manufacturers.... Massive Audio DMX, Soundstream, Atomic APX, Incriminator Audio Death Penalty Series, Kicker Solo X etc. In car audio, you have to pay to play. Dont expect a 100.00 subwoofer to take 2000W continuously.
Massive Audio offers a no questions asked warranty. Even covers blown voicecoils!

Dec 21, 2008 | Performance Teknique ICBM-Digital Car...

1 Answer

Optimum sound performance needed


1) legacy products are highly overrated and i have never seen one put out the power it claims
2) if you are running the amp bridged, you need to match the impedance of the speakers to the amps highest output impedance, otherwise your system will not sound all that great...

what size fuse or fuses does your amp use? what size wire did you install with (power and ground)? did you connect direct to battery or did you connect to a fuse block or similar? did you use a stiffening capacitor? does it sound like it is clipping when you turn it up or is it just distorted? what kind of box are you using for the speakers (ported, vented, sealed, bandpass)?

if you give me the model number of your speakers and your amplifier i can probably help you more, but with the information you have provided, this is all i can offer..

hope it helps,
trin

Nov 11, 2007 | Legacy - American II: 2 Channel 2000W...

Not finding what you are looking for?
Car Audio & Video Logo

148 people viewed this question

Ask a Question

Usually answered in minutes!

Top Legacy Car Audio & Video Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

isaac johny
isaac johny

Level 3 Expert

796 Answers

xxxxxx xxx

Level 3 Expert

4724 Answers

Are you a Legacy Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...