Question about Vacuums

1 Answer

Engine troubles I have a 1975 4x4 GMC full size van. The motor is a 350 cid small block on propane. The thing hadn't been running in 5 years and when I tuned it up I changed vacuum advance pod on HEI distributor and hooked to a better vacuum and now the hotter it gets the faster it idols and when I try and turn the timing back, it starts hard. Wondering if vacuum is too strong or what is up?

Posted by on

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I haven't fixed it yet but I think I might have a solution for it. From the factory this thing had a 4 barrel carb and they put an equivalent size atomizer in it for the propane and over the years someone omitted the EGR system in it and propane is already a hot burning fuel so without that system in it it picks up idol speed when under normal operating conditions and when I put the system back in it should fix the problem...... I hope. thanks for quick response. Grant

Posted on Mar 21, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Bissell 6591 operating twice as loud as before.


Hey Mike! Excessive noise can be contributed to dirty filters or clogs. Here's a quick link to troubleshooting steps to assist you.

http://www.bissell.com/FAQDetail.aspx?id=1421&cid=ccsocial

Feb 03, 2013 | Bissell 6591 Power Trak Revolution Bagless...

1 Answer

BISSLL 7700 NOT RELEASING WATER


Make sure the hose solution line is connected, wet clean button is pressed, look for two small o-rings on the end of the fitted end of the hose solution line, and run the machine for 5 minutes with all three buttons engaged to dislodge any clogs from the heater.

Here's a link to one of our BISSELL Authorized Service Center if you continue to have difficulty.

http://www.bissell.com/service-centers/?cid=ccsocial

Nov 13, 2012 | Bissell 7700 Big Green Complete Vacuum,...

1 Answer

Carpet beater not turning on, rest of vacuum ok, reset button down


Is the PN motor not working, or just the brush not spinning. If it's the brush, a new belt is needed.
If the motor isn't working, it could be due to several things. Follow the trouble shooting steps below.
1. Check all connections from hose handle to PN for discoloration. Any parts showing discoloration or melted plastic need to be replaced.
2. Attach PN directly to the hose. If the motor works, there's a problem in the wand wiring/connections.
3. Attach the Sidekick directly to the hose. If it works, but the full sized PN doesn't, there's a problem in the PN. Problems could include: wiring, connections, bad motor, bad switch.
4. If neither Sidekick nor PN work, the problem is likely in the hose. Potential problems include: bad wiring, connections, or bad switch.
5. You can try another hose known to be good to test the PN. If it still doesn't work, the problem could be in the canister itself.

I strongly recommend taking it to an authorized Aerus Electrolux store for diagnosis and repair if needed.

http://www.aerushome.com/storelocator/

Apr 09, 2011 | Electrolux Epic 6500 Vacuum

1 Answer

We have a Kenmore Progressive Model 116 Upright bagged vacuum with Hepa filter. It's at least a couple years old. For quite some time now when ever we use the vacuum the vacuum motor will shut off nafter...


I suspect that you have a restriction. The motor sounds like the thermal break is stopping the motor before damage, due to heat.
You must witness that the entire suction and discharge side are clear. This is not always very easy, but necessary. I bet that you find something blocking somewhere...

Nov 13, 2010 | Kenmore 34612 Bagged Upright Vacuum

1 Answer

Dyson runs about 5 min then shuts off


REMOVE AND CLEAN FILTERS AND YOU MAY FIND IT WILL WORK OK IF STILL CUTS OUT YOU MAY HAVE A FAULTY THERMAL CUT OUT BLOCK INSIDE THE MOTOR HOUSING
THIS HAPENS WHEN DYSON IS USED WITH CLOGGED FILTERS AND HEAT DAMAGE TO THERMAL BLOCK

AVERAGE REPAIR COST £45 - £ 69 FOR NEW REPLACEMENT

Jul 11, 2010 | Dyson DC14 Full Gear Bagless Upright...

1 Answer

I need the fuel/gas mixture for a small (12") McCulloch Chain Saw. It has a 2.0 C.I.D. label with Fuel Mix I lnoted at the fuel cap. ja


The 2.0 CID is Cubic Inch Displacement, the size of your motor. As for fuel mixture, generally a 50:1 is a benchmark for this. Typically, it should be 1 gal. of gas for 2.56 oz. of two stroke oil. They sell pre-packaged, pre-measured oil at your local DIY shop or lawn mower repair shop.

Jan 18, 2010 | McCulloch MC1275 Steam Vacuum

1 Answer

Hello, I have a problem with my Eureka Powerline bagged upright vacuum. It has a 12 amp motor and is model #4352, Type D. It was probably bought new in 1998. My problem is, while vacuuming today the motor...


it sounds like a rubber sealing in the motor has come loose and is being constantly rubbed against the walls of the motor with would cause the smell and loss of motor speed caused by the fricton of rubber against the rod so if you can get to the motor try to open it and see if you can get it if not take it to a small engine repair service hope this was helpful:)

Nov 16, 2009 | Vacuums

1 Answer

My filterqueen majestic is 10yrs old and just started to spark and smell of burning ive took it apart


If you have a burning smell from the motor, your motor is shot. You should be able to buy anew AMTEK Lamb motor for about $85-110 US. Request a double ball bearing motor as it will have a longer life span.
Also buy a fresh internal filter kit. There will be a small 5 .5 inch filter disc inside the cone protecting the motor in the event that the cone tears. Replace it .Also save and reinstall the small insulating disc that sits between the top of your motor and the screen at the top of the vac. This is to prevent electric shock. This disc is the size of a coin.
Post back if you need more help. Wiring is very easy. Do NOT twist your wires before installing into the connectors, twist the connectors, then tape to be certain they are on tight.

Nov 04, 2009 | Filter Queen Majestic Canister Vacuum

1 Answer

Aerus Model 152C- vacuum doesn't run


it probably does think you have a full bag.make sure you have it cleaned out and has a bag in there or it might be the sensor for the vacuum and is not working properly. contact your nearest electrolux vac store.or you are not using proper bags.

Jun 28, 2009 | Electrolux Vacuums

Not finding what you are looking for?
Vacuums Logo

Related Topics:

23 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18297 Answers

Roger Potts

Level 3 Expert

694 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...