Question about Mitsubishi WD-52525 52" Rear Projection HDTV

2 Answers

We have sound but no picture - Mitsubishi WD-52525 52" Rear Projection HDTV

Posted by on

  • 9 more comments 
  • wla1cxs Mar 22, 2008

    I have sound but no picture, if I unplug the TV, wait a few minutes, than plug it back in, that seems to work, also looking for a solution?

  • cdacosta Aug 05, 2008

    I have sound but no picture

  • Anonymous Sep 13, 2008

    55711 - Same issue. Could you break in down in laymans terms?

  • Anonymous Sep 13, 2008

    55711 - same issue. could you dumb this down for us. Is this something easy to do?

  • Larry DiTizio Dec 03, 2008

    I have same problem and it is not the lamp. I checked the voltage with a meter where the lamp plgs in and have 60.5 volts AC. I would think the voltgae should be higher than this.



    Any help is appreciated

  • deese_ashley Jan 05, 2009

    deese_ashley@yahoo.com
    please help!!!! wd-52525 mitsubishi hdtv. I have no picture just sound. Sometimes picutre is just green and squigley not really a picture at all.

  • meandmacie Jan 19, 2009

    I have sound, but no picture, The tv is just a few years old, Thanks! I have a toshiba 50A6Z

  • Anonymous Jan 27, 2009

    sound but no picture mitsubishi wd-52531

  • dorislorna Feb 10, 2009

    Mitsubishi WS-48413 rear projection HDTV has sound but no picture, only black screen

  • waynedrum Feb 13, 2009

    mitsubishi 65" sound but no picture and then after 2 minutes set shuts off. When I turn it back on it gets sound but again shuts off in 2 minutes with no picture ever. Only 2 years old

  • Anglori Feb 20, 2009

    I have an rca 50 inch hdtv that has sound but no picture



×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I have sound but no picture. Just red,green,and blue lines

Posted on Nov 29, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Mitsubishi Master
  • 8,617 Answers

TA connecter loose, No Vcc to IC2K01,
IC9C00, IC9C10, IC9C20

Posted on Mar 28, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

TV goes blank - no sound or picture


Sounds like a bad capacitor or two in the power section. Do you hear a hissing sound also?

Nov 18, 2009 | Pioneer PRO-510HD 53" Rear Projection...

2 Answers

I have a 46" DLP TV, I have sound but no picture. But I can play a DVD, and it works fine.


Does the dvd have picture when playing or no picture no matter what?

You can try switching cables.

Do you know if the screen is on?

May 11, 2008 | Projection Televisions

Tip

SONY GRAND WEGA ERROR CODES AND WHAT THAY ARE


Lamp cover error 3 times - Lamp cover is not fastened securely - No picture/No sound

Fan error 4 times
- Fan1-4 Power is not supplied.(G2 board)
- Fan connector is not seated securely
- Fan caught wires or harnesses
- No picture/No sound

Temp error 4 times
- Internal temperature is too high
- IIC-E line connector is not seated properly
(WE:H3 board, WF/XS:H4 board)
- No picture/No sound

Lamp driver error 5 times - Lamp driver defect - No picture/No sound

Low B error 6 times -No "DD 6V " output (G1 board) - No picture/No sound

Audio error 7 times
- Short-circuit of Audio power supply line
(KD board, G1 board)
- Blowout of a fuse
(F4702,F4703,F4704 on KD board)
- IC failure
(IC4703,IC4708,IC4710 on KD board)
- No picture/No sound

D-OVP error 8 times
- Overvoltage of +3.3V or +2.5V
(A board, B board)
- No picture/No sound

ATSC-OVP error 10 times
-No "DTL MODULE 5V " output
(G1 board, G2 board)
- No picture/No sound

Lamp error LAMP-LED is ON. - Lamp is dead - No picture/No sound

on Apr 13, 2009 | Sony Grand WEGA KDF-42WE655 42" Rear...

1 Answer

When sound & picture finally comes on the picture is pink and in the middle of the screen


This is a common problem with this model. The site www.magnavoxhelp.com has a chip kit to fix the no audio/video and video shrinking problem. 

Sep 06, 2008 | Philips Magnavox 9P6034C 60" Rear...

1 Answer

Turned tv on got picture and sound,turned sound down lost picture now can only get sound and no picture


Sounds like a loose video connection. Try re-attaching your cables. Also, see if the same thing is happening with DVD's

Aug 24, 2008 | Projection Televisions

1 Answer

Hi again


yes 3x its lamp cover no doubt. ballast supply will give different error on this unit. this should help hdtv man

Diagnostic Item
Description
Number of times
STANDBY or LAMP LED
lamp flashes
Probable Cause Detected Symptoms
Lamp cover error 3 times - Lamp cover is not fastened securely - No picture/No sound
Fan error 4 times
- Fan1-4 Power is not supplied.(G2 board)
- Fan connector is not seated securely
- Fan caught wires or harnesses
- No picture/No sound
Temp error 4 times
- Internal temperature is too high
- IIC-E line connector is not seated properly
(WE:H3 board, WF/XS:H4 board)
- No picture/No sound
Lamp driver error 5 times - Lamp driver defect - No picture/No sound
Low B error 6 times -No "DD 6V " output (G1 board) - No picture/No sound
Audio error 7 times
- Short-circuit of Audio power supply line
(KD board, G1 board)
- Blowout of a fuse
(F4702,F4703,F4704 on KD board)
- IC failure
(IC4703,IC4708,IC4710 on KD board)
- No picture/No sound
D-OVP error 8 times
- Overvoltage of +3.3V or +2.5V
(A board, B board)
- No picture/No sound
ATSC-OVP error 10 times
-No "DTL MODULE 5V " output
(G1 board, G2 board)
- No picture/No sound
Lamp error LAMP-LED is ON. - Lamp is dead - No picture/No sound

Jul 01, 2008 | Sony Grand WEGA KDF-42WE655 42" Rear...

5 Answers

No picture but has sound


My LG TV
switch on no picture but short period of sound then nothing

Jan 20, 2008 | Sony KP-51HW40 51" Rear Projection...

4 Answers

TV Picture Goes Black


I had the same exact problem.
I removed the bulb and cleaned it. There is a small screen at the top of the bulb and it was covered with dust. Once it was cleaned I replaced the bulb and it solved the problem.
Thanks to those who posted the solutions

Jul 28, 2007 | Sony Grand WEGA KDF-60WF655 60" Rear...

Not finding what you are looking for?
Mitsubishi WD-52525 52" Rear Projection HDTV Logo

Related Topics:

70 people viewed this question

Ask a Question

Usually answered in minutes!

Top Mitsubishi Projection Televisions Experts

matt martin
matt martin

Level 3 Expert

1191 Answers

Jaime Hernandez

Level 3 Expert

2267 Answers

The Knight
The Knight

Level 3 Expert

68250 Answers

Are you a Mitsubishi Projection Television Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...