Question about EliteGroup (ECS 915PL-A2) Motherboard

1 Answer

Checked all of those...any other thoughts?

Great response, but I've checked all of those. Any other thoughts?
Thanks! Stephen

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 2,351 Answers

Http://www.fixya.com/support/t444871-915pl_a2_no_post_no_beep_no_keyboard

Lets address the video. Display is more important.
If your only using one PCI-E you do not need to plug in the 4-pin power connector pg. 20 in manual, see notes no# 4.
However it is unclear if this is true by reading your manual.
On other boards the 4-pin 12v power connector is not needed un less you are running 2 PCI-E cards.
(You will have to test this statment).
Disconnect the power connector pg. 20 in manual, see notes no# 4.
Remove your installed PCI-E1 video card & re-seat it, (making sure it is seated evenly). (If you have a second PCI-E card do not install it.
Start PC & enter bios. Check that your bios is set to PCI-E for video display & not VGA. Pg. 32.
While in the bios disable the audio. (for now).
Set Plug & play Aware O/S, to No. (This allows the bios to set IRQ's rather than windows).
Save & re-start the PC. Did you get video? No?
Shut down the PC & connect the 4-pin 12v connector for the PCI-E1. Start the PC. Did you get video display?
Other reasons for not to getting video display.
CPU not seated correctly / bad or bent pin. Socket locking arm not engaged. Thermal grease not applied. HeatSink not locked.
1. Video card needs cleaned. (use house hold Alcohol & cotton sawbs). Clean copper contacts. Clean out PCI-E slot.
2. There may be a short between the board & the case.
3. Connection is loose, (either end of the video cable).
4. Connected to the wrong video out-put. (Switch cable to second video out put on a dual out port card).
5. Have a bad video card. (Swap it if you got another).

Memory check.
1.Can include not correct voltage for board.
(you'rs must be 2.5v). No higher.
Over clocking memory in bios. (Set to Auto)
3. Bad DIMM. (remove one DIMM if two is installed), (swap slots in-between restarts).
4. Download free Memory Tester (click the link).
http://www.memtest.org/

Give the stuff above a try Stephen.
It's late & I'm wired.
Have a good day!

Posted on Mar 18, 2008

  • Mike Peluso
    Mike Peluso Mar 20, 2008

    All out of options. ;-{

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Have Singer 2000. Repaired some jeans last week worked great Today it will not pull the fabric . Feed dogs do not seem to be working. Cleaned dust ect. from bobbin area. New thread in bobbin and...


Is it possible that the machine is set to "Buttonhole"? That will disable the feed dogs so you can make the buttonhole the desired size, on most machines. Try selecting a different setting on this machine. it looks very intricate to me and seems to me it shouldn't give any trouble, so a setting is my thought.
Hope this is of help, Please rate and comment, Thank You,
Joe

Sep 01, 2011 | Motherboards

1 Answer

Hello There: I have an Acer Monitor in Canada. Will this also work in the Philippines re they are 220 voltage? Thanks David The Monitor is a AL1706


You'll likely have to use a power converter that will convert from 220 back down to 110 (along with the plug differences).
Here are two links to two different quality products that should work for you:
Kensington http://www.amazon.com/Kensington-33117-International-Travel-Adapter/dp/B0002H4YUI
Targus http://www.amazon.com/gp/offer-listing/B00004Y7M3/sr=/qid=/ref=olp_tab_new?ie=UTF8&coliid=&me=&qid=&sr=&seller=&colid=&condition=new
I hope this response helps you out.
I wish you the very best of luck! If I can help you further, please let me know.
I strive for '4 Thumbs Up'! If I've assisted you, I'd greatly appreciate you taking the time to provide me with a favorable rating. Thanks so much!

Jun 28, 2011 | Acer Motherboards

1 Answer

My pc and Imac can't detect my hitachi Neso N2501s.1 external hard disk, the light on the hard disk is on and the fan is running but they can't detect i've even try it on other pc but no...


there something wrong with hitachi neso cord, the one you used to connect from hitachi neso to your pc or imac, try to purchase new cord.

Jun 22, 2011 | Motherboards

2 Answers

How to make a resume?


In terms of how, as in how to make the document itself? You're going to want at least a word processor. OpenOffice works wonders if you don't have Microsoft Office.

In terms of what to put in it? To simplify, you want to let the employer know what you've done, where you've been, with some specifics in a page or two.

For a bettter and more detailed explaination, read this article. It's great!

May 23, 2011 | Motherboards

1 Answer

I'm wanting to upgrade the RAM in my Dell Opti[plex GX620. The code on the motherboard is CN-0HH807-13740-632-030S. Any help would be greatly appreciated. Thanks


HI there Stephen,

Your Dell Optiplex GX620 has four memory slots which can accomodate a maximum of 4GB (DDR2). For the full information you can click the link below:

http://www.dell.com/us/en/dfh/desktops/optix_gx620/pd.aspx?refid=optix_gx620&cs=22&s=dfh

Please let me know if this answers your question. Thank you for using FixYa.

Dec 16, 2010 | Dell (J2628) Motherboard

1 Answer

Which can i conect the LED on the motherboar


As soon as power is switched on, mains via the UPS, the LED glows indicating that the MB is ready for action, plus an indication that the SMPS, internal power supply, responsible for converting the AC to DC(12V, 5 V & 3.3 V, both(+ve & -ve), IS working for the MB(3.3V supply to the MB) & the MB has successfully passed POST(only MB), ready for action.
I hope this is your query, else clarify the problem you are facing by posting it as a comment and I'll modify(try) the soln...........sodeep

Oct 26, 2009 | HP (D7580-60003) Motherboard

1 Answer

Cooler CPU Fan


Here is a list of the compatible CPUs. Is yours on the list? Did it come with the CPU installed? Steve Medley C:\Users\Stephen J. Medley\Documents\Downloads\200811030909521886G31MV-CPU-A85.mht

Nov 16, 2008 | Motherboards

2 Answers

Jumper setting on motherboard


Hi,
You could,nt find it Because It,s listed under Archive Boards.
I think this Is what your looking For, You can also download Drivers Et,c.
Please don,t forget to Rate This Post, Once you,ve Fixed Your Problem.

Many Thanks Mike @ Compurepair.

Posted @ 21.48PM ( G.M.T )

Mar 05, 2008 | Motherboards

2 Answers

Worked great until last night....


hi put some exhaust fans in the case see if this will help youi had this happen to me a few times add fans and als wellremember you still have your chip set on your mother board they do not have fans and need to be cooled too

Nov 03, 2007 | ASUS A8N32-SLI Deluxe Motherboard

Not finding what you are looking for?
EliteGroup (ECS 915PL-A2) Motherboard Logo

43 people viewed this question

Ask a Question

Usually answered in minutes!

Top EliteGroup Motherboards Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers

Mark Taylor
Mark Taylor

Level 3 Expert

728 Answers

Michael Thomas
Michael Thomas

Level 3 Expert

3051 Answers

Are you an EliteGroup Motherboard Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...