Question about Audio Players & Recorders

1 Answer

Parts for Technics SE A900S Audio Power Amplifier

Looking for IC Voltage Amp AN7062N for Technics SE A900S

Posted by on

  • 5 more comments 
  • sratra Mar 13, 2008

    Need an IC Voltage Amp Part No. AN7062N for Technics SE A900S

  • sratra Oct 13, 2008

    Need IC V-AMP Part No. RSN600A - Make: Panasonic

  • sratra Oct 13, 2008

    I now need the following part:
    Panasonic IC V-AMP Part # RSN6000A.
    Pl help me find it.


  • sratra Oct 31, 2008

    I have a Technics Pre Amp Model SU-C800UE-K, that gets power from the matching Power Amp SE A900S through a special cable provided for the purpose. I now need to replace the Power Amp due to its malfunctions.
    Is it possible to run this pre-amp without the said power Amp? I envisage purchasing BRYSTON 3B SST to replace the defective SE A900S.

  • Anonymous Mar 15, 2014

    i am told the output moduale is faulty and csnt be repared

  • Anonymous Mar 15, 2014

    the output moduale is haulty all i get is a loud buzz then shuts down

  • Anonymous Mar 15, 2014

    i am told it has a output moduale faulty,iget a loud buzz then shuts down.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 807 Answers

Here ya go.
http://www.vancebaldwin.com/products/?MSCAN7062

Posted on Mar 13, 2008

  • 1 more comment 
  • Stuart
    Stuart Mar 13, 2008

    Also this one.
    http://littlediode.com/components/catalo...

  • Stuart
    Stuart Oct 14, 2008

    The only one I can find at the minute is on a Polish website. I copied the web address below and pasted it in to Googles Translator from Polish to English. You can may be figure out a way to contact them about it. The address is:
    http://sklep.north.pl/szukaj/szukaj.php?...

    The translated address is here:
    http://translate.google.co.uk/translate?...

    Make sure you copy and paste all of it up to and including the final 8

    Will still look around for more sources.


  • Stuart
    Stuart Nov 01, 2008

    As long as the output signals from the pre-amp are ok for the power amp, they should be if you can work out which wires from the pre-amp goto which inputs on the power amp. The only other thing is to find out the voltage from the original power amp that powered the pre-amp and get an equivelent power supply. It may be 6v, 9v, 12v etc. You will also need to find out the current requirement for the pre-amp. That may be in milliamps something like 500ma or even 1amp or more. If it's not correct the pre-amp will try to take the power it needs from the supply and if the supply is not strong enough it will burn out or blow any fuses in it. If you have the user manuals it may tell you in the specifications.
    I have a service manual for the power amp but not for the pre-amp.




×

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I will buy a Technics se a900s amplifier, but


I think you are saying you want to connect the amp and use it's vu meters but not connect it to speakers?
Presumably you are already well catered for in the matter of amplification but lacking good vu meters?

There is a fair amount of information about this premium amp online including operating and service manuals that can provide a better answer than I can.

One note of caution; it is generally bad practice to operate a power amplifier without a load at the output and it might damage the amplifier. If it is desired to operate it without speakers providing the load, dummy loads are available.

I suggest you have a look through ebay or Amazon where you might find digital or analogue vu meters at a reasonable cost or alternatively I believe computer software could turn your laptop into vu meters.

May 11, 2016 | Technics Audio Players & Recorders

1 Answer

Good day i have a Technics amplifier SU-X320. Problem is it powers up up there is no sound. Checked all basic fault finding, suspect it is the volume IC.


"Volume IC" do you mean an IC that is a pre-amp and controls the volume and things like tone? Or do you mean the main power amp IC, which will be on the big heat sink?
If you amp uses the latter and not individual separate devices for the power amp, suspect that over the other IC. But if the amp has separate power amps for both channels, replace the IC.

Oct 09, 2013 | Technics Audio Players & Recorders

1 Answer

Technics Amplifier SU-V4


The clicking sound will be a relay for the protection circuit. That could be faulty, but first check out the main devices on the main amp section. Those attached to the big heat sink. If you see a single IC amp that could well be faulty.

Oct 04, 2013 | Audio Players & Recorders

1 Answer

After 10 years of function a problem appears with the technics se-a900s power amplifier: When the power output reaches or aprox the 10wrms the protection circuit enabled,and the unit goes off! (no...


I would have the power supply capacitors replaced. After several years ( from heat and age) they dry out and dont put out proper DC voltages to run the amp.

Oct 11, 2010 | Audio Players & Recorders

1 Answer

Technics amp SU-X999. I need an output I.C type SVI-4004


NAother option is to fix a universal amplifier kit into the set which powers from the same voltage preferrably a MOSFET drive which are very much available in the market and can be suited into the set. They will alos be very effficient but take care tto do the fixing mechanically , connecct the right power and groung with good shielding. Disconnect the old amp totally and use the power lines that come to the IC. I hope this works for you. Good day

Jul 30, 2010 | Technics Audio Players & Recorders

1 Answer

I have a technics amplifier model SU-G75, it will power on but it will not play any of the equipments that is attached to it


You have basically the same problem as a chap with another amp on this site. So here's what I told him:
"You need to determine if the power is getting to the audio amp section. For instance with the volume full up is it humming etc?
As a 'rule' it's unlikely that both left and right channels will fail at the same time (unless you have done something silly with the amp) you are looking for something that is common to both channels. Which is why the power section is first suspect. The exception to the rule (above) is where amps use say an IC power amp for both channels. You will find this IC on the big heat sink. Check whatever is on that anyway for damage or burning.
The only other area could be the pre-amp part. Again this could be a single IC controling both channels, so it's failure could cause a loss of sound. By the way if you can hear music/sound coming through when you put it up to full volume the pre-amp will be generaly good. "

Nov 23, 2009 | Audio Players & Recorders

2 Answers

I need a cooling fan for my su g50 where can I get one web site maby


The fan assembly can be purchased from tritronicsinc,com (use the guest account) for $24.31 using part number SYE1128-4


Dan

Jul 11, 2009 | Technics Audio Players & Recorders

1 Answer

Technics SU-V98 No Sound


If I understand your posting correctly, the amp works using the Aux In connectors but not using the VCR1 even when VCR1 is selected correct? If that is the case, there is an internal electronic switching IC (TA9263 I think) that may be defective. This is not a complex repair and can be confirmed easily by any shop that does audio repair. They will trace the incoming signal with an oscilloscope to the IC and see nothing come out when VCR1 is selected. The IC costs less than $10.

Dan

Feb 05, 2009 | Technics SUV500 2-Channel Amplifier

2 Answers

TECHNICS SU-V50


Hi max

I have done a followup with Technics Parts agents in the US, they will get back to me and then me to you shortly :) A vote as FixYa would help improve my ratings. Thanks

Graeme

Feb 06, 2008 | Technics SUV500 2-Channel Amplifier

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

1,860 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

98608 Answers

 Grubhead
Grubhead

Level 3 Expert

4678 Answers

The Knight
The Knight

Level 3 Expert

69570 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...