Question about E-Machines eMachines Refurbished EMA SYSTEM BOARD MODEL T2984 eMachines (102257) PC Desktop

5 Answers

Dead motherboard on emachines t2984

I have a emachines t2984 that wont power up. Took it to local shop and was told that the motherboard had to be replaced. I thought it was the power supply but they installed a new one and still didn't power up.

I'm not really sure it's the motherboard. What else could be wrong?

Posted by on

  • 8 more comments 
  • ljbltd Mar 12, 2008

    how can i fix a bad power switch?

  • ljbltd Mar 12, 2008

    It's not the power supply. It's the motherboard. Where can I get a replacement? What should I look for?



    Thank you in advance

  • Sooty99 Jun 16, 2008

    I have an Emachines t-2984. It just shut down when it was up and running and will not start up. I suspect that the power supply went out, however after reading about the power supplies, does anyone know what the chances are that the mother board did not fry? I hate to waste the time or money on a computer that I am not going to replace the mother board on. However if there is a chance that it is just the power supply, it's worth it to try and get it going.




  • checchelin Jun 22, 2008

    I replaced the power supplay in the eMachines T2984 and have a green led on the motherboard turn ON. but the computer not turn on when I press the

    from button.

  • 512kent Oct 17, 2008

    I have the exact same problem. The computer quit working. I replaced the power supply, and now I only get a green LED on the board. I have contacted both Intel and eMachine, and neither want to do anything because it is out of warranty. I am thinking about buying a replacement motherboard off ebay. Does anyone know if this will fix the issue, or will I be wasting my time and money?

  • vomommy Dec 06, 2008

    My T2984 was running perfectly, then after I turned the unit off one day it just wouldn't come back on. Nothing. Not a hum, or a flicker, or anything. I thought it was the power supply so I switched it out and there is that little green light but nothing else. Has ANYONE figured this out? Does this sound like the motherboard? Have I lost all my data? Uggggh!

  • Anonymous Jan 03, 2009

    My power flickered in the house, the computer went dead and now cannot be turned on. I tried a new power supply and same thing regarding the small green light. Power button does nothing. Is there any detail regarding this capacitor that goes bad or does the mother board need to be replaced?

  • junkEachines Feb 03, 2009

    4 yr old T2984 working ok until pwr company dropped power. Even though the computer was plugged into a APC UPS, the computer would not come on when the power was restored. Just the infamous "little green light" everyone else has experienced. A specialized service shop looked at the machines, did all their magic (claim they can fix motherboards...in this case the Intel Seabreeze) but no-go. Capacitors or CPU not problem. Diagnosis> dead component somewhere in motherborad. To costly to get into MB repair. Total junk. This baby will not even make a good boat anchor for a small canoe.

  • tklosr Feb 06, 2009

    Same problem! T2984 found dead after my wonderful husband shut off the electricity a few times to install electrical in another part of the house. Replaced the power supply & got a green light, but nothing. Replaced the motherboard, nothing. Anyone know where to find a new power switch wire??

  • myfam Feb 20, 2009

    This same occurred to my sister in summer of '08

    Is anybodys system still under warrenty with E-machine? mine is not, i tried the emachine support and got hung-up on twice - they referr to it as call disconnected. I'm going the intel route to see if i get any further. This is too many people with the same machine and the same problem to be chance.

×

5 Answers

Contacted emachine and they are completely denying this and told me that since the warranty is out of date, there isn't anything they can do. Never was any recall on this model.

Posted on Apr 08, 2008

It's not a power switch or a power supply failure, a capacitor has gone bad. I have the exact same problem with another eMachine, the T2984's have been recalled due to residue buildup in their capacitors which results in a failure to turn on. here's the artice..
http://www.intel.com/cd/channel/reseller/asmo-na/eng/tech_reference/box_desktop/int_inst_info/dsk_factory_notes/193414.htm

Posted on Apr 08, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,601 Answers

I hope that you took it back to them.
Have them check the power supply, too. Besides, a bad power switch and connections that would be the only thing that would be keep it from starting.

Posted on Mar 12, 2008

  • Thomas Christopher
    Thomas Christopher Mar 12, 2008

    You will have to take it out to see which part of it is broken.You may have to replace it

  • Thomas Christopher
    Thomas Christopher Mar 12, 2008

    You should be able to fit any ATX board in the case.

×

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

I am having he same power up problem. Not the power supply - checked with a different supply. Bypassed the on/off button and that did nothing. Tried clearing the CMOS by removing battery and moving jumper near the battery. That didn't work either. Any other ideas?

Posted on Jul 19, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

I am TOTALLY suing the Hell out of emachines!!

Not only did they cause me IMMENSE and inexplicable amounts of emotional and mental distress, but financial as well!!!

I have a T5082 and the power supply went out, replaced that and then 3 days later it won't turn on at all!!

GRRRR!!

I NEED my internet, not only that, I have a 2 and 4 year old that use it so they can learn and get off my back as well!

I also have Vista (Yuck, I know, but this is our 1st computer and I didn't know any better!!) For God's sake!! The transmission wento out on the car, the only other T.V. is broken, I can't really leave or watch anything, I'm a frickin' bored *** prisoner over here!!

What isn God's name do I do?!?1

OH! I am also EXTREMELY BROKE and have to use the damn library internet with their stupid time limits!!!!

Posted on Nov 06, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

IM connecting a OKIA LC-8460BTX POWER SUPPLY TO MY EMACHINES T2984. I cannt figure out where the wires are placed.


There should be a photo of the board and instruction on where the leads are fitted if you browse the manufacturers web site and input the model of the unit you are refitting.

I have found this site, which may be of use to you. Regards.
http://www.techsupportforum.com/hardware-support/motherboards-bios-cpu/302350-e-machine-t2984-motherboard.html

Jan 04, 2011 | E-Machines eMachines Refurbished EMA...

1 Answer

Wont start emachine 4260


FIRST OF ALL NEVER GO INTO BIOS UNLESS YOU KNOW WHAT YOU ARE DOING!SET YOUR BIOS TO DEFAULT SETTINGS,I HOPE YOU DID NOT TRY TO OVER CLOCK YOUR COMPUTER.SO MY ADVICE IS TO TAKE IT TO YOU LOCAL COMPUTER REPAIR SHOP AND TELL THEM YOUR PROBLEM AND THAT YOU WENT INTO BIOS.HOPE THIS HELPS BYE

Nov 27, 2009 | E-Machines eMachines Refurbished EMA...

1 Answer

T2984 won't power up


I've re[lace alot of bad eMacines power supplies. Nearly all of them took out the video chip on the mother baord, rendering it useless.

Mar 23, 2009 | E-Machines eMachines Refurbished EMA...

1 Answer

2 emachines won't boot


Are you attaching them properly
if so then it is something other then power supply
something has caused both power supplies to blow
have you installed anything in the first emachine you talk about

Jan 17, 2009 | E-Machines eMachines Refurbished EMA...

1 Answer

I have an emachine T2984 that won't boot. No noise of any kind. I had another emachine T2625 that was working. I took the power supply out of the T2984 (that wouldn't boot) and put it in the T2625 and it...


Power supply sounds fine. If the pc won't power up it could be your motherboard. If the pc is powering up and you get a 'no signal' on your monitor it could be your gpu.

Jan 17, 2009 | E-Machines eMachines Refurbished EMA...

2 Answers

Emachine T2984 won't power up


First, Check your ram. If not seated, it will not power up. Also, do you hear a series of beeps or not? Need a better & more exact description of problem and what occurs

Apr 14, 2008 | E-Machines eMachines Refurbished EMA...

1 Answer

Emachines t2984 that wont power up


Make sure the RAM is seated properly and recognized by the coputer bios program.

Mar 25, 2008 | E-Machines eMachines Refurbished EMA...

1 Answer

Where can I get a replacement motherboard for emachine T2984?


Here is a site where you can buy one for a relatively good price....hope it works out.

Mar 12, 2008 | E-Machines eMachines Desktop PC

4 Answers

Motherboard manuel


i need manual for motherboard 14319 imperial_gv 20030812 thankz

Dec 25, 2007 | E-Machines eMachines Refurbished EMA...

Not finding what you are looking for?
E-Machines eMachines Refurbished EMA SYSTEM BOARD MODEL T2984 eMachines (102257) PC Desktop Logo

2,869 people viewed this question

Ask a Question

Usually answered in minutes!

Top E-Machines Computers & Internet Experts

Brian Sullivan
Brian Sullivan

Level 3 Expert

27725 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18333 Answers

Are you an E-Machines Computer and Internet Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...