Question about Toshiba 43H70 43" Rear Projection Television

1 Answer

Help still have problem i`ve done what you said and still same thing when i turn it on i can see the guns are lit but no image comes on if i give chasses a tap it come on and bliks like crazy can you help any more? thanks

Posted by on

  • Rob McCutcheon
    Rob McCutcheon Sep 20, 2008

    yes this work for a bit but it ran for a week now back too the same thing again...what can it be this time

    thanks

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Toshiba Master
  • 8,617 Answers

You have got to have a cold or cracked solder joint. Get a strong light and go over the chassis with a magnifying glass. Solder everything that doesnt look shiny but be looking for hairline cracks in the solder especially near the vertical output IC and associated components.

Posted on Mar 12, 2008

  • Sonny Berry
    Sonny Berry Sep 20, 2008

    Still got to be a solder issue.

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

See doble image in my elementos t.v what i can do about it


First thing to try is a convergence. This may have to be done manually. Convergence is aligning the color guns so they lay on top of each other perfectly. You may have an auto converge but you will have to check in your set up menu.

May 01, 2016 | Projection Televisions

1 Answer

Hi! Thank you for your help. I have a Samsung TV


Hi Doug Rudnik,

First of all thank you for contacting Fixya.com regarding on your TV problem.

You've mentioned that you can hear a sound for 1 sec and then the unit immediately turned off and there's a constant red LED lit. The symptoms you've described indicates that the main board of your unit is working fine and it automatically shuts off because it sensed malfunction on image boards. The constant red LED means that it is on standby mode only.

Now, since you've replaced the power supply board but still the symptoms persist, then the suspect is either the X or Y sustain board but high chance that the fault came from the Y sustain board based on my experienced. Y sustain board is located on the left side of your unit while the X sustain board is on the right side if you are facing the rear cover. These boards has a ceramic fuse(white color) and pico fuse(looks like resistor), please check the continuity of the fuses to determine which board gone to malfunction. If you found an open fuse to Y-sustain board then you need to replaced it. Blown fuse means that the circuitry on its line gone to excessive current.

I would advice you also to inspect the electrolytic capacitors on these boards. Most of the time loud pop came from a blown capacitor and has a physical indication of fault like bulged/dome at the top and can be easily identify through visual inspection. It can give you an idea also which board gone to malfunction. See sample picture below of faulty electrolytic capacitor with bulged dome at the top.




12_6_2011_7_37_13_am.jpg

Here's the link for X and Y sustain board.

Y sustain board

X sustain board



Hope I've gave you an idea what's going wrong to your set.

Have a nice day and take care!

Kind Regards,

Jdvillanueva

Dec 06, 2011 | Samsung Projection Televisions

1 Answer

When I turn on my Philips rear projection tv, the power comes on but no picture or sound. power light stays lit solid. If i adjust slowly the screen or focus controls, the picture and sound will come on....


could be a number of things....check for bad solder connections on circuit board around Flyback xformer and also check connections on conversion module for colour problems....double images red , blue , green popping in and out.

May 19, 2010 | Philips 60PP9352 60" Rear Projection...

1 Answer

Colors bleeding, red tint around images


The liquid coolant between the guns and the lenses may be fogged, low, or both. If the red gun has fogged coolant, you'll see red fringing around objects. It can be drained and refilled with new coolant, but it's gotta be the right stuff. You may be able to get some from a junk set, as I have done with success. Shine a light into the front of each lens. If the liquid has gone bad, you'll be able to see it.

Dec 06, 2008 | Hitachi 53FDX01B 53" Rear Projection...

1 Answer

Tv duplicate image


your guns are off and need to be adjusted. your 3 guns (red, green and blue) are off and that would explain the funny colors and shadows. Have a tv tech come out and have a look, they can fix it for a reasonable price.

Oct 20, 2008 | Projection Televisions

5 Answers

KP51ws500 turns green and shuts itslelf off


There may be several causes but, one is that when any color gun is being over driven, the Sony shuts down the gun to protect it. Try this. Remove the front of the set by removing the two screws from each lower corner. Next remove the black panel held on by 5 or 6 screws. Now you should see a panel with 6 potentiometers on it. Turning the ones on the bottom row CCW reduces the drive. Turn the color down and if all the guns stay lit, SLOWLY turn them up until you get the color balance that you like.

May 02, 2008 | Sony KP-51WS500 51" Rear Projection...

1 Answer

Shadow


You need to use the convergence feature for your set. What this is is having the three color guns aligned properly, There is hopefully an automatic adjustment on your set-up menu, if not adjustments for each seperate gun. Basically you adjust the lines of the adjustment screen so the line turns black and white. You can easily see what needs it.

If this needs to be done manually, it is a chore. Contact me for directions how to do this. It is best left to a pro but this can get costly and wouldn't hurt if you tried yourself as if someone comes in, the cost would be the same whether it is out slightly or severely.

Jeff

Feb 12, 2008 | Pioneer PRO-200 60" Rear Projection...

2 Answers

42wt29b toshiba tv


You likely have bad convergecne ouput IC's.  They sometimes will be intermittent untill they fail completely.

Oct 01, 2007 | Toshiba 42H83 42" Rear Projection...

2 Answers

IQC50H94W


The convergence IC's should be the first suspect in any convergence issue. Hopefully you can place the magnets back where they were or you will have that alignment to deal with first.

Apr 09, 2007 | Zenith IQC50H95W 50" Rear Projection...

1 Answer

Bent image


Excelent description,whats happening is your set starts to show a blue convergence problem and is only correctable by replacing the blue convergence amplifier IC,the set has 3,one for each color,not all of them develope problems but they all develope loose conections,after the IC has been replaced there are adjustments to do.If you are familiar with tv service this information will give a place to start but if you are not too familar be safe and call a servicer to help you.Lets US know how it goes.

Oct 13, 2006 | Panasonic PT-53WX42 53" Rear Projection...

Not finding what you are looking for?
Toshiba 43H70 43" Rear Projection Television Logo

Related Topics:

46 people viewed this question

Ask a Question

Usually answered in minutes!

Top Toshiba Projection Televisions Experts

Jaime Hernandez

Level 3 Expert

2267 Answers

Dave Naylor
Dave Naylor

Level 3 Expert

834 Answers

The Knight
The Knight

Level 3 Expert

68197 Answers

Are you a Toshiba Projection Television Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...