Question about Rockford Fosgate Punch 500a2 Car Audio Amplifier

1 Answer

No power working fine for a couple of days and then losst power. Checked all connectoins and everythings fine , just no power.

Posted by on

  • Emanuel Gissendanner Mar 11, 2008

    where exactly would the fuse be ? This amp doesnt have one as for as i can i tell. Is there some where i can send or take it to get it looked at/

×

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Expert
  • 129 Answers

Good day.
Have you checked on the fuse terminals?
Maybe the zener diode along B+ and ground got shorted when supply was reversed.
Check for for the continuity along the supply line. Also, consider if there was a sudden surge of supply that busted parts along the filter line of your unit.


chris

Posted on Mar 11, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Engine stutters upon acceleration


you have changed everything so it should go unless you haven't checked the fuel pressure and injectors of problems in the carby if you have one as not all faults you describe are in the electrical system

May 02, 2014 | GMC Sonoma Cars & Trucks

2 Answers

Oil Pressure and Neutral Swith issue 2003 Sportster 1200


just replace the ignition switch because due to moisture it might have been damaged

Jul 09, 2008 | Harley Davidson Harley-Davidson Motorcycle...

1 Answer

AMCOR 24,000 BTU split system. Worked fine two years, then today it had no power. Checked circuit breaker, it had popped. Reset CB and went to inside unit - would not turn on or off with remote or hard...


I had this same problem. I disconnected the thermostat wire out side at the condenser and reconnected it and it started working. A couple days later it blew the breaker again this time I found the bus where the L1, L2. GR wire connect at the condenser had melted. I wire nutted all 3 wires instead of the using the bus everything is working right again. Hope this helps.
Tim

Aug 09, 2010 | AmcorAire UCHW-H24AF2 Split System Air...

1 Answer

Rode my bike a couple of days ago, and everything was fine. When I tried to start it up, nothing happened, checked the battery and it was fine, correct voltage and all. Checked all the fuses, none were...


probly need a new starter relay-located by batt n has the cables attached--also chec wiring for any flaws--I wood make sur batt cables r tite n clean-ur welcome olschooler

Jan 20, 2010 | 1979 Yamaha XS 650 F

1 Answer

The directional light, wipers, brights, are not working


the combination switch may be bad. (wipers, turn signal, hi-lo beam switch)

Oct 13, 2009 | 2008 Dodge Avenger

1 Answer

Amp doesn't come on


Hello rheabarb,

You did not say whether or not you checked the wiring going to your subs. Many times, a shorted or grounded speaker wire will cause an amp to fail. And if the amp powers up OK with the subs disconnected, I'd suspect one or more of the wires.

Hope this helps.

May 19, 2009 | Clarion APX1300 Subwoofer Mono Amp - 300W...

1 Answer

Blowing 30 amp fusible link


check all ignition feed power circuits.get the manual that come with your truck in the glove compartment. it will tell you what fuse that is.because it has every fuse and relay in your truck.

Apr 09, 2009 | 1989 Toyota Pickup SR5

1 Answer

Brakes


Try to jack up the wheels and turn them to see if there is no seized brakes/calipers. Let us know how you get on.
Cheers

Nov 03, 2008 | 2006 Chevrolet Trailblazer

1 Answer

Lose power to half of the systems


My solution turned out to be a fusible link behind the battery. Cost me $55 for a tow and another $75 to track down the problem. I wonder if yours is a loose connection on the same line as the fusible link. Or maybe yours has a circuit breaker. My question is, why did the fusible link go in the first place, and what caused the relays to click off and on--maybe the computer got confused?

Sep 20, 2008 | 1994 GMC Safari

Not finding what you are looking for?
Rockford Fosgate Punch 500a2 Car Audio Amplifier Logo

Related Topics:

94 people viewed this question

Ask a Question

Usually answered in minutes!

Top Rockford Fosgate Car Audio & Video Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Professor_V
Professor_V

Level 2 Expert

92 Answers

Robert Rankin

Level 2 Expert

338 Answers

Are you a Rockford Fosgate Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...