Question about Canon EOS 400D / Rebel XTi Digital Camera

2 Answers

Canon EFS Lens question- please help!!

We bought a Canon Digital Rebel XTi in December, with a Canon EFS 18-55mm lens. Today when I tried to use the camera, it would not auto focus. Any advice would be greatly appreciated, as it cost quite a bit of money!!

Sincerely,
A. Hetrick

Posted by on

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Turn to mf and use manual focus then change to af again and it should work again. It did for me

Posted on Apr 28, 2008

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 28 Answers

Make sure that the switch on the lens is set to AF. If that doesn't work, you may have a faulty lens. The EFS 18-55 is not a high quality lens.

Posted on Apr 16, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Canon rebel xti focus issues


this does not seem to be like a problem in settings

please use a different lens and try the same

Aug 15, 2008 | Canon EOS 400D / Rebel XTi Digital Camera

1 Answer

Blurred edges


blurring occurs not depending on ISO, i think the lens is the problem. try to clean the lens glass carefully, is there some grease stick on the lens? if not it might be dislocated one of the lens structure.
have you try another lens?

Jul 26, 2013 | Canon EOS 400D / Rebel XTi Digital Camera

1 Answer

Autofocus gives erratic results


Are you using this indoors, in low light perhaps? This would be the most common reason for this happening. The only way to get around that is to use a "faster" lens, such as f2.8 / f1.8 / f1.4 etc.

If not, try cleaning the lens and camea contacts with a plastic eraser, make sure no debris falls in the camera body (hold upside down for this).

Jun 02, 2009 | Canon EOS Digital Rebel XTI Digital Camera

2 Answers

F stop


Sounds like your camera and your lens aren't communicating. Have you tried cleaning the contacts on the camera and the lens mount?

Sep 27, 2008 | Canon EOS 400D / Rebel XTi Digital Camera

2 Answers

Canon rebel xti focus issues


I think it might be a lens issue.
make sure you change the macro option. the macro must be activated if you are taking a picture of something which is close to the camera. if it's not activated, the picture will not be focused.
The same will happen if the item is far and the macro is ON.

Aug 14, 2008 | Canon EOS 400D / Rebel XTi Digital Camera

1 Answer

Tamron lens for Xti?


if it is an auto focus lens that works on one eos camera, it should work on almost all of them. the only known exception is that some high end extenders will not fit the eos1dmarkII as it protrudes into the opening too far.
but a good rule is that if it fits without any obstruction issues, it should work. try cleaning contacts on the lens and camera body. if that doesn't fix it, talk to Tamron. you can use it manually, but will not be as easy and you would get less predictable results.

my suggestion is to always go with lens from camera maker.

sounds like there is an issue with the tamron lens. not the camera.
good luck
mark

Dec 16, 2007 | Canon EOS 400D / Rebel XTi Digital Camera...

3 Answers

SPOTS on pictures taken by my Canon EOS Rebel XTi


Cleaning the lens and CMOS (Canon uses CMOS instead of CCD sensors) would be the first thing I would do. Before an expensive cleaning (usually at least $60) try getting a blower and blowing off the lens and sensor (find the sensor cleaning thing in the yellow section of the cameras menu, select it, the mirror will lock up, take off the lens, blow on the sensor with the blower)
For the lens, besides the blower, use a microfiber cloth on it.

If the problem persists, almost any camera store will clean cameras. Try Ritz cameras, here is a list of their stores in NY city.

Nov 25, 2007 | Canon EOS 400D / Rebel XTi Digital Camera...

Not finding what you are looking for?
Canon EOS 400D / Rebel XTi Digital Camera Logo

180 people viewed this question

Ask a Question

Usually answered in minutes!

Top Canon Cameras Experts

kakima

Level 3 Expert

98694 Answers

TC CAMERA REPAIR.Com...

Level 2 Expert

164 Answers

old marine
old marine

Level 3 Expert

1567 Answers

Are you a Canon Camera Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...