Question about NAD C350 2-Channel Amplifier

2 Answers

Nad amp failure

Nad c350 amp: no selection lights hence no play. power light is on and soft clipping light illuminates.

Posted by on

  • 1 more comment 
  • Gabbe Jun 14, 2008

    Mine has exactly the same problem. The power button and the soft clipping-button illuminates, but not the input selectors.



    I've checked all the fuses, and they were all working. What to do next?

  • jcoldrdige Jun 19, 2008

    Hi, I have exactly the same problem with my C350. Power and soft clipping lights illuminate but the input selectors do not. I have checked the fuses and they are also fine.

    Anyone get anywhere with this problem?


  • Jimmy007 Jul 18, 2008

    I have the same issue. However none of the fuses are blown. Does this still mean the transitors need checking or would it be something else??

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

Solution if all fuses checked out OK and +/-40V are present on main PCB DC connector from power supply:
Check for +37V and -37V on small sub-power supply PCB - mounted vertically on the main power supply PCB. (next to ribbon cable connector is a layout with voltages.) If the +/-37V are missing check (replace) C501 (0.1uF) on the small power supply PCB for leakage, but also check (replace) R401 (2R2) and R402 (2R2) on the main power supply PCB. Both resistors are fuse-resistors and will have gone open circuit when C501 has gone leaky.

Posted on Aug 30, 2008

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Check fuses mounted near transformer . If blown check output transistor. Also check transistor transistors on small heat sink . they will cause fuse to blow.

Posted on Apr 28, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My NAD C350 plays very faintly. when I turn the volume dial to the max position, I can bearly hear the music. I can hear properly from earphones output. Thanks


Take care. First put the volume down complete. Then unplug the head phone and than try to raise the volume. Could be the headphone connector does not switch through correct. Could be the connections between the pre and power amp are not in place or not proper pushed in?
Always take care when working with amplifiers. When switching them on with volume to max, you easy can kill your speakers. Also when disconnecting the headphones on full power kan damage the loudspeakers.

Aug 29, 2013 | NAD Amplifiers & Preamps

1 Answer

NAD C350, everything works after i replaced many blown parts except it has no sound output from any channel, just need some ideas on what to check for faults. thanks


With no background on the original problem and no details regarding what parts were replaced how can anyone answer the question?

What exactly does it mean if 'everything works' but it has 'no sound output'? As a two channel amp that would be its ONLY function.

The root cause for 'no sound' could be something as simple as a misplaced control (Tape Monitor?) or missing pre-out/main in links. It's in the manual.

Register and download it for free at retrevo.com

http://www.retrevo.com/support/NAD-C350-Amps-manual/id/8043dj589/t/2/

Jun 01, 2011 | NAD C350 2-Channel Amplifier

1 Answer

Hello i own NAD 3150, its not working, all the indicator lights ( power, protection and soft clipping glows)


HI...
It's either failed power supply capacitors or one or more power transistors in the output amp have gone bad

Oct 05, 2010 | NAD Amplifiers & Preamps

1 Answer

My NAD C350 won't allow me to switch input source - permanently on "AUX". Any idea as to cause/fix? Also I need to switch out my power 220v power supply for 120 (US). Would appreciate guidance here as...


Can't help on power problem, but the other sounds like an IC has failed that controls input selection. If you are going to do it yourself you will need a circuit diagram to find the IC.

Dec 20, 2009 | NAD C350 2-Channel Amplifier

2 Answers

Excess clipping on nad 372 amp


อิอิ ขอบคุณคับ

May 24, 2009 | NAD C272 Amplifier

1 Answer

No power in NAD c350


Hi...

Have you checked the rectifier diodes / bridge rectifier . Most DMMs have setting where you can test for forward voltage drop on a diode
0.300- 0.800v depending on the type. If it reads nothing , swap the meter leads.
Also check the leads coming from the power transformer and see if there's continuity. THey will read low value ohms

Apr 26, 2009 | NAD C350 2-Channel Amplifier

1 Answer

Nad c350 no power at all


check your output stage for bad speakers cable or bare wire of cable touch the body of amp----short circuit speaker cable----bad speaker it self------ bad input cable or defective input device .
disconnect all and check if it is ok---start to connect one by one from input to outputs------if all above failed you must contact service center for help.

Aug 22, 2008 | NAD C320 2-Channel Amplifier

Not finding what you are looking for?
NAD C350 2-Channel Amplifier Logo

Related Topics:

768 people viewed this question

Ask a Question

Usually answered in minutes!

Top NAD Amplifiers & Preamps Experts

 Grubhead
Grubhead

Level 3 Expert

4576 Answers

The Knight
The Knight

Level 3 Expert

68202 Answers

Larry Stiles
Larry Stiles

Level 2 Expert

286 Answers

Are you a NAD Amplifier and Preamp Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...