Question about Audio Players & Recorders

2 Answers

Sony xpold amp has no power

I just bought a xm1252gtr sony xplod amp.800 watt output..conected it to my 12' sony xplod sub..the lighds came on and everything, worked perfectly fine, then all of the sudden it turned off and hasnt came on since..any ideas??it is as though there is no power running to the amp but all the cables are wired up correct and the ground wire is fine

Posted by on

2 Answers

Check the fueses

Posted on Mar 19, 2008

Fuses

Posted on Mar 18, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

800 watt mono block sony xplod amp blowing my dual coil 1500 watt subs


if the wiring to the sub is correct, then you have something wrong with the amp itself... something is power surging to the subs which is causing them to blow

Aug 25, 2012 | Car Audio & Video

1 Answer

My stereo in 1997 chevy caviler is turning off and on when turned up to a high volume. I have a sony xplod 52 watt by 4 channel radio. With two 6x9 sony xplod 50 watt rms and 300 watt peak power in the...


Most likely cause is heat. The clearances behind the radio are often not sufficient to provde the proper air coolling that the higher power radios need. The heat sinks on the rear of the radio require a certain amount of air flow to dissipate the heat generated under high load conditions. If you add summer heat to the equation, you can have the radio going into thermal cutout to protect it circuity.

May 27, 2011 | 1997 Chevrolet Cavalier

1 Answer

I have two sony xplod 12" speakers wich can hold


You only gave us the model of the amp so I will make an assumption that your 12" subs are the Sony XS-GTX120LW. First, they cannot hold 1200 watts a piece. They are meant to be powered with 350 watts RMS. They will hold 1200 watts peak. That means that 1200 watts for a few seconds will be ok. Past that and kiss them goodbye!

Next you indicated that bridged the amp. Since the subs are both 4 ohm single voice coils did you wire them in series or parallel?

It sounds to me like you wired them in parallel resulting in the amp seeing a 2 ohm load. The amp you referenced is only stable when bridged at 4 ohms.

Has the amp begun working again once it cooled down? If not you could have fried the outputs by having the resistance too low.

Dec 21, 2010 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

I Have a Sony Xplod 800 watt amp and 2 12 inch Sony Xplod subs


You should definately bridge them. Firstly, lay the 2 speakers face down next to each other. Note the connections +- +-. The first + will go to the amplifier. The next terminal(-) will be connected to the next speaker(+). Take the last(-) and connect to amplifier. Please note that your amplifier has a bridge section which is normally the first + and the last- on the two channels. Connect your woofers on the bridge.

May 28, 2010 | Sony XM-ZR1252 Car Audio Amplifier

2 Answers

Amplifier For Powering Sony Xplod xs-l121p5


Pump the brakes!
You need to know the RMS power rating of the sub you are powering.
Dont exceed the RMS power rating of the sub by more than 25%.
If you see a peak power rating on either the sub or the amp, ignor it, means nothing. Always compare RMS ratings.
Example: a Sony 12" Xplod sub, boasting 1200 watts, will only handle, 350 watts RMS, so the amp you choose to power the sub should be 350 watts RMS as well, and should not exceed more than 25% of the RMS power handling (487.5 watts).
Bottom line, know your RMS numbers, not Peak.
Byron
www.distinctbeat.com

Dec 06, 2009 | Sony Car Audio & Video

1 Answer

Settings for a Sony Xplod 1200 watt amp, with two 12 inch subs


What kind of subs are you running? Meaning what brand, what are the ohm, spl and wattage? I'll look up your amp while you get that info to me. Looking forward to helping you:) Thanks!

Apr 08, 2009 | Sony Xplod 1200W Class AB Bridgeable 2-Ch....

1 Answer

Can a 1000 watt amp run 800 rms subs and best wiring option


yeah it will run them but you won't get your full power because the rms for your subs is high. try bridging them with some 8 gauge wire, and of you got a crossover it will help you out alot

Feb 22, 2009 | Sony Xplod XM-1652Z Car Audio Amplifier

1 Answer

My Amp


sounds like the sub that throws it into protect mode is cross wired pull sub out and make sure they are wired right make sure ground from sub goes to ground on box and do same for power wire

Jun 11, 2008 | Sony Xplod Car Audio Amplifier XM-DS1300P5...

3 Answers

Power protector light on sony xplode 1000 watt amp


a green light is the power indicator, a red light is when the protector is in affect

May 30, 2008 | Sony Xplod XM-554ZR Car Audio Amplifier

Not finding what you are looking for?
Audio Players & Recorders Logo

Related Topics:

191 people viewed this question

Ask a Question

Usually answered in minutes!

Top Audio Players & Recorders Experts

kakima

Level 3 Expert

98770 Answers

 Grubhead
Grubhead

Level 3 Expert

4678 Answers

The Knight
The Knight

Level 3 Expert

69718 Answers

Are you an Audio Player and Recorder Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...