Question about Vacuums

1 Answer

My vacuum does not have any suction, and it spits out dirt when I roll it backwards. It is an upright Hoover Elite

Posted by on

  • dcroda Mar 10, 2008

    Your comment completely helped! My vacuum is fixed. Thank you so much!



1 Answer

  • Level 1:

    An expert who has achieved level 1.


    An expert who has answered 20 questions.


    An expert that hasĀ over 10 points.


    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 30 Answers

Trouble Shooting guide:

1. Check to make sure that your agitator still spins. (Agitator = brush). If your agitator does not spin, it could very well be a belt gone bad and means there will be no suction.

2. If belt is fine and agitator spin, your vacuum could be clogged. A clogged vacuum can be cleaned with a brush inserted into the hose of the vacuum to pull out the debris.

Posted on Mar 07, 2008


1 Suggested Answer

  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

A 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
The service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
Good luck!

Posted on Jan 02, 2017


Add Your Answer

Uploading: 0%


Complete. Click "Add" to insert your video. Add



Related Questions:

1 Answer

I have suction through the hose but not when using in the upright position. The problem started once I removed the filter to clean it.

there is a chance that the hose between the ground pick-up and the suction hose is clogged,, this happens when the filter is blocked and all the dirt and stuff only makes it part way up the hose and then settles at the bottom. run a wire coat hanger down the line to break up the blockage.


Dec 30, 2010 | Hoover U5507900 Elite Rewind Bagless...

1 Answer

My deluxe elite rewind vacuum spits out dirt

The elite rewind does not have any fancy features. This sound like you have a blockage in the foot or base of the vac. remove the bottom cover to look under. Also check the hose, it can be in there as well.

Apr 16, 2010 | Vacuums

1 Answer

Hoover Windtunnel spits dirt back out the back

Your problem sounds to be an obstruction in the foot (lower body) of the windrummel. Most all windtunnel's have a second cavity for suction to go over the top of the roller. When you remove the bottom plate, next remobe the belt and roller, under the roller will be a removable cavity, take it out. remove the dirt and clean out any debris. also check the suction path connecting hose. if your belt has not been changed in the last 12 months, I would recommend changing that as well.

Jan 17, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

I have the Hoover upright windtunnel and have used it only once. It worked wonderfully the first time but now only the hand tool has suction. I can't find the book that came with it though. How do I get...

Seems like you must have suction at th hose. The either a belt came off or it is plugged up at the dirt inlet by the brush roll. Some Hoovers have a spring loaded door that opens and closes depending on whether the handle is down or in its upright position, It may not be opening when you drop the handle to vacuum.

Jun 08, 2008 | Hoover Vacuums

2 Answers

Loss of suction in my Hoover Windtunnel bagless selfpropelled upright

Did you check the dirt inlet by the brush roll, filters ok, they should be replaced once a year. Belts can look fine, but if they are a few months old, I am sure they have stretched and the brush roll will not turn like it should under load. It is possible that the motor isn't running up to speed, thereby reducing suction.

Mar 11, 2008 | Hoover Self-Propelled WindTunnel Bagless...

3 Answers

Hoover Wind Tunnel Upright Self-Propelled

Thanks to reddevil6. Sure enough it was the belt. What I did was take off the belt and flipped it over, worked like a charm. Since it was stretched on one side the other side was still ok. Still need a new, but s aved me a trip to the store!

Nov 21, 2007 | Vacuums

Not finding what you are looking for?
Vacuums Logo

Related Topics:

268 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts


Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18417 Answers

D. Floyd Kolb
D. Floyd Kolb

Level 3 Expert

43501 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides