Question about Legacy LD53UM In-Car DVD Player with 3.5" TFT LCD Monitor Car Video Player

2 Answers

Legacy ld53um when i connect it i get power but there is no sound and when i put a disk in it says loading then it says no disk any suggestions please help needed

Posted by on

  • 1 more comment 
  • tjaa Mar 07, 2008

    but what about the speakers?? i heard that you may have to bypass the amp that was originally running the spoeackers ne one know how i can do that or another solution??? please help

  • tjaa Mar 07, 2008

    and how do you clean the laser eye?

  • tjaa Mar 08, 2008

    but you dont know about the speakers?

×

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Champion:

    An expert who has answered 200 questions.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

  • Expert
  • 227 Answers

Buy a cd cleaner kit, if it doesn't work have someone who know how re-align your laser eye. Goodluck.

Posted on Mar 07, 2008

  • hogan doan
    hogan doan Mar 08, 2008

    You clean the laser eye with the cd cleaning kit. Goodluck.

  • hogan doan
    hogan doan Mar 08, 2008

    Take the unit out and bench test it before install. Check to see if it is in multi zone, switch it to single zone. If all else failed, you can always add an external amp. You would get much better sound than the onboard output for around $100. Just have to know where and what to get. Let me know if I can help.

×

Make sure your red and yellow wires are tied together as 1 to your power. if not i know in some cases this will cause that type of odd fuction hope it works out for you.

Posted on Apr 08, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I have a hp altec 255 laptop .when I put in reinstall disk .windows 7 .computer will not set it up to take program .enyway to get a new hp recovery and applications/drivers reboot disk


please check bios boot type I sujspect it may be booting for UEFI rather than for legacy boot. Windows 8 will boot on UEFI boot type but windows 7 will need legacy bios type of boot up settings in bios
see
http://blogs.technet.com/b/askcore/archive/2011/05/31/installing-windows-7-on-uefi-based-computer.aspx

Dec 21, 2014 | HP Computers & Internet

2 Answers

Hello.My ACER Aspire One netbook will not properly load, or load at all actually. It worked fine yesterday, I shut it down.. and when I turn it back on it won't work correctly. It comes to a black load...


Hello my friend. The problem is that the "hard drive" has a lot of bad sectors and the netbook cannot recognise it. The Hard disk might need replace with a new hard disk. Please refer to a computer technician. Please rate my help! Thanks!

May 11, 2011 | Acer Aspire One PC Notebook

1 Answer

I HAVE A 1200 Watt Legacy Rebel amp and when I power it on the lights turn on but no sound comes out. Please give any help


You need to make sure that the subwoofer leads are connected correctly. It may be that the subs aren't connected properly. That would cause the amp to turn on without any sound coming out.

Mar 06, 2011 | Legacy LA2259 Car Audio Amplifier

1 Answer

I hooked the yellow wire the black wire and the red wire together but the screen or nothing will come on for the radio part


try and find a good ground for black wire red and yellow fine. and if you have a brown wire might be ground also

Jan 29, 2010 | Legacy LD53UM In-Car DVD Player with 3.5"...

1 Answer

1995 Subaru Legacy electrical nightmanre...PLEASE HELP!!!!!!


Really sounds like you need to make sure all the ground wires body and motor are good. Sometimes a poor ground will do that. The electricity will try to find any thing that it can to return the circuit. I even had one time the ground was going through the shift cable. Which destroyed the cable after a while. Good luck and hope this helps.

Apr 24, 2009 | 1994 Subaru Legacy Outdoor

3 Answers

Unable to load games


I have a very similar problem that my wii console gives me black screen with disk read error every time I inserted a new disc that worked previously. The way I worked around this problem is by
1. ejecting the disc
2. powering off(hold the power button for about 10 seconds)
3. unplugging the power cord
4. waiting one minute or so
5. plugging in again and re-inserting disc
This worked every time when I switched disc.

Nov 17, 2007 | Nintendo Wii Console

6 Answers

No HDD Found on initial XP Install


Did you insert the sata driver disks when prompted in the first stages of installation? I think it's mentioned as scsi drivers.

Mar 04, 2007 | Mach Speed (S755) Motherboard

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

303 people viewed this question

Ask a Question

Usually answered in minutes!

Top Legacy Car Audio & Video Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

isaac johny
isaac johny

Level 3 Expert

796 Answers

xxxxxx xxx

Level 3 Expert

4748 Answers

Are you a Legacy Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...