Question about Technics SL-1210 Turntable

2 Answers

Jordi I have a technics sl 1210 mk2 and when i push start to 33r.p.m o 45r.p.m , the pitch aren't constant, so the sound and the light pitch aren't constant too It seems like the magnethic transmission was inverted, sometimes left to rotate , inclusive slowly rotate in wrong direction. Somebody help me please!!!!!

Posted by on

2 Answers

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 515 Answers

Check to make sure that your voltage setting is set correctly. Look under the turntable platter. You'll see a voltage selector. Make sure it's properly set for your area (115V or 220V). Do the lights dim off/on? If so, than that is usually the problem. If not, then you might have a faulty turntable drive issue, which means something is wrong on the main board (located underneath the turntable platter).

If the issue is on the main board, then this is not an easy fix. FYI... the pitch fader will not affect the power, and make your lights dimm, so spraying it with De-Oxit will not do anything, other than clean it out.

BTW, we are an authorized Technics service center, and work on over 2 dozen Technics 1200s a week. We are THE experts here in the U.S. when it comes to these turntables hands down. So, if you have any questions, feel free to contact our Support Department, which is available 24/7 @ 1.877.357.7677 - or visit our main site HERE.

- DJ PRO AUDIO
www.DJPROLAB.com




Posted on Mar 21, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Genius:

    An expert who has answered 1,000 questions.

  • Master
  • 1,175 Answers

The speed on the TT is crystal controlled . If that circuit has got an "issue" the speed wont be right.

Also, try cleaning the pitch slider with stuff called Caig "De-Oxit"

Parts Express or Radio Shack sells it.

Posted on Mar 12, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

1210 mk 2 pitch


Doubt it, ive heard of this problem before, usually people buying them second hand and the answer has always been get them repaired professionally, i dont know the reason for them doing it sorry.

Jun 10, 2008 | Technics SL-1210 Turntable

1 Answer

Technics sl 1210 will not start up


did you ever open the turntable. It sounds like the on/off switch is bad. Remove the platter and screws with a phillips screw driver and just make sure the connections are in place. make sure you disconnect the power first. let me know what happens afterwards.

May 24, 2008 | Technics SL-1210 Turntable

2 Answers

PITCH CONTROL PROBLEM


The reset button disables your pitch control and allows the turntable to rotate at TRUE "0" (zero). FYI, these turntables were NOT made for DJing. They were made for radio, studio, and high end home use. They became DJ turntables, because they were perfectly built for the trade. So, the pitch reset button is more of a function best suited for radio stations or a producer who needs to record or play at a true zero speed.

Now, on to your question...

More than likely you just have to calibrate your pitch control. There are various videos on YouTube on how to do this properly. Just do a search CALIBRATING 1200s or similar. FYI, all the Technics SL1200/1210 MK series are the same inside. MK2, MK3, MK5 - so don't worry if you only find videos on calibrating MK2's or MK5s - works the same on all the models.

Good luck!

- TERMiNAL OPTiC
www.DJPROLAB.com

Apr 01, 2008 | Technics SL-1200M3D Turntable

1 Answer

Technics sl 1210 MK2 does not start


Your switch probably went bad. Does it not respond at all? Does the button at least 'bounce' back when you press it? If not, then you might have messed something up when putting it back together.

- DJPROLAB

Feb 14, 2008 | Technics SL-1210 Turntable

1 Answer

1210 mk5g pitch adjustor


switch off for a will and see.
if still bad. check the circuit board under.

with old electronic devices, capacitors are commly the ones that may go wrong/dry. which would cause oscillatory circuit to generate wrong signals or strobe or feebacks. if you know how to take out the circuit board, check it starting from capacitors.

Jan 22, 2008 | Technics SL-1210M5G Turntable

1 Answer

1210 mk 2 strangeness


Check that your voltage settings are set correctly. This is located underneath your turntable platter. If you remove the slipmat, you will see 2 holes on the metal platter. Rotate the platter till you see the voltage switch, located @ the 9'o'clock position. Make sure it's set to your correct settings (N.America = 115V / Euro = 220V). If not, you will need a flat head screw driver to switch it. Before you switch it, make sure your unit is off and unplugged. After you swich it, it should be ok.

If your still having issues with the speed and the pop-up light, then there is something seriously wrong, and will need to be checked by a technician. Sometimes a resistor or IC will go bad, causing the speed issue, but for the pop-up light - that's usually faulty wiring generally caused by an incorrect replacement.

Did you buy this new or used? Have you had this serviced recently?

- TWEAK AV LAB
The ORIGINAL TURNTABLE Technicians

Dec 01, 2007 | Technics SL-1210 Turntable

1 Answer

Technics 1210 mk2 problem with pitch and lights


Check that your voltage settings are set correctly. This is located underneath your turntable platter. If you remove the slipmat, you will see 2 holes on the metal platter. Rotate the platter till you see the voltage switch, located @ the 9'o'clock position. Make sure it's set to your correct settings (N.America = 115V / Euro = 220V). If not, you will need a flat head screw driver to switch it. Before you switch it, make sure your unit is off and unplugged. After you swich it, it should be ok.

If your still having issues with the speed and the pop-up light, then there is something seriously wrong, and will need to be checked by a technician. Sometimes a resistor or IC will go bad, causing the speed issue, but for the pop-up light - that's usually faulty wiring generally caused by an incorrect replacement.

Did you buy this new or used? Have you had this serviced recently?

- TWEAK AV LAB
The ORIGINAL TURNTABLE Technicians

Nov 30, 2007 | Technics SL-1210 Turntable

Not finding what you are looking for?
Technics SL-1210 Turntable Logo

147 people viewed this question

Ask a Question

Usually answered in minutes!

Top Technics Turntables Experts

 Grubhead
Grubhead

Level 3 Expert

4584 Answers

T-Comtech Repairs
T-Comtech Repairs

Level 2 Expert

411 Answers

Electro Med Services...
Electro Med Services...

Level 3 Expert

5612 Answers

Are you a Technics Turntable Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...