Question about Vacuums

2 Answers

Vacuum My hoover windtunnel light blinks from green to red and has lost suction.

Posted by on

2 Answers

The vacuum will not turn on or off with the slide swith when i push it on i can't turn it off

Posted on Mar 18, 2008

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    MVP:

    An expert that gotĀ 5 achievements.

    Governor:

    An expert whose answer gotĀ voted for 20 times.

    Scholar:

    An expert who has written 20 answers of more than 400 characters.

  • Expert
  • 148 Answers

If it is blowing air, then it is still clogged up somewhere, you didn't give your model number, but some of these have removable covers on each side and on the back. Also make sure that all covers are back on securely.

Posted on Feb 25, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Vacuum not clogged but has low suction


Check all the pipes, there could be something stuck in them which hasn't come out.
Also check the base of the vacuum if there is something stuck in the base.
Lastly check if there are any leaks in the pipes.
Also check the suction without using the handle, by pulling the pipe in your hand and see if it has more suction.

Apr 28, 2014 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

Red power light blinks even with completely clean canister and filter


Check for a filter where the air blows out of the machine. Could be clogged.

Jul 26, 2013 | Hoover S3755 WindTunnel Bagless Canister...

1 Answer

Suction not working on vaccuum.


Check for a blockage in the hose, or a tear / hole in the hose between the "pleats"

Jun 13, 2010 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

My Hoover Dirt Finder red light stays on. All


Inspection of the circuit board found that the 470uF capacitor looked damaged. I replaced it and I now have the Green and Red lights are working correctly.

Jan 19, 2010 | Hoover U6476-910 WindTunnel Upright Vacuum...

1 Answer

Brush spin,good suction at hose, no suction at


Air passage from back of brush head, through the joint, and up to bag, may be blocked.

Jul 11, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

The Hoover Windtunnel vacum will not pull suction


Either the machine or hose is blocked OR the filters are blocked.
Also possible that the belt is broken.
Please leave feedback
Thanks

Feb 13, 2009 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Wind tunnel hoover


Do you have suction at the hose end, if you do then it may be clogged at the inlet by the brush roll. Is the filter cartridge clean? If it is clogged and air can't pass thru it, then you will have no or low suction. Might also check the belt to make sure it is turning.

Nov 30, 2007 | Hoover U5753-900 WindTunnel Bagless...

1 Answer

Embeded Dirt Finder


check out the switch that activates it. go to thehooverstore for a complete listing of hoover machines. I'm sure you'll find your machine listed along with an exploded diagram of the machine

Sep 19, 2007 | Hoover U6437-900 / U6439-900 Windtunnel...

1 Answer

Hoover Windtunnel


Mine does the same thing. There is no suction. I found that there is a door that opens when you tilt the handle in the down possition. I think there should be a spring in place so it can open. Until I find a replacement spring I have to open the door manually throught the opening under the light.

Oct 15, 2006 | Hoover U6630-900 WindTunnel Bagless...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

156 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18304 Answers

Roger Potts

Level 3 Expert

694 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...