Question about MTX Thunder 8302 Car Audio Amplifier

1 Answer

Mtx ta7801 amp not working

Hi i have an mtx ta7801 amp, i let my brother use it and it quit working. i hooked it up and all the lights would work but no sound. i checked all external and internal fuses but everything was good. when i looked inside the amp i noticed around a black diode or chip was a burn area. it looked like a drip of soda got on the a chip or something. do you know where i could get my amp fixed or find a chip?

thanks derek

Posted by on

1 Answer

Depending on where you live, Car Tunes is a good place to fix it but it might cost a good amount. I have a mtx 1501XD and the same problem, lights but no sound i saw no marks inside mine however. They told me i was better off buying a new one bc it was going to cost so much to fix most likely. That was coming from a guy I know so they were just trying to **** money out of me either, he does sound for a living.

Posted on May 29, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

I got a mtx ta7801 amp every time I hook it up it says short even when no rca our speaker wires are attached any one have any clue as to whath is wrong


Im sure you have but check all the fuses and be sure ground/power is in the right spot, and check remote wire for cuts

Dec 17, 2010 | MTX Thunder TA7801 Car Audio Amplifier

1 Answer

Can you bridge 2 4 ohm kicker speakers to a mtx thunder 7801 amp?


Ya. Just hook one sub to your amp (bridged) and hook the other sub (positive and negative) to the first subs positive and negative

Nov 12, 2010 | MTX Thunder TA7801 Car Audio Amplifier

1 Answer

Just hooked up mtx 500d mono amp and 12 inch sub worked for a 1/2 hour then sub quite and led on top of amp just flashes.


either ur ohm load is way off ur pos n neg might be touchin or more than likely u blew u sub is it scratchy when u push in the middle of the cone ? does it push in at all?

May 14, 2010 | Car Audio & Video

1 Answer

The lights on my amp dont work anymore ?


Give it a ride though the dishwasher, the amp may just be dirty.

Dec 18, 2009 | MTX Thunder TA7801 Car Audio Amplifier

1 Answer

Amp is a mtx 801d not sure


no you will not blow it out by hooking up both voice coils. But First before you do, what oms are they. and is your amp one oms stable? There a lot of ways you can wire double voice coil. But if you can get me that info i can send you some digrams to help you out and tell you whats best.

Oct 05, 2008 | MTX Thunder TA7801 Car Audio Amplifier

1 Answer

MTX Thunder TA81001 amp


A large capacitor between your battery and the amp may help. Your alternator is most likely strained by the amp's power consumption. If you can't get a stronger alternator or suitable capacitor, you may nbeed to replace your battery and alternator more often than normal.

Feb 29, 2008 | MTX Thunder TA7801 Car Audio Amplifier

3 Answers

The red light on my amp keeps coming on and it wont work


You need to check your woofers. Most likely one or both may be a) blown or at a dead short or b) the ohm rating on them may be too low. What model woofers and amp do you have??

Nov 17, 2007 | MTX Thunder TA7801 Car Audio Amplifier

1 Answer

Amp is not coming on


the fuse may not be working, you could try a larger sized one, also if you have the old power cable try it again with a larger fuse in place, if it worked before its likely to just be the fuse wasnt big enough, check all the other connections are in the right place, if they all are and you know the amp hase worked before then it could only realy be the fuse isnt big enough or the power lead is faulty.


cheers, adam

Nov 17, 2007 | MTX Thunder TA7801 Car Audio Amplifier

2 Answers

My amp doesn't turn on...


If there is a zero ohm connection across the B+ and ground terminals, it should blow the fuse as soon as you apply power.

 

 

 

Oct 10, 2007 | MTX Thunder TA7801 Car Audio Amplifier

Not finding what you are looking for?
MTX Thunder 8302 Car Audio Amplifier Logo

Related Topics:

144 people viewed this question

Ask a Question

Usually answered in minutes!

Top MTX Car Audio & Video Experts

Professor_V
Professor_V

Level 2 Expert

92 Answers

Matthew Spark
Matthew Spark

Level 3 Expert

1066 Answers

yadayada
yadayada

Level 3 Expert

70387 Answers

Are you a MTX Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...