Question about Whirlpool AD40DSL Dehumidifier

1 Answer

Unit will not turn on

I've had this model for about 5 years. It's worked flawlessly. I recently replaced a cracked reservoir and float before leaving on vacation. When I returned, the dehumidifier did not work. It WAS getting power, but if I adjusted the humidity settings, it wouldn't cycle ON. If i manually depressed the switch that is depressed when the float valve is positioned, this has no effect either. Not sure if there is an internal fuse or not....

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 473 Answers

Sounds like it has a bad relay on the compressor. This is most common. If it is anything else I would suggest buying a new unit due to cost for repair.

Posted on Feb 25, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The float shuts off the unit even with no water in unit


It sounds like the reservoir is tripping the switch, be sure it moves freely when the reservoir is installed.

Apr 23, 2014 | Fedders A7DH65B2A Dehumidifier

1 Answer

Hello, we are having some trouble with our Frigidaire dehumidifier model FDR30S1. It runs but is not pulling in any moisture. We've tried a few solutions but have not been successful thus far. What is...


Generally, most humidifiers work best between 60 -80 degrees . There is a model that is called a Low Temp model, that's designed for low temperatures in basements.

As far as your problem is concerned, there are 5 basic, yet solvable reasons for what you described. Please pay particular attention to numbers 1 & 2.

1. The humidity extraction level is set to HIGH. Lower it to 32-35%. If you have a manually
controlled unit, set the Manual Control Knob to Maximum.

2. Air intake filter is dirty or clogged. Turn unit OFF, & Unplug the
Unit, before removing to inspect & clean it, if necessary. If washed,
allow filter to completely dry before reinstalling. DO NOT operate
the unit without the filter.

3. Obstructed air flow. Maintain a minimum of 12 to 18" of clear air
space around the entire unit.

4. Cooling coils are dirty and need to be cleaned. Use warm water & dish washing liquid to
clean the coils. Rinse and wipe dry. Apply a light coating of WD40 to the coils.

5. Ambient air temperature at floor level is between 40 - 60 degrees.
dehumidifiers do not work well between those temperatures
(Unless, you have a Low Temp Unit). This applies mainly to
where the air temperature at floor level is colder than at shoulder
level
in basement applications. Raising the unit up off the floor,
onto a sturdy table, counter top, etc, that can handle the weight
of the unit, plus a full tank of water, will usually resolve this
problem.

If none of the above solves the problem, it may be a case of the compressor needs to be recharged with refrigerant gas or that the humidity condenser sensor has failed. These things usually occur in units that are 5 years old or older. It's rare in a unit younger than that. But, it can happen.


I hope this helps you troubleshoot and solve the problem. Thanks for choosing FixYa.

Jul 27, 2011 | Frigidaire FDR30S1 Dehumidifier

1 Answer

I have had the Frigidaire dehumidifier model FDB5OR1 for four years. Starting last year, the unit would occasionally continue to operate after the bucket was already full, resulting in puddles on the...


The faulty float valve is almost always the problem, based on what you described. It is a replaceable part, but you may have to but the entire bucket assembly. Generally, they run around $50.00. However, not all parts are still available for that model, even though it's only 4 years old.

If you want pursue finding the float valve or a new bucket assembly, the best place I've found is online is Appliance Factory Parts http://www.appliancefactoryparts.com/search/index.php they carry parts for just about any appliance you can think of.

Or Frigidaire Parts Select
http://www.partselect.com/Entry.aspx?Source=GAWS&Brand=Frigidaire&Term=frigidaire&gclid=CIfU4u28vqkCFcPd4Aod6CC5hQ

I hope this helped you. Please let me know. Thanks.

Jun 18, 2011 | Frigidaire FDL50R1 Dehumidifier

2 Answers

I have a Fedders dehumidifer model # A70145D2A-A-R. It is a few years old and it's worked pretty great but now it just runs continuously and no moisture is gathered. What can I do to fix it? I was...


You'd be hard pressed to find a Fedders like yours. They've been out of business for several years.

There are several basic things that can cause what you described.

1. The humidity extraction level is improperly set. Lower the level to 32-35%

2. A dirty of clogged air intake filter. Turn the unit OFF unplug it and remove the filter for cleaning.

3. Obstructed air space. A dehumidifier requires a minimum of 12" clear air space around the entire
unit.

4. The ambient air temperature at floor level is between 40 & 60 Degrees F. Dehumidifiers do not work well in that temperature (Except low temp models). This especially true in a basement application, because the air temperature at floor level is colder than say, chest level. Raising the unit up off the floor onto a sturdy table, cabinet top, etc, that can handle the weight of the unit, plus a full tank of water, will normally resolve that problem.

5. The cooling coils are dirty and need to be cleaned.

Critical problems:
1 The humidity sensor has failed an needs to be replaced.

2.The compressor is low on refrigerant gas and needs to be recharged.

Sometimes the repairs (Time spent finding, the Parts & labor), if necessary, can cost almost as much or as much as a new unit, which would have a full warranty.

Hope this helped you troubleshoot the basic and solvable problems and you won't need to make any critical repairs. Please let me know. Thanks.

Jun 16, 2011 | Fedders R6DH45X Dehumidifier

2 Answers

My DeLonghi Portable Dehumidifier Model DEM10 has stopped working. It doesn't make the same noise when you turn it on anymore i.e the slight refridgerator sound. Does this sound like a repairable problem...


Hello,

First, make sure the reservoir is empty. If you plug the unit in and see a green power light, but the unit won't run, make sure the reservoir is properly inserted. Many dehumidifiers have switches or sensors to make sure that the reservoir is placed so that it won't leak. Look for these sensors and make sure the reservoir is engaging them. If your dehumidifier has a float or switch to indicate a full reservoir, make sure this switch isn't being tripped accidentally.

Good luck.

Aug 13, 2010 | DeLonghi Dehumidifiers

1 Answer

Wont run. E2 on screen. about three years old


Hello,

First, make sure the reservoir is empty. If you plug the unit in and see a green power light, but the unit won't run, make sure the reservoir is properly inserted.

Many dehumidifiers have switches or sensors to make sure that the reservoir is placed so that it won't leak. Look for these sensors and make sure the reservoir is engaging them.

If your dehumidifier has a float or switch to indicate a full reservoir, make sure this switch isn't being tripped accidentally.

I hope this helps.

Take care.

Aug 12, 2010 | Haier Dehumidifiers

1 Answer

Light saying bucket is full is on all the time and unit is not working


Hello,

First, make sure the reservoir is empty. If you plug the unit in and see a green power light, but the unit won't run, make sure the reservoir is properly inserted.

Many dehumidifiers have switches or sensors to make sure that the reservoir is placed so that it won't leak. Look for these sensors and make sure the reservoir is engaging them. If your dehumidifier has a float or switch to indicate a full reservoir, make sure this switch isn't being tripped accidentally.

Good luck.

Jul 28, 2010 | Kenmore 54501 Dehumidifier

1 Answer

Auto shut off comes on instantly


TURN UNIT OFF.. MAKE SURE DEHUMIDIFIER HAS NOT BEEN RUN FOR AT LEAST FIFTEEN MINUTES... TAKE BUCKET OUT... HOLD IN THE BUTTON THAT THE FLOAT IN THE BUCKET PUSHES ON.. THEN TURN ON THE UNIT.. DO NOT LET GO OF THE BUTTON EVEN A LITTLE BIT IF YOU DO YOU WILL HAVE TO WAIT FIFTEEN MINUTES AND TRY AGAIN.. IF UNIT WORKS THEN YOUR FLOAT IN THE BUCKET IS THE PROBLEM...

May 07, 2010 | Goldstar DH304 Dehumidifier

1 Answer

Soleus 40 pint dehumidifier... used for 3 years, stopped making water. Recently overfilled, auto shut off hadn't worked and water level overflowed. 2 days later can't get to make water. Tried all the...


Check to see if the styrofoam is still in the lever of the shut off arm. It's atop the water reservoir. If there is nothing there it will not float causing the arm not to shut off.

Nov 25, 2009 | Soleus CFM-40 Dehumidifier

Not finding what you are looking for?
Whirlpool AD40DSL Dehumidifier Logo

Related Topics:

198 people viewed this question

Ask a Question

Usually answered in minutes!

Top Whirlpool Dehumidifiers Experts

Bill Long

Level 3 Expert

587 Answers

Mike Squire

Level 2 Expert

391 Answers

Mike

Level 3 Expert

4334 Answers

Are you a Whirlpool Dehumidifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...