Question about Vacuums

2 Answers

Kenmore Central Vacuum System-electrical o.k. but suction function not working. No noise from canister.

Posted by on

Ad

2 Answers

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 58 Answers

It could even be a bad motor if its an old kenmore system. If its more than 10 years old it maybe worth getting a whole new tank over just a motor.

Posted on Jul 26, 2009

Ad
  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers

There should be a switch on the canister, for manual or automatic. Switch it to manual and see if it comes on. If it does, then there maybe a bad relay. If it doesn't, then there is a problem inside of it, motor, pc board, would have to be checked. Without the model number, not sure what components are inside without the model number to look it up.

Posted on Feb 26, 2008

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi there,
Save hours of searching online or wasting money on unnecessary repairs by talking to a 6YA Expert who can help you resolve this issue over the phone in a minute or two.

Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.

Here's a link to this great service

Good luck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Rattling noise beneath filter


Broken fan maybe. If the fan is has come loose from the motor shaft, it will rattle and there will be little or no suction. A trip to the local vacuum guy may be in order.

Oct 29, 2013 | Kenmore Vacuums

1 Answer

I have a Kenmore "Intuition"


I had a different vacuum that did this. I took all manner of things apart looking for blockages and the like .I found that by having the vacuum handle in the full upright position shuts off the suction to this area and doesn't power the brush BY DESIGN. I think this is to get more suction to the hose.

Dec 18, 2017 | Kenmore 25512/ 25513 Progressive Canister...

1 Answer

Canister turns on but no suction in house


sounds like there could be a clog in the lines, Check the pipes running through your attic/basement, and see if there's something blocking the piping.

If you can't seem to find the problem, I'd suggest looking into having someone who services central vacuums come and take a look. They'd have the proper tools and knowledge to help you in person

Apr 19, 2010 | Eureka 1810 Central System Vacuum

1 Answer

My Kenmore Progressive is making a noise that sounds as if something is blocking the suction. I have checked the tubes and can't find any obvious blockages


Have you changed out the bag? Checked the air filters? When you run it and hold your hand over the hose opening, do you feel suction?
Check the head for blockages, you said the tubes are good, so check the hose, if no obstructions there, open the canister and check the bag, if it's full change it, if not, pull it out and check the filter that's under the bag, if it's not clogged re-run the above steps but this time look for possible vacuum leaks. Let me know if this helps.

Oct 19, 2009 | Kenmore 25512/ 25513 Progressive Canister...

1 Answer

We have a Kenmore canister vacuum cleaner and the power in the floor component (rotating brush, etc) is no longer functioning. The vacuum is producing suction, but does not seem to be providing power to...


the problem could be with the power head itself or the hose providing the power. If you can turn the unit on from the handle, then its not the hose and you need to get a new power head..

Aug 14, 2009 | Panasonic Kenmore Canister Vacuum Vacuum

1 Answer

No suction


If the motor is running and is not full of dirt, and the hose is not plugged, the canister must be cracked or open somehow.

May 08, 2009 | Kenmore 22812 Bagged Canister Vacuum

1 Answer

Central vacuum power head no work


Looks like a Beam central vacuum www.beamvac.com, and a Kenmore vacuum head.

Reply what problems you are experiencing and I will try to help.

Jan 23, 2009 | Vacuums

1 Answer

Lack of suction


I use a broom handle..works very well

Nov 26, 2008 | Kenmore 23612 Progressive PowerMate Bagged...

Not finding what you are looking for?
Vacuums Logo

Related Topics:

171 people viewed this question

Ask a Question

Usually answered in minutes!

Top Vacuums Experts

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18425 Answers

D. Floyd Kolb
D. Floyd Kolb

Level 3 Expert

43501 Answers

Are you a Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...