Question about Hoover U5450-900 Windtunnel Supreme Bagged Upright Vacuum

3 Answers

Wind tunnel supreme sounds very loud

We recently bought a wind tunnel supreme. it is very loud, and sounds like its going to come apart any moment.. the sound seems to be coming from the base. Is there anything we can check?

Posted by on

3 Answers

  • Level 1:

    An expert who has achieved level 1.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 8 Answers

Something mite be lose in the motor take to the nearest hoove repair store and have them check the motor

Posted on Feb 22, 2009

Be sure, especially if there is anyone with long hair in your home, to do this at least once a month:
Remove the bottom plate and take the brush out
Unscrew the caps at the ends of the brush and remove any hair and debris before replacing them
Remove the belt and then remove any hair wound around the drive shaft

Posted on Mar 02, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers

You can take the bottom plate off and check the belt and brush roll. if they look ok, then you may have a bad motor. But if this is less then 1 year old, then it is under warranty, you can take it in for warranty repair. There is a 1-800 number by the model number plate you can call to find out where you can take it to near you.

Posted on Feb 28, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Hoover 30600 max wind tunnel less than a year old makes a whistling noise


Ours did too. I bought a Dyson.

Check for gaps in the hoses and in the wind tunnel canister. Something is not sealing properly.

Nov 11, 2016 | Hoover Vacuums

1 Answer

Loud rattling noise and no suction


You have something that's been sucked up into the floor cleaning part of the machine... then clogged it off. Be persistent and you should be able to find it and get it out..

Nov 04, 2013 | Hoover Vacuums

1 Answer

How do you change the Hoover wind tunnel belts?


If you turn the vacuum over there will be (4) screws that hold on the base cover for the roller brush. Remove the screws and the cover and you can get to the belt(s). You can get replacement belts here:

Hoover Windtunnel Belts

Nov 18, 2009 | Hoover Company Wind Tunnel U53019 Upright...

1 Answer

I have a Hoover Wind Tunnel Supreme mach 3.9. It


Check the filter above the dirt tank. If you take out the dirt cup and look where in slides into the machine, there is a filter that is probably dirty. It can be cleaned or replaced

Oct 08, 2009 | Hoover Vacuums

1 Answer

Wind tunnel supreme sounds very loud


Sounds like a bad motor, you have a years warranty on this, take it in for warranty repair. You will void the warranty if you mess with it.

May 08, 2008 | Vacuums

1 Answer

Hoover Wind tunnel supreme, loss of suction


http://www.geeksquad.fixya.com/ThreadView.aspx?prdid=40600&thid=562967
Hoover Wind tunnel supreme, loss of suction
posted by bazballfan on May 01, 2008
Hello, I purchased two of these models in late 2007 and after changing the bags on each of them I have little to no suction with the vacuum. The hose is fine and I have taken them apart and there is no obstruction in the hose or in the base.
These worked so well and now they don't do anything. The bag isn't filling much and the simplest things can’t be vacuumed up
Please help me to fix this



Hello,
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure.
Hoover U5450-900 Windtunnel Supreme Vacuum
Sorry you are having a problem, it sounds lie you have done almost everything, but just in review it could be some of these problems:
Belt change – every 4 to 6 months
Are the brushes in good shape
Where does your suction drop off
Is the bottom plate securely on the bottom
Are there any gaskets that are broken or leaking
Is the bag installed securely
Did you check for any clogs or obstructions
Is the filter clean
Feel free to contact your local vac dealer in your area.
So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.
http://www.hoover.com Telephone
Contact our Customer Service Department at 1.330.499.9499
Monday through Friday
8 a.m. - 7 p.m. EST

Thanks, Don – The Vac Man
Go Ahead. Use Us.

May 01, 2008 | Hoover U5450-900 Windtunnel Supreme Bagged...

1 Answer

Edge of carpet went into carpet; was removed, but now all rollers on the unerside don't function.


You didn;'t say what the problem is, but I assume that the brush roll is not turning. Take of the cover over the brush roll, then you can get to the brush roll and the belt. The belt probably came off or broke. Best to replace the belt.

Jan 07, 2008 | Vacuums

2 Answers

Hoover wind tunnel vacuum cleaner shuts off during use


Check the inlet down by the brush roll to make sure it isn't clogged. If not and the hose isn't clogged, then probably the thermo protector (part #28382093) maybe bad. It is mounted near the motor. Could be motor Part #43576188. But I would suspect a clog in the inlet or hose, or the thermo protector has gone bad.

Dec 25, 2007 | Hoover U5444-900 5100 Wind Tunnel 15 Inch...

1 Answer

Hoover Wind Tunnel


what probably happened is you swapped end over end when you replaced the beater brush. anyway go to thehooverstore, find your machine and you'll see an exloded diagram of your machine.

Aug 18, 2007 | Hoover Company Wind Tunnel U53019 Upright...

Not finding what you are looking for?
Hoover U5450-900 Windtunnel Supreme Bagged Upright Vacuum Logo

188 people viewed this question

Ask a Question

Usually answered in minutes!

Top Hoover Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18330 Answers

Roger Potts

Level 3 Expert

694 Answers

Ryan S
Ryan S

Level 2 Expert

328 Answers

Are you a Hoover Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...