Question about Keurig Elite B40 Coffee Maker

5 Answers

The add water light stays on not matter how much water is in the reservoir

I have an Elite B40 Keurig coffee maker. The add water light goes on and stays on even when there is plenty of water in the reservoir. This has happened in the past and, after a while, it will sometimes just go off. I have tried unplugging the machine, re-seating the reservoir, etc.. This has also happened with the Keurig machines that other family members have.

Posted by on

  • 7 more comments 
  • lgann Jul 31, 2008

    I have the same problem. I have unplugged, reseated, refilled, emptied, tapped, touched, and cussed. None of the above seems to have had any beneficial effect. Any new ideas or solutions?

  • Anonymous Oct 28, 2008

    I have the same problem and it is something internal to the coffee maker. I tried a second reservoir and it displayed the same "Add Water" light no matter how much water was filled.

  • Anonymous Nov 10, 2008

    The add water light stays on..

  • liajewelry Dec 13, 2008

    Brand New - out of the box - and the 'add water' light will not go off - no matter what. Waiting to hear back from Keurig.

  • Anonymous Apr 01, 2009

    Tried the above. Nothing works. Any other ideas?

  • Anonymous Mar 12, 2014

    Once reservoir is empty how do you remove water still in coffee maker for transport

  • Anonymous Mar 12, 2014

    After removing side Water reservoir there is still water in the unit. How do you remove all water for storage?

  • Anonymous Mar 16, 2014

    were to buy

  • Anonymous Mar 26, 2014

    and the add water light is on but the reservoir is full

×

5 Answers

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 2,039 Answers

Lot of time you have a magnet in the water tank fill it with water and gently tap the side of machine the magnet is block or jam on empty


THANKS FOR USING FIXYA


PIERRE

Posted on Feb 24, 2008

  • Tenoso Apr 10, 2011

    Wow! That was easy and corrected the problem! There was a bit of grit or something wedging my water float in the up...emptied reservoir, lifted the float, removed the obstruction, refilled the water

  • neiltobin
    neiltobin Sep 01, 2012

    Didn't work. Now what? Help!

×

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

I found this site after having the same problem. None of my whacking and shaking helped. I think the magnet is a float, that's how it monitors water level, and it was floating so you would think it was working, right? Wrong. I poured the water out, shook the magnet around, installed the reservoir, and poured the water back in. The indicator changed to ready, life is good again.

Posted on Jan 26, 2009

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 1 Answer

On my unit, the floating water sensing disk is not a magnet but a reflective disc that is "seen" by a photo cell in the side of the unit. If the disk gets covered in junk so it isn't shiny anymore the sensor doesn't "see" it and thinks the water level is low. Remove the reservoir and put something shiny like a knife blade up to the photo cell. The light should stop flashing. Since the disc can't be removed to clean (a design flaw in my opinion), first try rinsing the reservoir with lots of fresh water. If that doesn't do the trick, I had to make a little tool out of wire with a bit of cloth on the end to scrub the thing. Its a tight fit but it has worked for me.

Posted on Dec 05, 2014

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Thank you pierre...it worked...have a great night

Posted on Nov 14, 2008

It worked, thanks

Posted on Oct 29, 2008

  • kittyco
    kittyco Oct 26, 2013

    That did the trick. Thanks much!

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Keurig B40 prime problem?


That whole system is run with air pressure. You need to check all the valves for deposits and proper operation.

Aug 10, 2014 | Keurig Elite B40 Coffee Maker

1 Answer

My Keurig Elite 40 (B40) beeps continuously when I turn it on.


Heating element may be damaged...return for exchange asap

Mar 05, 2013 | Keurig Elite B40 Coffee Maker

1 Answer

Keurig b40 pump out of sync


PLugged exit port tube. Manual Page 18

Jun 24, 2012 | Keurig Elite B40 Coffee Maker

Not finding what you are looking for?
Keurig Elite B40 Coffee Maker Logo

7,672 people viewed this question

Ask a Question

Usually answered in minutes!

Top Keurig Coffee Makers & Espresso Machines Experts

Mike Cairns
Mike Cairns

Level 3 Expert

3053 Answers

Richard Roth
Richard Roth

Level 3 Expert

9472 Answers

Cindy Wells

Level 3 Expert

4755 Answers

Are you a Keurig Coffee Maker and Espresso Machine Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...