Question about Kenmore 23313 Whispertone Bagged Canister Vacuum

1 Answer

No suction I just replaced the bag, and normally after this I have a lot of suction. Now that I have changed the bag I have less suction that I had before. Not even enough to picj up dog hair. I snaked he hose and checked all of the connections. It seems to have an air leak but no amount of tape will fix this. I cleaned the filer as well with warm water and dried it and re installed but still absolutely no suction. I am ready to throw it out! Any suggestions would be appreciated

Posted by on

  • marrarry Aug 21, 2008

    My Kenmore whispertone won't **** at all. The motor appears to be running but the suction is completely gone. I have changed the bag, ensured there is no leak in the system, checked the hose and the exhaust, cleaned all the filters I can reach without a screwdriver. It is a 9 year old vacuum but it cost a pretty penny and I am reluctant to throw it out. I don't want to spend a whole lot fixing it

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 2 Answers

1, Does the blower (discharge) side blow bunches of air??
Yes: Something is clogged from the bag to the hose end. Try blowing out the hose from the discharge side.
Or: The bag is not properly seated. Make sure that the plastic piece is properly inserted into the bag, and properly aligned and locked in place with the suction intake.
No: Something is wrong in the motor/fan assembly.
2: The hose has a plastic cover on the end farthest from the unit. Make sure that this cover is closed. If it is open, your suction will go way down.

Posted on Feb 24, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Why does my Electrolux epic 6000 sr shut off with suction?


Hi,

If this Epic 6000 is shutting off when you either just turn it on or while vacuuming with it...it\'s one of several things...1. Change the bag if you\'ve been picking up a lot of "fine" dust such as drywall dust or carpet freshener powder. That\'s ******* them. 2. Being the machine is over 22 yrs. old, the suction control valve inside either needs to be replaced or just cleaned well. This is the usual cause of the vac shutting off especially if you\'ve tried the dial in several different settings. Hope that helps!

May 20, 2014 | Electrolux UltraLux 2000 Bagged Canister...

1 Answer

No suction in hose


There is most likely something stuck in the hose.

Jun 06, 2013 | Riccar Model RC1100 Canister Vacuum...

1 Answer

Eureka Rally 2 had great suction the first two times I used it and now faint. No blockage and new bag and clean filter. What coud it be?


The dust bag holder is an important part of this vacuum. Make sure the bag is installed into the holder sliding bag collar into slots to secure.
Make sure the bag is tucked into cleaner. or the bag cover will not latch securely.
Also, the motor and exhaust filters should be cleaned at each bag replacement.
REPLACING THE FILTERS
Filters should be cleaned or replaced when they become visibly soiled or suction power is reduced. Always operate the cleaner with the filters installed to avoid motor damage. The dust bag must be changed and the filters cleaned or replaced if the window of the Clean Filter Indicator changes into red when the cleaner is operating at maximum power and the nozzle is raised from the floor.

Dec 25, 2010 | Eureka Vacuums

1 Answer

My Kirby Ultimate G does not have enough suction to pick up pet hair. Is there anyway this can be corrected? I felt under the vacuum when it was running, the roller is running, but I felt very little...


An Ultimate G has lots of suction. If you turn on your vacuum and the bag immediately inflates - that is how you can tell if your Kirby is moving air (suction). There is a more modern brush that came out with the Ultimate G Diamond and the Sentria that has stiffer bristles that dig up pet hair better.

Another way to test the suction is to spread some baking soda onto a hard floor and vacuum it up - you can see how much suction your Ultimate G has, or take off the vacuum head and put on a hose and test the suction at the end of the tube.

Ways to increase your Ultimate G cleaning efficiency. Take off the vacuum head and remove the brush roller. Attach your hose attachment and **** vacuum out the head. Put on a new belt, and remove any hair and or string or threads that may be wrapped around the brush roller. Put the roller back on and on the ends of your roller you will see that the ends spin and have numbers on them. If your vacuum brushroll is original - you could have your bristles rather worn and so you can align the #3 on BOTH sides of the brushroller. This would be a good time to consider upgrading to the Sentria Brush.
Remove the bag, and replace with the CLOTH Kirby bag. It has the best filtration and it has the best airflow (which increases what you are referring to as suction). If you want to go the cheap route - at least get the paper Micron Magic with HEPA filtration (but it has slightly less air flow)
Remove the side mini emptor from the vacuum and check to see if there is anything clogged up on either the vacuum or the mini-emptor.
If your engine is running and inflating the bag and you replace the belt, the brush roller and to the cloth dust bag - your vacuum should pretty much run like a brand new Sentria Vacuum. Your vacuum system is outstanding, but may benefit from a little TLC if you have been neglecting it.

Mar 19, 2010 | Kirby Ultimate G Bagged Upright Vacuum

2 Answers

My hoover has no suction at the nozzle, though it has strong suction at the hose. This problem started after I replaced the vacuum bag for the first time.


there is a blockage behind the roller brush remove the roller plate and the roller and check the inlet hose for a blockage also remove the bag and chek the inlet to the bag for some type of obstruction. Don the Vacuum Doctor Alb, N.M.

Nov 01, 2009 | Hoover Tempo Widepath Upright Vacuum -...

1 Answer

Lost suction after I changed the bag and cleaned the air filter


The bag has a cardboard collar with latex. It must seal over the inlet. Make sure not to tear the bag when replacing.

Is the cover closing properly? The cover seals against a gasket. The same with the filter.

May 20, 2009 | Riccar 8955 Upright Vacuum

2 Answers

Decreased suction


you might have a clog, to try and unclog the lines, you need to unplug the unit, and remove the bag compartment. Then take a shop vac using the hose attachment hold it into the attachment door where there is low suction and try to draw the clog out the way it went in.

May 09, 2009 | Broan-NuTone CV353 Central Vacuum

Not finding what you are looking for?
Kenmore 23313 Whispertone Bagged Canister Vacuum Logo

Related Topics:

213 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18298 Answers

Roger Potts

Level 3 Expert

694 Answers

yadayada
yadayada

Level 3 Expert

60769 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...