Question about Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum

3 Answers

Loss of Suction

Thank you for any help you can offer. I have a Kenmore Progressive Direct Drive Upright Bagless. When I start it up and begin to vacuum after about 3 seconds the suction power drops, a strange sucking noise comes from the lower right air vent and the intelliclean switch transfers all the way down to the green setting. There is no problem when I use the hose or the attachments.
Its the same noise you hear when you put your hand over the end of the hose...... the noise comes from the back lower right hand side of the vacuum. There is an air vent that seems to be making the noise.

Any help you can offer would be great. I just want to get the vacuum working again..... it was awesome before this happened.

Posted by on

  • bamajim Jun 07, 2008

    The only thing that has suction on mine, is on the bag. So much , that I can't open the bag door when it is running. No suction on carpet, or tool attatchment. I snaked a coathanger up through bottom up to where tools attatch, and couldn't see where it was clogged.

  • Anonymous Jul 28, 2008

    Loss of suction and a strange noise coming from the back after just a minute or two of vacuuming on carpet cyle. I've cleaned the debris out several different times from the intake in back of the brushes. Also, the present carpet fuzz in the cyclone contaniner doesn't circulate very much if at all. Even on just "suction tools" if you put your hand over the hose opening it makes that "choking" sound - so, I guess it's not just the carpet cleaning portion that's messed up.

×

3 Answers

  • Level 1:

    An expert who has achieved level 1.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 1 Answer

Thank you for this solution, it saved me $$$ and a trip to the repair shop.

Posted on Oct 11, 2008

  • Level 1:

    An expert who has achieved level 1.

    Problem Solver:

    An expert who has answered 5 questions.

  • Contributor
  • 7 Answers

The vacuum is supposed to do this. Basically, when there is a clog/blockage excessive suction can be generated inside the motor/fan system. To prevent overheating or failure of the vacuum motor, a small valve opens that lets air be sucked into the vacuum allowing the motor to work easier. You can cause this to happen by simply placing your hand on the suction tube blocking all suction. The small valve is actually a piece of rubber with a spring behind it.

To fix the problem, find all the blockage or low flow locations and clear them. Clogs and multiple dirty filters will cause this.

Posted on Dec 05, 2008

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers

If the suction is ok at the end of the hose, then check lower, The dirt inlet is probably clogged and that is why with the hose off, it sounds ok. The inlet starts by the brush roll and goes up to where the hose plugs into it.

Posted on Feb 29, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Ther is no suction and rolar prush is not runing in my kenmore vacume progressive


Remove the rotating brash and check it, something is blocking the suction, probably you need a new belt

Mar 24, 2013 | Kenmore 31912 Progressive Direct Drive...

1 Answer

Manual for Kenmore Progressive Direct Drive Upright Vacuum


can some one show via picture of the location where the micro switch is where the hose attaches to the progrssive direct drive vacuum cleaner to get the start brushes rolling again,

Sep 28, 2010 | Kenmore 31913 Progressive Direct Drive...

2 Answers

Our kenmore progressive with direct drive makes real loud noise when using and i am sure we have the bag on the right way


Hi,

Here is a tip that I wrote about my Bissel but I bet you have the same problem and the hose is clogged...

Bissell Bagless Upright Vacuum not working


heatman101


Aug 29, 2010 | Kenmore 31913 Progressive Direct Drive...

1 Answer

My vaccuum has no more suction


There is no drive belt on a progressive drive vacuum. It is direct drive meaning it is attached via the motor. No vacuum means no air flow somewhere in the unit. Torn bag,Wrong bag, pluged filter under bag.Make sure the opening in the bag is the correct size,too big and it will not seal. Make sure when you close the housing it seals also. No housing seal no vacuum. Kenmore vacuums tend to be plastic housings. Cracks are comon in the wheel housing area. Check there first. Plastic expoxy will work with this fix if so needed.

Feb 22, 2010 | Kenmore 31913 Progressive Direct Drive...

1 Answer

I have a Kenmore Progressive Inteleclean Upright vacuum cleaner (with Bag) . It has good suction only through the hose now and none through the bottom for cleaning carpets. and, there is a noise like it...


Theres a little bendable neck that hose with suction plugs into. Thats the one thats clogged. You will have to fish it out by taking off the roller and clearing the clog.

Sep 22, 2009 | Kenmore Progressive Bagless Upright with...

1 Answer

Only suction to attachments


Something is stuck in the throat of the floor head, between the brushes that turn, and where the hose connects at one side (usually right hand side) of the floor head.

Reply back what you find.

Feb 04, 2009 | Kenmore 35912 / 35913 Progressive Upright...

1 Answer

Kenmore progressive Direct Drive Vacuum w/Hepa


Check the hose and dirt inlet for a blockage. Also the brush roll, check it to see if you can turn it or not by hand. If not, then something may have jammed it.

May 03, 2008 | Kenmore 31913 Progressive Direct Drive...

2 Answers

Getting suction to use attachments


When the vacuum is in the upright position, it should give you suction thru the hose.

Dec 02, 2007 | Kenmore 31913 Progressive Direct Drive...

1 Answer

My vacuum is not sucking at all.....


I took out the air flow filter at the back of the vacuum and turned it on, somehow the clog cleared. Then I put the filter back in and it works perfectly! Barb

Mar 01, 2007 | Kenmore 35912 / 35913 Progressive Upright...

Not finding what you are looking for?
Kenmore Progressive Bagless Upright with Inteli-Clean SystemVacuum Logo

1,079 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenmore Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18297 Answers

Roger Potts

Level 3 Expert

694 Answers

yadayada
yadayada

Level 3 Expert

60667 Answers

Are you a Kenmore Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...