Question about Car Audio & Video

1 Answer

Reicever light up but no display or sound

Had battery in my car replaced now ny sterio lights up but there is no display or sound

Posted by on

  • 3 more comments 
  • rozz174 Mar 20, 2008

    i have the eclipse 5443 it lights up and has sound but no display

  • rozz174 Mar 20, 2008

    i have the eclipse 5443 it lights up and has sound but no display

  • Johnny Apple Apr 19, 2008

    Display doesn't illuminate but still here sound. Reseting doesn't work either connections and fuses all are fine.

  • presstone007 Aug 22, 2008

    mines brand new. the display lights up and everything but i hear NOTHING from my speakers. not even fuzz or anything.


    i have a 98 expedition btw

  • hsvsvz1 Dec 24, 2008

    i switch the ign on and the backin lights on pold out panel light up and i have sound on one side of the car and no visual on the screen

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that hasĀ over 10 points.

    Mayor:

    An expert whose answer gotĀ voted for 2 times.

  • Contributor
  • 43 Answers

Check the fuses first - there will most likely be one that is hot in accessory and one constant hot.

Posted on Feb 23, 2008

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Display POWER ON but SC25 not working.not reset


my regservo need to active plz help me for activation code

Dec 29, 2013 | Pioneer Elite SC-25 7.1-CH A/V Receiver

1 Answer

Cva 1003 STERIO. (ALPINE) i dont have illumination wires, will this mean that my sterro wont work?


that just means that the backlighting for the display will not switch on and off, or dim, with the dashboard lights, the display will be lit all the time.

Mar 12, 2011 | Car Audio & Video

2 Answers

LG 700E CRT 17" monitor,


problem with the monitor Display cable. it is damaged.

Normally monitor will receive 3 colors red, green, Blue signals from CPU. If one cable i.e Red wire connection is missing in display cable which is connected to monitor, Red color image on monitor wil be replaced with other fade color.
So, need the replace the display cable or display connector!

Dec 09, 2010 | LG Studioworks 700S 17" CRT Monitor

1 Answer

Display light problem


Hi,

If your display screen is not displaying on your Nokia 3220, this is screen problem on your phone.

To solve this problem, you will need to replace the screen on your phone. I have experience this kind of problem before, what i did to solve the problem was to replace the screen on ny phone.

Replacing the screen on your phone will solve the problem on your phone.

Regards.

Jul 24, 2010 | Nokia 3220

2 Answers

2007 Monte Carlo wouldn't start this morning.


The vehicle is almost new so I wouldn't normally suspect a bad battery due to weather changes. A dome light or spot light might have been forgotten which would drain the battery over night. Check all light switches and you'll know right away if that's what may have drained the battery to cause this clicking sound that is so typical of a dead battery.
Hope this helps

Dec 07, 2009 | 2007 Chevrolet Monte Carlo

1 Answer

Toyota corolla 1995 sterio fuse proublem


Trying replacing the radio fuse under your dash. You have blown the radio fuse, and I believe the dome light is on that fuse as well.

Feb 04, 2009 | Sony Xplod XM-554ZR Car Audio Amplifier

1 Answer

No sound from sterio when engine is reved.


This sounds like you have a problem with the voltage regulator in your car. Normally it is part of the alternator. Does your lights on the inside and outside of car get dim when the engine is idle, and do they get brighter when you rev the engine? Does your battery gage go way down when the engine is idle and then go way up when the engine is revved up? These are all signs that the regulator is not working.

The radio will only operate normal at the proper voltage, if your voltage regulator is putting out too much voltage when the car is revving, it can make the radio malfunction.

Have the alternator/regulator in your car checked. It may just be that part needs to be replaced.

Nov 09, 2008 | JVC AM FM CD DET FACE CAR STEREO

1 Answer

2000 Intrepid turns over no spark


"No Bus" usually means you have a bad ground. Check the condition of the battery ground, clean it if necessary. Check other grounds as well.

Jun 10, 2008 | 2000 Dodge Intrepid

Not finding what you are looking for?
Car Audio & Video Logo

Related Topics:

317 people viewed this question

Ask a Question

Usually answered in minutes!

Top Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4807 Answers

yadayada
yadayada

Level 3 Expert

70346 Answers

The Knight
The Knight

Level 3 Expert

72620 Answers

Are you a Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...