Question about Westinghouse WST1600 Upright Vacuum

1 Answer

WST 1600A I purchased this vaccum about four months ago from Heartland America. Up to this point it's worked fine. After cleaning it this time when I went to start vaccuming again it runa for about 10 seconds and cuts off. I've changed the battery, taken everything that can be removed out checked it and replaced it. THe motor sounds like it's straining. I have not taken the housing off the motor to see what's going on with that. I misplaced my manual.

Posted by on

  • Catpoint Feb 23, 2008

    Thanks but I've already checked every place there could be a clog in the machine. It's kinda confined to the motor area. I'm skeptical to mess with that part of the machine.

  • laketravis Apr 17, 2008

    This is the second WST1600A I purchased. The first one I bought 2 years ago, one battery lasted less than a year, the next one died just after a year. Since the packs are so expensive, i bought a whole vacuum via Amazon.com 3/28/08 and it came in with both battery packs dead - after charging they will run for less than a second and turn off with the straining sound. Nothing wrong with either vacuum since the one old pack that holds a charge works fine in both,



    The batteries are on back order at Westinghouse. If you bought a WST166A less than a year ago, call and ask for a new pack. They are nice enough and willingly exchange. but they are on back-order.



    Scott 78734

×

1 Answer

  • Level 1:

    An expert who has achieved level 1.

    Hot-Shot:

    An expert who has answered 20 questions.

    Corporal:

    An expert that has over 10 points.

    Mayor:

    An expert whose answer got voted for 2 times.

  • Contributor
  • 27 Answers

It sounds like there is a clog. If there is no air flow it could be overheating.

Posted on Feb 23, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Sucking and blowing


Shop-Vac® Brand. The Original Wet/Dry Vac™

https://www.shopvac.com/
Shop-Vac® is proud to be an American-based company. ... When we say the Shop-Vac® is powerful, we're talking debris cleaning, leaf-blowing, heavy-duty, wet or ... Many of our vacs are backed with a 3 to 5 year warranty, but we've seen ... I had just gotten back from work, so my arm was hurting, and I really didn't want to ...

My ShopVac Blows - WOOD Community

community.woodmagazine.com > Forums > Tools and Tool Buying
Nov 23, 2009 - My ShopVac suddenly started blowing dust out the exhaust ports. I don't mean a little dust, it blows almost as much dust as it sucks in!!!! ... ... I'd look it over very carefully looking for tears or splits. Might be a good idea just .... A few months ago I purchased a Dust Deputy and hooked it up to my shop vacuum.

10 Shop-Vac Vacuum Hacks For Around The House - Thrillist

https://www.thrillist.com/.../10-shop-vac-vacuum-hacks-for-around-the-...
Sep 14, 2015 - Simply flip the switch from suck to blow and blow leaves to your heart's... you really need to get your act together if you're using a Shop-Vac for ...

Shop Vacs...and dust control? - Home Forums - GardenWeb

ths.gardenweb.com > Home Forums > Cleaning Tips

Jan 09, 2016 | Shop Vac Vacuums

1 Answer

I can run my dc17 to clean my floors but when I put it upright to use the wand it turns off


I called Dyson and they walked me thru the process of making sure nothing was blocking the airflow and suction. Everything seemed fine (not blocked). We couldn't figure out anything on the phone and I was still having the same problem.

Trying to figure out the solution, I removed (entirely) the filter that you're supposed to clean every 6 months and ran the vacuum (I cleaned this filter 2 months ago). It worked! I cleaned the filter (again!) and let the vacuum run and it seemed fine.

I can understand why they won't instruct you to completely remove the filter but it would save a lot of time if they just had you check ALL the options.

I hope this helps!

Longmont Epoxy Garage Floors

Sep 10, 2013 | Dyson DC17 Animal Bagless Upright Cyclonic...

1 Answer

I bought it in may , I can honestly say , it is THE worst vaccum


There are several filters on bag-less vacuums that need to be cleaned. Dig out your owners manual or open the one below. See section 3 for filters and maintenance. If you are vacuuming a house bigger than about 1500 square feet, you should be cleaning the filters every other use. Personally, after using a bagless for a couple of months, I went back to my bagged vacuum.
http://www.hoover.com/pdfs/manuals/U6630900.pdf

Dec 20, 2009 | Hoover U6630-900 WindTunnel Bagless...

1 Answer

Brushes do not turn worked , fine last time i used it a month ago.


The brushes are run by vaccum. Take the brush out and there is a passage way in there that could be blocked. If I rememer correctly there is a screen in there. If that dont help then there is a spring hooked to a lever underneath so when you lay the back down it engages caccum to the rollers. It could be that this is stuck and not moving. Try moving it by hand with the scrubber running.

Jun 20, 2009 | Hoover F7220900 SteamVac V2 Upright Vacuum

1 Answer

Cord Heats Up


You have prob run over the cord and caused a internal short in the cord to be sure plug in but dont turn on the vac see if it gets hot if no then your motor is drawing to much power. check the brush see if it moves easly with your hand and UNPLUGED if it does not turn easly there is string or carpet that needs to be removed.And if thats not it look for a new vac

Jun 13, 2009 | Vacuums

1 Answer

How do I remove the housing cover on a westinghouse vacuum?


Remove clear snap-in lights lens. Remove both lightbulbs. Where the bulb sockets are there is a screw, remove them. Then simply pull up on the housing from the rear where the wheels are and remove the top cover.

Dec 28, 2008 | Westinghouse WST1500 Wired Special Edition...

1 Answer

NO POWER WHEN I PLUG UP THE VACCUM


I had the same problem when I first bought mine. I let it set for a while and did some online research. I can't remember the site I went to, but it said that this sweeper will shut off when overheated to protect it and will start back up later. I went back and turned mine back on and it was fine.

Jul 27, 2008 | Hoover U5507900 Elite Rewind Bagless...

2 Answers

I purchased a hoover windtunnel 2 model#u8361900 in Dec 2007.I am very disappointed because the self cleaning filter is not turning and particles keep clogging in that area. I have manually removed the...


http://geeksquad.fixya.com/ThreadView.aspx?prdid=0&thid=724091
Generic problem for all Vacuums
I purchased a Hoover WindTunnel
Posted by billmar082 on Jun 30, 2008
I purchased a Hoover WindTunnel 2 model#u8361900 in Dec 2007.I am very disappointed because the self cleaning filter is not turning and particles keep clogging in that area. I have manually removed the particles but the filter will not turn. I also haven't been able to use the pet brush for some time. The cleaner has not been used hard about once a week since it was purchased. I am not happy that this product has stopped working efficiently since purchased 6 months ago. Thank you Marcia Long Pottstown Pa
Hello,
I would advise you to ALWAYS to FIRST UNPLUG YOUR VACUUM before beginning any service procedure. I sorry you are having a problem with the Hoover WindTunnel Vacuum Model #U8361-900 but I never heard of a filter that you say is self cleaning and NOT turning. I have never seen a filter that turns inside the chamber, the dust and dirt basically go around and circulate around the filter and you can clean the filter by either brushing it off, vacuuming it off or using some type of brush to clean off the filter such as and old paint brush or if you have some type of blower system – that would work as well. You said your vacuum is less than one year old so I would contact your local factory authorized Hoover dealer in your area or to cal the cust serv @ the Hoover factory listed below. So if you need further assistance, please feel free to contact your local vacuum cleaner dealer in your area or in the yellow pages, or contact the factory phone number or website to further assist you with your questions.

http://www.hoover.com Telephone
Contact our Customer Service Department at 1.330.499.9499
Monday through Friday
8 a.m. - 7 p.m. EST

Thanks, Don the Vac Man
Go Ahead. Use Us.

Jun 30, 2008 | Kenmore Progressive Bagless Upright with...

2 Answers

Hoover Z-400 - Hepa Filter


These filters should be changed at least once a year, they get clogged up and won't clean out. So I would try a new filter and go from there, make sure there are no clogs in the hose and down below where the dirt inlet is.

Feb 20, 2008 | Vacuums

2 Answers

WST1600 upright


Hi , check battery teminals might corroded need clean the post ,unscrew clean and try to charge , if does not full the battery have problem , need to replace.

Jan 21, 2008 | Westinghouse WST1600 Upright Vacuum

Not finding what you are looking for?
Westinghouse WST1600 Upright Vacuum Logo

Related Topics:

145 people viewed this question

Ask a Question

Usually answered in minutes!

Top Westinghouse Vacuums Experts

Les Dickinson
Les Dickinson

Level 3 Expert

18299 Answers

AskDyson
AskDyson

Level 3 Expert

2572 Answers

Roger Potts

Level 3 Expert

694 Answers

Are you a Westinghouse Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...