Question about Filter Queen Majestic Canister Vacuum

1 Answer

The electric Foot keeps losing power have tried cleaning the arm connections but I think its in the foot itself

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 506 Answers

The problem may be in the motor itself, there may be a loose terminal screw or wire nut that makes the electrical connection to the power head motor. The motor in the power-head consists of two wires it is just a matter of disassembling the power-head. If the motor was shorted it would not function at all. Also check the strain relief of the pigtail lead that attaches the wand to the power-head.

Posted on Feb 08, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of.(from cars to computers, handyman, and even drones)
click here to download the app (for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

The power nozzle is not working and the belt seems to be in place. The motor is running fine and I can use other attachments


There are a few problems with this head which we frequently encounter.

One, the motor get's clogged up and the brushes get stuck in the motor.
The red top circuit breaker fails, and under load, the motor will stop.

Take the 2 wires off of the breaker in the power head, and short them together to find out once you have cleaned out the motor which will be a mess inside.

The belt if worn will not operate the power head if you put your foot on it and see if the brush spins.

The belt is a major problem as well as the replacement of the motor.

The motors are 45.00 CAD and belts 4.00 Cad.

The yoke on the power head also gets clogged and needs cleaned out.

Try these procedures and I hope all works out for you!

William R!

Feb 21, 2015 | Rainbow E series Canister Wet/Dry Vacuum

1 Answer

My miele shuts off and/or will not start unless i wiggle the cord and get lucky. what can i do at home? i have no money to bring it to a service center.


If you think you're going to get to me that way ... you're right!
Soft-touch is my middle name. :-)

I can think of a few possibilities.
- The AC outlet where you plug the vacuum may be faulty. - Not uncommon.
- The plug on the power cord may be either loose or the blades may be corroded. - Most likely.
- The power cord may have a break in it. - Probable.

Let's eliminate the possibilities.
1. Plug something else in the AC outlet and see if shaking the cord does anything.
Is the appliance on regardless you shaking the cord?

2. With your vac power cord fully extended plug it in.
Step on the cord about half way, and shake the section between your foot and the vacuum.
Anything? Probably not.

3. Now shake the section between your foot and the AC outlet.
Anything? Probably yes.

I suspect the problem is in, or very near, the plug itself. The new molded plugs tend to go like that.
Take hold of the cable about a foot from the plug and gently move it pushing lightly towards the wall. The vac will likely come on.

If that's the case, all you need is a replacement plug that's in good shape, and a good samaritan-ess to replace it for you. Unless of course you're the handy type.

If it is a three prong plug, make sure to use the same type.
.

May 31, 2011 | Miele s558 Silver Moon Vacuum

2 Answers

Plenty of suction from the hose pipe itself but no suction when vacuuming the carpet


Hello Can,

Go through this guide to help find the issue www.builtinvacuum.com/flowchrt.html. You should have suction without a filter. The bottom is on the unit, right? It needs to be air tight.

Apr 21, 2011 | Vacuums

1 Answer

I have a Electrolux canister model L-E (circa 1986). Won't turn on. I think the foot switch is broken inside. Was working fine - turned it off then would not turn on BUT foot switch sounded different,...


I have one of these LE models also. Yes, the on/off button is broken. I have had to replace it twice on mine. My local vacuum repair shop suggested NOT to use your foot to operate this switch, but just press it on or off with your fingers. That will help to keep it from breaking.

Jan 10, 2011 | Electrolux UltraLux 2000 Bagged Canister...

1 Answer

I unscrewed the 4 screws on the bottom of my gen 3 mistakenly trying to replace wheels. now it turns on sometimes when the on button is pushed and sometimes it doesn't. is there an easy fix?


Easy fix... wow... um.. maybe.

I think that you may have accidently disconnected the metal arm between the foot pedal and the actual switch. Its not a problem, but you will have to open the top of the kirby unit to see if it has been disconnected or not. we are trying to get to the area above the wheels but below the foot switch.

first, take the handle and the bag off the unit and lay them down.
next, take the plastic covering around the switch off, you will need a flat screwdriver to take that off. the pry spot is just above the switch where you can slide in the screwdriver.
next, lift up the light and remove your belt/brush attchment off the front of the unit.
remove the 2 screws at the top portion looking just above the shaft sticking out of the unit.
remove the 2 screws behind the foot switch
you should see what looks like a 7/L chrome metal bar going between the footswitch and an orange plastic piece inside the unit where the bag goes. it should be inside the orange plastic piece and inside the lower portion of the footswitch.

I think that when you dropped the wheels it may have come off of the footswitch. re-attach and you should be good to go.

Good luck.

Nov 06, 2010 | Kirby Generation 3 Bagged Upright Vacuum

1 Answer

Vacuum is making a burning smell from the motor/fan.


Hello,

Actually the screws to access the motor on Kenmore canisters are located underneath of the foot pedal that retracts the cord reel, and there's usually also two screws that underneath of the tool lid arms.

You may access the screws underneath of the cord reel by prying the foot pedal off of the vacuum. Simply put a flat head screw driver in between where the foot pedal and the vacuum cleaner meet on the top of the machine, and pry upwards with the screw driver. Once you remove the pedal you'll see the screws and have direct access to the vacuums motor.


If you are trying to access the power nozzle motor, here's a detailed step by step instruction tutorial that will walk you right through it.
http://www.fixya.com/support/t4499227-need_replace_belt_in_kenmore_vacuum

When a vacuum cleaner smells like something is burning, it can only really be one of two things. Either the rubber belt inside of the power nozzle is burning, or the motor is burning. If it's the belt that's burning, it will be a burning rubber type of smell, but if it's the electrical motor, it will be more of an electrical smell.

If you have any further quesitons, please feel free to reply using the clarification request tool here on Fixya. I'm always more then happy to answer any follow up questions.

If this was helpful, please rate my repair by clicking the thumbs up icons in the top right hand corner of this repair.

Thank you,

Chris J.
GoVacuum.com

Apr 11, 2010 | Kenmore 25614 / 25615 Progressive Bagged...

1 Answer

My solution release is not releasing cleaning solution


This unit uses two things to release the solution:
(1) an eletrical switch in the upper handle to send the signal to the foot valves, and
(2) an electric valve in the foot to release the solution to dispense on the carpet.

There is not reason to believe the switch has failed, and you would need somebody to check the voltage at the valves when the trigger is pulled. This should only be done by a person comfortable with a electric test meter, as this is 120 volts to the valves.

Mar 11, 2010 | Hoover F7431-900 SteamVac Vacuum

1 Answer

Foot activated power switch will not remain on


This kind of switch will turn on the power when it's pressed down a little, but must be pressed down further for it to actually lock itself on. First, make sure that you're pressing it far enough. One way to tell is operate the switch with the vacuum unplugged. You'll here it click when it locks. Make sure there isn't a foreign object or gunk stuck under the foot pedal that's keeping it from moving the whole way. Finally, you'll have to open the vacuum up, with it unplugged, and check the power switch inside. Try operating the power switch with just your hand. If you think it needs a new switch, you'll easily be able to find one, and really should be able to find one for only a few bucks if you're willing to do the shopping. Just hook the new one up like the old one was.

Dec 29, 2009 | Vacuums

4 Answers

I have a red c velvet. My vacuum keeps shutting


Could be you have a filter issue and it is overheating and shutting itself off. Make sure you have not put on the wrong filter type for the machine. Some of the pieces that come in the FJM boxes are not actually filters and people make the mistake of putting them on as filters. The other major problem that could be happening is that there is some problem with the hose itself. On my vacuum it will shut itself off after 2-5 minutes, but the power light remains on. I have to press the up button to get more suction, but that only lasts until it shuts itself off again. If I unplug the hose from the cannister... the power comes on fully and the vac never shuts itself off.
A tech told me that the likelihood is that there is some component or connection in the hose control that is causing faulty shutdown. He told me I would need a new hose costing $175. After a year of trying different things, I am convinced he is right and we need to bite it and just buy a new hose.

Sep 13, 2009 | Miele S558 Red Velvet Bagged Canister...

Not finding what you are looking for?
Filter Queen Majestic Canister Vacuum Logo

Related Topics:

67 people viewed this question

Ask a Question

Usually answered in minutes!

Top Filter Queen Vacuums Experts

Brad Brown

Level 3 Expert

16373 Answers

yadayada
yadayada

Level 3 Expert

77169 Answers

Steve Sweetleaf
Steve Sweetleaf

Level 3 Expert

1147 Answers

Are you a Filter Queen Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...