Question about Miele Red Star Bagged Canister Vacuum

1 Answer

New Miele Red Star - Powerbrush not working

I bought a new Miele Red Star on the internet and connected it as shown. However, the power brush does not come on. I have unplugged both power connections, powered it off and on (unit and brush), and taken the cover off the bottom of the brush to be sure nothing was stuck in there (it was clear).

Any ideas on what might be wrong?

Posted by on

  • doitmyself2 Feb 22, 2008

    Duh, why didn't I think of that? The attachments are are SEB 213 and SES 105. The plug on the SEB 213 does not fit into a wall socket. Also, I did make sure both plugs were pushed in multiple times. The plug from the powerhead to the vac can be plugged into the vac handle or turned over and plugged into the vac handle. Hopefully I did not burn something up trying it both ways. Thanks much. Guess I'll take it to the dealer.

×

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    President:

    An expert whose answer got voted for 500 times.

  • Master
  • 1,673 Answers

Wish you had listed the model number of the vac and of the powerhead. The plug going into the cannister, is it pushed all of the way in, also same for the plug going into the hose end? You can hook up the powerhead plug to a/c and see if it runs, if it does, then it is ok. Unhook the hose and plug and hook up a/c to that plug end and see if the powerhead will run, if not maybe the switch on the hose handle has a problem. Otherwise you have a problem in the cannister. If this is brand new, then it has a warranty, take in for repair.

Posted on Feb 22, 2008

  • gfweis Apr 15, 2011

    Thanks very much for this tip. When my power head stopped working a couple days ago, I called and asked the local Miele repair shop what might be the problem. They said it was almost certainly a bad switch. Cost? $39.95 labor; $80 for the new switch. (Or perhaps a short in the electrical line in the hose...cost for that was even more.) Actual answer: the plug going into the cannister, although it didn't look loose, just needed to be taken out and put securely back in. Apparently, even if it is a very little bit dis-lodged, power is shut of to the power head. You saved us a visit to the repair shop. Very generous of you.

×

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

Miele 228 power brush stopped working


Does the motor on the Head Run but the Brush does not turn... change the Belt, the brush head is operated by a rubber belt this is so it has no direct drive so if you suck up something then you ruin a belt and not the motor. Besides you should change the belt as per MFG directions. I change ours at Least 2 times a year and if you do.. say Pull in a Rug corner and it smells like Burnt Rubber? ... you just decreased your life of the Belt.... you'd be surprised on how well a New Belt helps your Vac pick up things. Change the bag often too, do not wait till it can pickup no more. The bag is Not meant to be FULL to be changed, besides it keeps Mites in the trash where they belong and not a breading ground in your closet... If you have a bag-less clean and rinse (All Filters Every Vac has a Filter even the Bag-Less ones) and let dry after a day of vacuuming follow MFG directions, Hope this helps.

Jul 22, 2014 | Miele SEB 228 Powerbrush

1 Answer

Miele Red Star, small spark at outlet, no power to vacuum


The vacuum has a standard tube internal fuse. If you are lucky that is all it is. See the site http://www.sannerud.com/house/miele.html for instructions on how to open it up.

hope that helps

Jun 05, 2010 | Miele Red Star Bagged Canister Vacuum

2 Answers

I need a new motor


red star was part of there low end line. not cost effective as miele parts prices are outrageous.

May 06, 2010 | Miele Red Star Bagged Canister Vacuum

2 Answers

Miele SEB-213 powerbrush stopped working


Pull the head cover off to check the belt, if the belt is ok then it might be the power connection between the handle and the power head shaft. If the red light is on the power head, then its not the connection
because its getting power. Now some heads have a reset button on them,you could check this also.
With the cover off the power head, remove the belt, now turn it on, and be careful, but try to make the motor shaft spin,with one finger, because if it does start to spin you do not want to hurt your finger.

If the motor starts to spin,put the belt back on, if it does not spin again, the motor is too weak.
If it does not spin at all, the motor is bad.Hope this helps you,and you get it working.

Mar 24, 2009 | Miele SEB 213-2 Vacuum

1 Answer

Meile SEB 213 powerbrush cuts out


Your problem is either in the wand, assuming you have the telescopic dark grey electric wand. The only other thing it could be is the hose, once again, assuming you have the electric hose with either the rocker switch that shuts down the power brush, or the deluxe hose, with the electronic suction control, as well as the brush shut off. Miele wands and hoses are notorious for causing power brushes to cut off. If your Miele is under two years old, I would suggest taking it to a autherized Miele service center, and see what, if any, warranty you have left, and have it checked out. Let me know how you make out.

Jan 14, 2009 | Miele SEB 213-2 Vacuum

1 Answer

I have a Miele Red Star vacuum, model 314i. I bought a HEPA filter for it but am not sure how to install it.


Hi,

At GoVacuum we put together a General Miele Maintenance video together for Miele Owners. Although the video showcased in the video is not specifically your Red Star machine, the filter installation is going to be the same.

Check it out here:


Sep 03, 2008 | Miele Vacuums

3 Answers

The dirtlifter powerbrush do not trun.the belt are ok and i unplug it and trun it back . still not working


I have a Bissell Dirtlifter Powerbrush that will not spray soap. I assume the soap lines are clogged, but how in the heck to you "unclog" them? I've searched high and low on the Internet looking for that answer.......

Apr 20, 2008 | Bissell 9500 ProHeat 2X CleanShot Upright...

1 Answer

Miele Red Star


it's under the canister handle, on the left side.

Aug 15, 2007 | Miele Red Star Bagged Canister Vacuum

Not finding what you are looking for?
Miele Red Star Bagged Canister Vacuum Logo

1,226 people viewed this question

Ask a Question

Usually answered in minutes!

Top Miele Vacuums Experts

Ryan S
Ryan S

Level 2 Expert

328 Answers

Roger Potts

Level 3 Expert

694 Answers

Les Dickinson
Les Dickinson

Level 3 Expert

18299 Answers

Are you a Miele Vacuum Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...