Question about Kenwood KAC-9104D Car Audio Amplifier

1 Answer

My kenwood 9104d amp is not pushing my subwoofers like it was. when i unhook on subwoofer it sounds like it did, but when i plug the other one up it dose not push them hard

Posted by on

Ad

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 12,061 Answers

Sounds as though one of the crossovers in that one is faulty?

Posted on Feb 06, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

2 Answers

Kenwood kac-9104d stopped working was in car music loud amp stoped worked I stop to change fuse it wasn't blown popped hood that amp was blown don't know what's wrong with it


Turn your gain below half. Make sure you have a solid ground, not a seat belt bolt. The fuse blew to protect the vehicle because there was too much power being pulled by the amp, possibly from overheating.

Sep 19, 2011 | Car Audio & Video

1 Answer

How many watts in a Kenwood kac-9104D


Kenwood KAC-9104D

Product Features
  • Mono subwoofer amplifier
  • 500 watts RMS x 1 at 4 ohms (900 watts x 1 at 2 ohms)
  • Variable low-pass filter (50-200 Hz at 24 dB per octave)
  • Bass boost (0-18 dB at 40 Hz )
  • Subsonic filter (15/25 Hz, 18 dB/octave )

Jun 29, 2011 | Kenwood Car Audio & Video

1 Answer

My kenwood light is red it turn green 4 a slpit second n turn bac red n want play my subs need help how to fix it


UNHOOK YOUR SPEAKER WIRES FROM AMP/IF THE GREEN LIGHT STAYS ON IT IS ONE OF
YOUR SPEAKERS.

Dec 21, 2010 | Kenwood Car Audio & Video

1 Answer

What kind speaker use my kenwood powered subwoofer 103SW


It uses a 10 inch, 4 ohm speaker, probably rated at 100 watts. If you are getting no sound, check your connections. Or, the subwoofer amp may be blown.

Aug 29, 2010 | Kenwood 103SW Speaker

1 Answer

I recently purchased a new Kenwood KAC-9104D 1800 amplifier. I hooked it up just as I had with a previous amplifier but it wont power the subwoofers. When one of the RCA cables is plugged in and the other...


You should check and verify first the output signal in the amplifiers by using a multimeter on the db range, this is to identify good output of the amp. After that check the polarities for correct wire orientations.You should connect the speakers one at a time to check.

Jan 16, 2010 | Kenwood KAC-9104D Car Audio Amplifier

1 Answer

I have a Kenwood KFC-W3514DVC and its hooked up to a Valor Multimedia VPA402 500 watt 2 channel amplifier. If i want to optomize my system the cheapest way should i buy another subwoofer or should i buy a...


find the rms rating of the sub and compare it to the amp.if the rms of the amp is higher than the sub you have enough power to push the sub.if its lower look at the rms of the amp if it can be bridged.you would like to see the rms matched to the sub or subs if you have enough power.

Sep 06, 2009 | Kenwood KFC-W3514DVC Car Subwoofer

1 Answer

I have a kdc mp632u and i cant get any sound out of my subwoofers. The amp comes on and there is power to the amp but still no sound. can someone tell step by step what i have to do to get it to work with...


Hello,

First, make sure that the RCA's from the HU to your amp are properly connected, and fully seated on both ends. There are 2 sets of outputs. You should be using the ones on the left as you face the rear of the HU. Here is a link to the manual. Page 40 shows the connections on the back:

http://inform3.kenwoodusa.com/manuals/KDCX590.pdf

After making sure that everything is connected OK, check to see if you have the subwoofer output turned on your MP632U.

To do this, push the control knob on the right toward AM (toward the bottom). Subwoofer output switches off/on each time you push it. When it is on, the display reads "SW ON".

If this does not solve the problem, you most likely have a defect in either the HU or the amp.

Hope this helps! If it does, please rate as "FixYa." Thanks!


Mar 28, 2009 | Kenwood KDC-MP632U

1 Answer

How to adjust the controls and gain on my kenwood 9104d 1800w amp


Hook the speakers in series to decrease your chances of blowing the amp and/or speakers themselves. And at high volumes make sure that the bass control is set for flat response.

Jun 25, 2017 | Car Audio & Video

1 Answer

Kenwood KDC-W6031 DC Player front panel will not release, the release button cannot be pushed down.


Unhooked panel at one side and it came off. I then took the panel apart and removed the piece of plastic blocking release button.

Aug 07, 2008 | Kenwood Car Audio & Video

Not finding what you are looking for?
Kenwood KAC-9104D Car Audio Amplifier Logo

Related Topics:

184 people viewed this question

Ask a Question

Usually answered in minutes!

Top Kenwood Car Audio & Video Experts

xxxxxx xxx

Level 3 Expert

4861 Answers

yadayada
yadayada

Level 3 Expert

76109 Answers

Jeff Turcotte
Jeff Turcotte

Level 3 Expert

8269 Answers

Are you a Kenwood Car Audio and Video Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...