Question about Sony XM-754HX Car Audio Amplifier

2 Answers

Sony XM-754HX Car Audio Amplifier

My offset,thermal,and overcurrnt light is on is that good or bad if bad how do i fix it plz help me

Posted by on

  • addeh_ Jul 17, 2008

    Hi, i have a sony XM-754hx amp.. And everything is correct, but the overcurrent light. It lights orange, have no idea why. 1 day it just broke, the subwofer died, and we tried to figure out why, and what i know is that the overcurrent doesnt light green, wich is wrong. So if anyone could help, i would be greatful. And there's nothing wrong with the fuse, and there is nothing wrong with any of the cables, i just bought new ones. Ty

×

2 Answers

  • Level 1:

    An expert who has achieved level 1.

  • Contributor
  • 1 Answer

Cheack ur wires from ur head unit to the amp un plug the positve wire frome the amp and the remote wire wait bout 30 sec and then plug it back in

Posted on May 31, 2009

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Master
  • 631 Answers

Green is good. Amber or red is bad.

Posted on Feb 21, 2008

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My off set light is on even after i unhook my rca and speakers how do i fix this


offset light is on when coonected amp, groung is good, wires fine, tried another amp and works fine , what the heck. is the amp no good

Oct 27, 2010 | Sony XM-1502SX Car Audio Amplifier

1 Answer

I have Sony XM-2150GSX amp on offset cant get it off


check for a short on one of the edges or a resistor on the edge of the board

Jul 04, 2009 | Sony XM-2150GSX Car Audio Amplifier

1 Answer

Problems with Sony XM-752EQX Car Audio Amplifier


does the amp power on? usually if you cant get any power to an amp, its a problem with the ground connection. did you shave the paint off from the area where the ground wire touches the metal of your cat?

Mar 24, 2009 | Sony XM-752EQX Car Audio Amplifier

1 Answer

Offset problem


What make/model amp is it?

Sep 24, 2008 | Sony XM-754HX Car Audio Amplifier

1 Answer

Sony xm


internal heat capacitor or even a bad connection indside amp is bad giving you a hi output load wich the amp has an auto matic sensor to send it into this offset you speak of so it does not burn up

Sep 22, 2008 | Sony XM-1502SX Car Audio Amplifier

1 Answer

Sony car stereo


When the amplifier shows an offset fault, it's generally because there is DC voltage present on the speaker terminals. The amp has shut down to protect the speakers.

Aug 14, 2008 | Sony XM-754HX Car Audio Amplifier

1 Answer

No Sound/ lights flashing on Amp


Disconnect your subs from the amp. If the lights go out then your sub is blown and is putting the amp into protect. If the lights keep flashing even with the subs disconnected than the Amp is toast.

Jul 09, 2007 | Sony XM-752EQX Car Audio Amplifier

1 Answer

CUT WIRES INTO MY AMP !!!


Here is the link to the user manual http://esupport.sony.com/US/perl/model-documents.pl?mdl=XM754HX&LOC=3 All the connections and installation wiring are well documented in english and french. Hope this helps - please ask again if you have any problem :)

Apr 11, 2007 | Sony XM-754HX Car Audio Amplifier

Not finding what you are looking for?
Car Amplifiers Logo

Related Topics:

399 people viewed this question

Ask a Question

Usually answered in minutes!

Top Sony Car Amplifiers Experts

Tygh Duval
Tygh Duval

Level 2 Expert

290 Answers

Donald DCruz
Donald DCruz

Level 3 Expert

17129 Answers

yadayada
yadayada

Level 3 Expert

60769 Answers

Are you a Sony Car Amplifier Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...