Question about Qca Spas Jewel Series Topaz Plus Hot Tub

1 Answer

I have a 2004 great lakes hot tub with a balboa controler. My hot tub heats up fine when the pump runs on high but the temp light never comes on when the pump runs in low.

Posted by on

Ad

1 Answer

  • Level 2:

    An expert who has achieved level 2 by getting 100 points

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

    Vice President:

    An expert whose answer got voted for 100 times.

  • Expert
  • 366 Answers

Check to see that the flow switch is working properly, it may not have enough flow on low speed to allow the heater to turn on. Make sure your filter/s is/are clean. If you have a pressure switch instead of a flow switch, it may need to be adjusted or replaced.

Posted on Feb 09, 2010

Ad

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya Repairman can help you resolve that issue over the phone in a minute or two.
Best thing about this new service is that you are never placed on hold and get to talk to real repair professionals here in the US.
click here to Talk to a Repairman (only for users in the US for now) and get all the help you need.
Goodluck!

Posted on Jan 02, 2017

Ad

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

My Balboa 300F hot tub will not heat up. I am not able to get it out of economy mode. What can I do?


First, balboa does not manufacture hot tubs! They make control systems for hot tubs. If you are no longer able to switch between modes, then your topside control panel buttons are dead or falling. But... Even if you are still in economy mode, spa should still heat up. Once a demand for heat is recognized, you have a "Heat Call" and heater should come on. Is the "heat on" light, illuminated? If so, water should be heating, if not heater element may be bad? A multi meter would be good here: is there proper voltage at terminals on circuit board to heater? If so, bad element! If no voltage, then heater is not necessarily bad, probably just fine, I would then look at sensors? Good luck

Feb 23, 2015 | Pool & Spa

1 Answer

F2 error code 2004


Balboa Direct has an excellent error code listing on their site.

Mar 29, 2014 | Pool & Spa

1 Answer

Balboa VL700S control panel jets 1 not working


Your problem is going to be in the circuit board in the spa control box under the skirt.
You have a bad relay.
Rod
US Parts Center

Jun 25, 2013 | Pool & Spa

1 Answer

Balboa 52502 val 5m7


have you cleaned your filter recently. Sound like there may be a low flow error in low speed
either that or the start capacitor on your pump is bad and the pump will not come on in low speed unless you first give it a boost in high speed
anytime you ask for heat with insufficient flow there will be an error message

Jun 21, 2012 | Balboa Instruments Pool & Spa

1 Answer

Hot tub keeps running all night keeping me awake. How do you shut it off? It's a Great Lakes.


If the system is the Jacuzzi 52221-05 system mentioned in the subject header, there could be a stuck relay causing the problem and you might need to get a spa technician out to assist you in repairing the problem. However...

If it is a Great Lakes system as mentioned in your message body, then there could be a programming issue allowing the filter cycle to run continuously. Provide a model number off of the Balboa control. Then we can provide you an instruction manual or reference card to assist you in resolving this problem. you can also search our online manuals at our website. You can find them online at:

BALBOA WATER GROUP INSTRUCTION MANUALS

Sep 18, 2011 | Jacuzzi Balboa R574 System for 1 2 Speed...

1 Answer

We have a Great Lakes spa with a Balboa control panel, manufactured in 1992. When you plug the spa in, it will shut down and read Sn on the topside control panel. We have replaced the high limit/temp...


Contact Balboa's Customer support department directly at 800-645-3201, follow the prompts to customer tech support (or press 0 and ask for customer support). You will need to be at the spa, control panel open and ready to read off the chip number, and you will need to be proficient with a test meter (AC voltage). The SN error is related to a bad sensor(s), but can also indicate a failed board. An incorrect sensor set will also create this problem, so confirm you used the exact or compatible replacement. If the SN code issue is no longer a problem, but the spa is still not heating, look and see if the heater led is on. If it is, you likely have some burned relays on the board, which can be replaced cheaper than replacing the board. If you need more help, email me at info@coastsideservices.com

Jun 12, 2010 | Pool & Spa

2 Answers

How to Get Hot tub off sleep mode


press temp button and then the light button in sequence.

Nov 14, 2009 | Jacuzzi Balboa R574 System for 1 2 Speed...

Not finding what you are looking for?
Qca Spas Jewel Series Topaz Plus Hot Tub Logo

1,138 people viewed this question

Ask a Question

Usually answered in minutes!

Top Qca Spas Pool & Spa Experts

Ian Kime
Ian Kime

Level 2 Expert

77 Answers

byrdhaus188

Level 1 Expert

33 Answers

Brad Brown

Level 3 Expert

16644 Answers

Are you a Qca Spas Pool and Spa Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...