Question about Canon T70 35mm SLR Camera

1 Answer

The three bars on the LCD screen just blink, whether film is in or not. I load film and the film indicator turns on, but it doesn't advance the film. When I press the button to take a picture it beeps at me repeatedly. Any ideas?

Posted by on

1 Answer

  • Level 3:

    An expert who has achieved level 3 by getting 1000 points

    Superstar:

    An expert that got 20 achievements.

    All-Star:

    An expert that got 10 achievements.

    MVP:

    An expert that got 5 achievements.

  • Master
  • 10,319 Answers

You have a short in the circuit. one of the capacitors have gave out
it will need to be torn down and checked to see which one is bad

Posted on Feb 04, 2010

1 Suggested Answer

6ya6ya
  • 2 Answers

SOURCE: I have freestanding Series 8 dishwasher. Lately during the filling cycle water hammer is occurring. How can this be resolved

Hi,
a 6ya expert can help you resolve that issue over the phone in a minute or two.
best thing about this new service is that you are never placed on hold and get to talk to real repairmen in the US.
the service is completely free and covers almost anything you can think of (from cars to computers, handyman, and even drones).
click here to download the app (for users in the US for now) and get all the help you need.
goodluck!

Posted on Jan 02, 2017

Add Your Answer

Uploading: 0%

my-video-file.mp4

Complete. Click "Add" to insert your video. Add

×

Loading...
Loading...

Related Questions:

1 Answer

The power lights flashes three times and the TV doesn't work


Three times flash to LG TVs denotes a fault with its main board. Contact any service technician. If you're sound in electronics, check this link. http://electronicshelponline.blogspot.com/ Blinking codes to many brand TVs are given in detail. Pull up older posts there, either by its left side bar, or see it in Timslide option.

Jun 23, 2013 | LG 47LG50 47 in. LCD HDTV

2 Answers

Just loaded film and cant take picture, its not advancing


You need to add a little more information about what you did exactly.
Did you pull enough leader film out? If I had to guess, I would say the film wasn't rolled far enough onto the "advancement reel" so you are not able to advance it because the camera doesn't think it has film in yet.

Nov 14, 2011 | Vivitar V3800N 35mm SLR Camera

2 Answers

I've got Nikon F65. I cannot load film. The motor which load up the film doesn't move at all. Please help!


I don't know this model but you can try this.Drop the film canister in and pull the film strip out and place on the film advance sprocket.Rotate the sprocket by hand/thumb until film is seated (1 turn). If the auto feed is working you will be OK. 2 other things ,1 of course load film in dark area, 2 check the batteries on the camera first, if they are week your film advance wont work ,Good Luck.

Jul 29, 2011 | Nikon Photography

1 Answer

My pentax k1000 works great except for when I first load the film. Every time I first load the film, the rewind knob wont rotate when I snap pictures. Everything on the inside is intact and usually I have...


I'm not sure I see a problem here. There is enough slack in the film that the first few exposures can spool out of the canister without it turning. If in doubt, close the back and then _lightly_ turn the rewind crank to take up the slack. Don't force it, just turn it until you feel resistance. Then advance the film and see whether the rewind knob turns.

Feb 28, 2011 | Pentax K1000 35mm SLR Camera

1 Answer

My Nikon N75 says error and there is a flashing circle with a dot in the middle when i look through the lens.... What does this mean?!


If the LCD panel shows "E" then the film isn't loaded properly. If the LCD panel shows "ERR" and "E" blinking, then the film is not correctly advanced. If the LCD panel shows a blinking "E" when the exposure meter is turned on, then film remains in the camera after it has been rewound. In all cases, reload film.

If it's not one of those cases, or if the problem persists, please reply to this post giving further details.

Feb 06, 2011 | Nikon N75 35mm SLR Camera

1 Answer

The film has 36 exposures and indicator shows only 32 pics taken. Film is advanced and when I look into the view finder I have a blinking M and red circle on far right side. It will not let me take a...


You may be out of film. If you used too much leader to load the film, the counter would not know to keep up so you would be off a bit. On the rewind side, check to see if there is any slack in the film, If you can turn the rewind 2 or 3 turns then it is not loading error but mechanical problems.

Oct 19, 2009 | Canon EOS-AE-1 35mm SLR Camera

1 Answer

Loading/ Unloading the Film


anniehongx,

open the film door and charge the shutter. are the drive and take up sprockets turning? if they are then the film was not loaded properly. be sure to push enough film leader into the take up spool bars.
if the spools are not turning then a gear or spring ( advance lever return lock ) is broken.
there are no new parts for the ME Super however some camera repair shops have good used parts that can be used. get an estimate first.

Mar 02, 2009 | Pentax ME Super 35mm SLR Camera

2 Answers

Error message on camera


I had the same problem, what I did was set ISO to manual,and still got the Err,but I took a shot and the film advanced and it seems to be ok now.

Mar 25, 2008 | Nikon N80 35mm SLR Camera

Not finding what you are looking for?
Canon T70 35mm SLR Camera Logo

Related Topics:

65 people viewed this question

Ask a Question

Usually answered in minutes!

Top Canon Photography Experts

kakima

Level 3 Expert

102366 Answers

old marine
old marine

Level 3 Expert

1921 Answers

David Payne
David Payne

Level 3 Expert

14161 Answers

Are you a Canon Photography Expert? Answer questions, earn points and help others

Answer questions

Manuals & User Guides

Loading...